aboutsummaryrefslogtreecommitdiff
path: root/net/pear-Net_UserAgent_Mobile/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-16 19:02:33 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-05-16 19:02:33 +0000
commit8e6e187b1678fb2922807ba2a2e0db94525ef14d (patch)
treefe47583b6774d8d82456574c67f2d66c52b4b1c5 /net/pear-Net_UserAgent_Mobile/Makefile
parented57331c6183fc33e94eabe8d5fc84519aa6af09 (diff)
downloadports-8e6e187b1678fb2922807ba2a2e0db94525ef14d.tar.gz
ports-8e6e187b1678fb2922807ba2a2e0db94525ef14d.zip
Notes
Diffstat (limited to 'net/pear-Net_UserAgent_Mobile/Makefile')
-rw-r--r--net/pear-Net_UserAgent_Mobile/Makefile24
1 files changed, 15 insertions, 9 deletions
diff --git a/net/pear-Net_UserAgent_Mobile/Makefile b/net/pear-Net_UserAgent_Mobile/Makefile
index fd9af8bc23b5..76b652e5544a 100644
--- a/net/pear-Net_UserAgent_Mobile/Makefile
+++ b/net/pear-Net_UserAgent_Mobile/Makefile
@@ -6,8 +6,9 @@
#
PORTNAME= Net_UserAgent_Mobile
-PORTVERSION= 0.29.0
+PORTVERSION= 1.0.0
CATEGORIES= net www pear
+DISTNAME= ${PORTNAME}-${PORTVERSION}RC1
MAINTAINER= smatsui@karashi.org
COMMENT= PEAR class that parses HTTP mobile user agent string
@@ -15,15 +16,20 @@ COMMENT= PEAR class that parses HTTP mobile user agent string
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_PHP= pcre
+
CATEGORY= Net/UserAgent
-FILES= Mobile.php Mobile/AirHPhone.php Mobile/Common.php \
- Mobile/Display.php Mobile/DoCoMo.php Mobile/DoCoMoDisplayMap.php \
- Mobile/EZweb.php Mobile/Vodafone.php Mobile/NonMobile.php \
- Mobile/Request.php
-TESTS= 00-compile.phpt 01-request.phpt 02-docomo.phpt \
- 03-jphone.phpt 04-ezweb.phpt 05-display.phpt \
- 06-nonmobile.phpt 07-airhphone.phpt 08-display-xmlmap.phpt \
- 09-fallback-on-nomatch.phpt DoCoMoMap.xml
+FILES= Mobile.php Mobile/Common.php \
+ Mobile/Display.php Mobile/DoCoMo.php \
+ Mobile/EZweb.php Mobile/NonMobile.php \
+ Mobile/SoftBank.php Mobile/Willcom.php \
+ Mobile/DoCoMo/ScreenInfo.php
+TESTS= AllTests.php MobileTestCase.php prepare.php \
+ Mobile/AllTests.php Mobile/DoCoMoTestCase.php \
+ Mobile/EZwebTestCase.php Mobile/NonMobileTestCase.php \
+ Mobile/SoftBankTestCase.php \
+ Mobile/WillcomTestCase.php \
+ Mobile/DoCoMoTestCase/docomo-screen.xml
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"