aboutsummaryrefslogtreecommitdiff
path: root/net/pear-Net_UserAgent_Mobile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-06-06 19:49:42 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-06-06 19:49:42 +0000
commit3a82a8783c45e739ca6fc634ccd75a0afd07a245 (patch)
treed0befcb294bdc257071933566a272e2555d3ea4e /net/pear-Net_UserAgent_Mobile
parent18899c377d4bdf3eddf14ea4a9068c27c665de36 (diff)
downloadports-3a82a8783c45e739ca6fc634ccd75a0afd07a245.tar.gz
ports-3a82a8783c45e739ca6fc634ccd75a0afd07a245.zip
Notes
Diffstat (limited to 'net/pear-Net_UserAgent_Mobile')
-rw-r--r--net/pear-Net_UserAgent_Mobile/Makefile30
-rw-r--r--net/pear-Net_UserAgent_Mobile/distinfo2
-rw-r--r--net/pear-Net_UserAgent_Mobile/pkg-descr8
3 files changed, 40 insertions, 0 deletions
diff --git a/net/pear-Net_UserAgent_Mobile/Makefile b/net/pear-Net_UserAgent_Mobile/Makefile
new file mode 100644
index 000000000000..4cf6516a7995
--- /dev/null
+++ b/net/pear-Net_UserAgent_Mobile/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: pear-Net_UserAgent_Mobile
+# Date created: 06 June 2005
+# Whom: Shinsuke Matsui (<smatsui@karashi.org>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net_UserAgent_Mobile
+PORTVERSION= 0.23.0
+CATEGORIES= net www pear
+
+MAINTAINER= smatsui@karashi.org
+COMMENT= PEAR class that parses HTTP mobile user agent string
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Net/UserAgent
+FILES= Mobile.php Mobile/AirHPhone.php Mobile/Common.php \
+ Mobile/Display.php Mobile/DoCoMo.php Mobile/DoCoMoDisplayMap.php \
+ Mobile/EZweb.php Mobile/Vodafone.php Mobile/NonMobile.php \
+ Mobile/Request.php
+TESTS= 00-compile.phpt 01-request.phpt 02-docomo.phpt \
+ 03-jphone.phpt 04-ezweb.phpt 05-display.phpt \
+ 06-nonmobile.phpt 07-airhphone.phpt 08-display-xmlmap.phpt \
+ DoCoMoMap.xml
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/net/pear-Net_UserAgent_Mobile/distinfo b/net/pear-Net_UserAgent_Mobile/distinfo
new file mode 100644
index 000000000000..0996b583b69c
--- /dev/null
+++ b/net/pear-Net_UserAgent_Mobile/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Net_UserAgent_Mobile-0.23.0.tgz) = 10620f2ab7c847579341365ee95aa8a7
+SIZE (PEAR/Net_UserAgent_Mobile-0.23.0.tgz) = 28278
diff --git a/net/pear-Net_UserAgent_Mobile/pkg-descr b/net/pear-Net_UserAgent_Mobile/pkg-descr
new file mode 100644
index 000000000000..8ee993c31fdd
--- /dev/null
+++ b/net/pear-Net_UserAgent_Mobile/pkg-descr
@@ -0,0 +1,8 @@
+Net_UserAgent_Mobile parses HTTP_USER_AGENT strings of (mainly Japanese)
+mobile HTTP user agents. It'll be useful in page dispatching by user agents.
+This package was ported from Perl's HTTP::MobileAgent.
+See http://search.cpan.org/search?mode=module&query=HTTP-MobileAgent
+The author of the HTTP::MobileAgent module is
+Tatsuhiko Miyagawa <miyagawa@bulknews.net>
+
+WWW: http://pear.php.net/package/Net_UserAgent_Mobile/