aboutsummaryrefslogtreecommitdiff
path: root/net/pear-SOAP/Makefile
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2007-07-31 10:21:26 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2007-07-31 10:21:26 +0000
commit47e3fba32aef3a712a174ecf142d9cf3a31ebc2e (patch)
treefddc8bf85226ce7ac9ef780e2ecb445bbe17d395 /net/pear-SOAP/Makefile
parent7eda652de0147c464a41690bcd51019023a9cd53 (diff)
downloadports-47e3fba32aef3a712a174ecf142d9cf3a31ebc2e.tar.gz
ports-47e3fba32aef3a712a174ecf142d9cf3a31ebc2e.zip
Notes
Diffstat (limited to 'net/pear-SOAP/Makefile')
-rw-r--r--net/pear-SOAP/Makefile23
1 files changed, 21 insertions, 2 deletions
diff --git a/net/pear-SOAP/Makefile b/net/pear-SOAP/Makefile
index 5a05242f7c65..fa28ff2e12b2 100644
--- a/net/pear-SOAP/Makefile
+++ b/net/pear-SOAP/Makefile
@@ -6,15 +6,21 @@
#
PORTNAME= SOAP
-PORTVERSION= 0.10.1
+PORTVERSION= 0.11.0
CATEGORIES= net www pear
MAINTAINER= bg1tpt@gmail.com
COMMENT= PEAR SOAP Client/Server for PHP
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
+ ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
RUN_DEPENDS= ${BUILD_DEPENDS}
+LATEST_LINK= pear-SOAP
+OPTIONS= PEAR_MAIL "PEAR::Mail support" off \
+ PEAR_MAIL_MIME "PEAR::Mail::Mime support" off \
+ PEAR_NET_DIME "PEAR::Net::DIME support" off
+
CATEGORY= SOAP
FILES= Base.php Client.php Disco.php Fault.php Parser.php \
Server.php Transport.php Value.php WSDL.php \
@@ -33,5 +39,18 @@ EXAMPLES= attachment.php client.php com_client.php \
_EXAMPLESDIR= example
.include <bsd.port.pre.mk>
+
+.if defined(WITH_PEAR_MAIL)
+BUILD_DEPENDS+= ${PEARDIR}/Mail.php:${PORTSDIR}/mail/pear-Mail
+.endif
+
+.if defined(WITH_PEAR_MAIL_MIME)
+BUILD_DEPENDS+= ${PEARDIR}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime
+.endif
+
+.if defined(WITH_PEAR_NET_DIME)
+BUILD_DEPENDS+= ${PEARDIR}/DIME.php:${PORTSDIR}/net/pear-Net_DIME
+.endif
+
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>