aboutsummaryrefslogtreecommitdiff
path: root/net/pen
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2006-09-24 14:34:36 +0000
committerClement Laforet <clement@FreeBSD.org>2006-09-24 14:34:36 +0000
commit3c00a1855ced51c6fc42ec7c28afe10b80f5e536 (patch)
tree21aef6291842557104364b77a5bf9ae921c283b0 /net/pen
parent290ddfc9ebfce9547af1b10f5011ee67a63c0f13 (diff)
downloadports-3c00a1855ced51c6fc42ec7c28afe10b80f5e536.tar.gz
ports-3c00a1855ced51c6fc42ec7c28afe10b80f5e536.zip
Notes
Diffstat (limited to 'net/pen')
-rw-r--r--net/pen/Makefile4
-rw-r--r--net/pen/distinfo6
-rw-r--r--net/pen/files/pen.sh.in28
3 files changed, 33 insertions, 5 deletions
diff --git a/net/pen/Makefile b/net/pen/Makefile
index a4c32af4519b..549412aee079 100644
--- a/net/pen/Makefile
+++ b/net/pen/Makefile
@@ -1,4 +1,3 @@
-\# ex:ts=8
# New ports collection makefile for: pen
# Date created: Nov 13, 2001
# Whom: ijliao
@@ -7,7 +6,7 @@
#
PORTNAME= pen
-PORTVERSION= 0.17.0
+PORTVERSION= 0.17.1
CATEGORIES= net
MASTER_SITES= ftp://siag.nu/pub/pen/ \
http://siag.nu/pub/pen/
@@ -17,6 +16,7 @@ COMMENT= A load balancer for simple tcp based protocols
GNU_CONFIGURE= yes
USE_OPENSSL= yes
+USE_RC_SUBR= pen.sh
CONFIGURE_ARGS= --with-daemon --with-docdir=${DOCSDIR} \
--with-ssl=${OPENSSLBASE} --with-kqueue
diff --git a/net/pen/distinfo b/net/pen/distinfo
index ff3d7e6bc148..f18d01a12b2e 100644
--- a/net/pen/distinfo
+++ b/net/pen/distinfo
@@ -1,3 +1,3 @@
-MD5 (pen-0.17.0.tar.gz) = d144ebf5aa8b25d6f685ec5ceff6f57a
-SHA256 (pen-0.17.0.tar.gz) = c4d1e5efe324b94e4152fc7a72fd3a946d97de76f8d54d89a5b83dc44732ce24
-SIZE (pen-0.17.0.tar.gz) = 116945
+MD5 (pen-0.17.1.tar.gz) = 62548155d3bf42aea05b32227e132331
+SHA256 (pen-0.17.1.tar.gz) = 13e070e4e03d9141530bbf9fa071d2ce3f04b0324349757c8842e073eef85556
+SIZE (pen-0.17.1.tar.gz) = 117009
diff --git a/net/pen/files/pen.sh.in b/net/pen/files/pen.sh.in
new file mode 100644
index 000000000000..f99fc50be72d
--- /dev/null
+++ b/net/pen/files/pen.sh.in
@@ -0,0 +1,28 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: pen
+# REQUIRE: NETWORKING SERVERS
+# BEFORE: DAEMON
+# KEYWORD: shutdown
+
+#
+# Add the following line to /etc/rc.conf to enable pen:
+#
+# pen_enable="YES"
+#
+
+. %%RC_SUBR%%
+
+name=pen
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/bin/pen
+
+pen_enable=${pen_enable:-"NO"}
+pen_flags=${pen_flags:-""}
+
+load_rc_config $name
+run_rc_command "$1"