aboutsummaryrefslogtreecommitdiff
path: root/net/php56-soap
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2014-09-04 14:24:25 +0000
committerAlex Dupre <ale@FreeBSD.org>2014-09-04 14:24:25 +0000
commitf23aed7bde4b7e82cbb2943a38f6f60f51038567 (patch)
tree65444edf752ebaf49e944ea49c7e7dad35e1de9a /net/php56-soap
parentb3f383ce848e6d547e583f3f4ce764dd3c400cb6 (diff)
Notes
Diffstat (limited to 'net/php56-soap')
-rw-r--r--net/php56-soap/Makefile10
-rw-r--r--net/php56-soap/files/patch-soap.c56
2 files changed, 66 insertions, 0 deletions
diff --git a/net/php56-soap/Makefile b/net/php56-soap/Makefile
new file mode 100644
index 000000000000..2f9c1925e81d
--- /dev/null
+++ b/net/php56-soap/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= net
+
+MASTERDIR= ${.CURDIR}/../../lang/php56
+
+PKGNAMESUFFIX= -soap
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/php56-soap/files/patch-soap.c b/net/php56-soap/files/patch-soap.c
new file mode 100644
index 000000000000..b81d1b8cac02
--- /dev/null
+++ b/net/php56-soap/files/patch-soap.c
@@ -0,0 +1,56 @@
+--- soap.c.orig 2012-03-02 15:46:04.000000000 +0100
++++ soap.c 2012-03-02 15:45:38.000000000 +0100
+@@ -23,7 +23,7 @@
+ #include "config.h"
+ #endif
+ #include "php_soap.h"
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ #include "ext/session/php_session.h"
+ #endif
+ #include "zend_exceptions.h"
+@@ -1639,7 +1639,7 @@
+ soap_obj = service->soap_object;
+ function_table = &((Z_OBJCE_P(soap_obj))->function_table);
+ } else if (service->type == SOAP_CLASS) {
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ /* If persistent then set soap_obj from from the previous created session (if available) */
+ if (service->soap_class.persistance == SOAP_PERSISTENCE_SESSION) {
+ zval **tmp_soap;
+@@ -1722,7 +1722,7 @@
+ }
+ efree(class_name);
+ }
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ /* If session then update session hash with new object */
+ if (service->soap_class.persistance == SOAP_PERSISTENCE_SESSION) {
+ zval **tmp_soap_pp;
+@@ -1820,7 +1820,7 @@
+ if (service->type == SOAP_CLASS || service->type == SOAP_OBJECT) {
+ call_status = call_user_function(NULL, &soap_obj, &function_name, retval, num_params, params TSRMLS_CC);
+ if (service->type == SOAP_CLASS) {
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ if (service->soap_class.persistance != SOAP_PERSISTENCE_SESSION) {
+ zval_ptr_dtor(&soap_obj);
+ soap_obj = NULL;
+@@ -1845,7 +1845,7 @@
+ soap_server_fault_ex(function, EG(exception), NULL TSRMLS_CC);
+ }
+ if (service->type == SOAP_CLASS) {
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ if (soap_obj && service->soap_class.persistance != SOAP_PERSISTENCE_SESSION) {
+ #else
+ if (soap_obj) {
+@@ -1887,7 +1887,7 @@
+ soap_server_fault_ex(function, EG(exception), NULL TSRMLS_CC);
+ }
+ if (service->type == SOAP_CLASS) {
+-#if HAVE_PHP_SESSION && !defined(COMPILE_DL_SESSION)
++#if HAVE_PHP_SESSION
+ if (soap_obj && service->soap_class.persistance != SOAP_PERSISTENCE_SESSION) {
+ #else
+ if (soap_obj) {