aboutsummaryrefslogtreecommitdiff
path: root/net/phpldapadmin
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2018-04-02 20:11:58 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2018-04-02 20:11:58 +0000
commitf8906302f6abe559b4e461af237d6aefa4407457 (patch)
tree50e9bd11992d55335a3d1b5c6f80bbbc3e85138b /net/phpldapadmin
parentb02281a107f8af68f3f7c3e279729dccd73de795 (diff)
downloadports-f8906302f6abe559b4e461af237d6aefa4407457.tar.gz
ports-f8906302f6abe559b4e461af237d6aefa4407457.zip
Notes
Diffstat (limited to 'net/phpldapadmin')
-rw-r--r--net/phpldapadmin/Makefile6
-rw-r--r--net/phpldapadmin/files/patch-config__config.php.example8
-rw-r--r--net/phpldapadmin/files/patch-lib__PageRender.php10
-rw-r--r--net/phpldapadmin/files/patch-lib__TemplateRender.php6
-rw-r--r--net/phpldapadmin/files/patch-lib__ds_ldap.php6
-rw-r--r--net/phpldapadmin/files/patch-lib__ds_ldap_pla.php6
-rw-r--r--net/phpldapadmin/files/patch-lib__functions.php46
-rw-r--r--net/phpldapadmin/files/patch-tools__po__Makefile4
8 files changed, 61 insertions, 31 deletions
diff --git a/net/phpldapadmin/Makefile b/net/phpldapadmin/Makefile
index 02c129549f7d..b3ebc1f4fdd2 100644
--- a/net/phpldapadmin/Makefile
+++ b/net/phpldapadmin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= phpldapadmin
PORTVERSION= 1.2.3
-PORTREVISION= 7
+PORTREVISION= 8
PORTEPOCH= 1
CATEGORIES= net www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-php5/${PORTVERSION}
@@ -14,15 +14,13 @@ COMMENT= PHP application to administer LDAP over the web
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cpe tar:tgz
+USES= cpe php:web tar:tgz
CPE_VENDOR= deon_george
NO_ARCH= yes
NO_BUILD= yes
USE_PHP= gettext ldap openssl pcre session xml iconv hash
-WANT_PHP_WEB= yes
-
GROUPS?= ${WWWGRP}
CFGDIR= config
CFGFILE= config.php
diff --git a/net/phpldapadmin/files/patch-config__config.php.example b/net/phpldapadmin/files/patch-config__config.php.example
index a3a6025b29b8..4a74b855ad7e 100644
--- a/net/phpldapadmin/files/patch-config__config.php.example
+++ b/net/phpldapadmin/files/patch-config__config.php.example
@@ -1,6 +1,6 @@
---- ./config/config.php.example.orig 2014-05-03 08:00:05.933577117 +0100
-+++ ./config/config.php.example 2014-05-03 08:00:38.259564444 +0100
-@@ -379,7 +379,7 @@
+--- config/config.php.example.orig 2012-10-01 06:54:14 UTC
++++ config/config.php.example
+@@ -379,7 +379,7 @@ $servers->setValue('server','name','My L
/* Default password hashing algorithm. One of md5, ssha, sha, md5crpyt, smd5,
blowfish, crypt or leave blank for now default algorithm. */
@@ -9,7 +9,7 @@
/* If you specified 'cookie' or 'session' as the auth_type above, you can
optionally specify here an attribute to use when logging in. If you enter
-@@ -546,7 +546,7 @@
+@@ -546,7 +546,7 @@ $servers->setValue('sasl','authz_id_rege
$servers->setValue('sasl','authz_id_replacement','$1');
$servers->setValue('sasl','props',null);
diff --git a/net/phpldapadmin/files/patch-lib__PageRender.php b/net/phpldapadmin/files/patch-lib__PageRender.php
index 065f5875b479..b27154aee037 100644
--- a/net/phpldapadmin/files/patch-lib__PageRender.php
+++ b/net/phpldapadmin/files/patch-lib__PageRender.php
@@ -1,6 +1,6 @@
---- ./lib/PageRender.php.orig 2012-10-01 07:54:14.000000000 +0100
-+++ ./lib/PageRender.php 2014-05-03 07:57:44.744575309 +0100
-@@ -287,7 +287,7 @@
+--- lib/PageRender.php.orig 2012-10-01 06:54:14 UTC
++++ lib/PageRender.php
+@@ -287,7 +287,7 @@ class PageRender extends Visitor {
break;
default:
@@ -9,7 +9,7 @@
}
$vals = array_unique($vals);
-@@ -957,7 +957,7 @@
+@@ -957,7 +957,7 @@ class PageRender extends Visitor {
if (trim($val))
$enc_type = get_enc_type($val);
else
@@ -18,7 +18,7 @@
$obfuscate_password = obfuscate_password_display($enc_type);
-@@ -982,7 +982,7 @@
+@@ -982,7 +982,7 @@ class PageRender extends Visitor {
if (trim($val))
$enc_type = get_enc_type($val);
else
diff --git a/net/phpldapadmin/files/patch-lib__TemplateRender.php b/net/phpldapadmin/files/patch-lib__TemplateRender.php
index 610c5dbcfd3a..5dc8a263f858 100644
--- a/net/phpldapadmin/files/patch-lib__TemplateRender.php
+++ b/net/phpldapadmin/files/patch-lib__TemplateRender.php
@@ -1,6 +1,6 @@
---- ./lib/TemplateRender.php.orig 2014-05-03 07:58:18.076584893 +0100
-+++ ./lib/TemplateRender.php 2014-05-03 07:59:18.859574787 +0100
-@@ -2466,7 +2466,7 @@
+--- lib/TemplateRender.php.orig 2012-10-01 06:54:14 UTC
++++ lib/TemplateRender.php
+@@ -2466,7 +2466,7 @@ function deleteAttribute(attrName,friend
if ($val = $attribute->getValue($i))
$default = get_enc_type($val);
else
diff --git a/net/phpldapadmin/files/patch-lib__ds_ldap.php b/net/phpldapadmin/files/patch-lib__ds_ldap.php
index b811aee6d4dc..c7debfa14eab 100644
--- a/net/phpldapadmin/files/patch-lib__ds_ldap.php
+++ b/net/phpldapadmin/files/patch-lib__ds_ldap.php
@@ -1,6 +1,6 @@
---- ./lib/ds_ldap.php.orig 2012-10-01 07:54:14.000000000 +0100
-+++ ./lib/ds_ldap.php 2014-05-03 07:57:44.746572911 +0100
-@@ -1116,13 +1116,24 @@
+--- lib/ds_ldap.php.orig 2012-10-01 06:54:14 UTC
++++ lib/ds_ldap.php
+@@ -1116,13 +1116,24 @@ class ldap extends DS {
if (is_array($dn)) {
$a = array();
diff --git a/net/phpldapadmin/files/patch-lib__ds_ldap_pla.php b/net/phpldapadmin/files/patch-lib__ds_ldap_pla.php
index 775fa46c31d1..de5f2b23f24e 100644
--- a/net/phpldapadmin/files/patch-lib__ds_ldap_pla.php
+++ b/net/phpldapadmin/files/patch-lib__ds_ldap_pla.php
@@ -1,6 +1,6 @@
---- ./lib/ds_ldap_pla.php.orig 2012-10-01 07:54:14.000000000 +0100
-+++ ./lib/ds_ldap_pla.php 2014-05-03 07:57:44.748572937 +0100
-@@ -16,7 +16,7 @@
+--- lib/ds_ldap_pla.php.orig 2012-10-01 06:54:14 UTC
++++ lib/ds_ldap_pla.php
+@@ -16,7 +16,7 @@ class ldap_pla extends ldap {
function __construct($index) {
parent::__construct($index);
diff --git a/net/phpldapadmin/files/patch-lib__functions.php b/net/phpldapadmin/files/patch-lib__functions.php
index bf7572fa379b..2b607e86f827 100644
--- a/net/phpldapadmin/files/patch-lib__functions.php
+++ b/net/phpldapadmin/files/patch-lib__functions.php
@@ -1,6 +1,38 @@
---- ./lib/functions.php.orig 2012-10-01 07:54:14.000000000 +0100
-+++ ./lib/functions.php 2014-05-03 07:57:44.751570981 +0100
-@@ -2127,7 +2127,7 @@
+--- lib/functions.php.orig 2012-10-01 06:54:14 UTC
++++ lib/functions.php
+@@ -745,6 +745,7 @@ function blowfish_encrypt($data,$secret=
+ if (! trim($secret))
+ return $data;
+
++/*
+ if (function_exists('mcrypt_module_open') && ! empty($data)) {
+ $td = mcrypt_module_open(MCRYPT_BLOWFISH,'',MCRYPT_MODE_ECB,'');
+ $iv = mcrypt_create_iv(mcrypt_enc_get_iv_size($td),MCRYPT_DEV_URANDOM);
+@@ -754,6 +755,7 @@ function blowfish_encrypt($data,$secret=
+
+ return $encrypted_data;
+ }
++*/
+
+ if (file_exists(LIBDIR.'blowfish.php'))
+ require_once LIBDIR.'blowfish.php';
+@@ -801,6 +803,7 @@ function blowfish_decrypt($encdata,$secr
+ if (! trim($secret))
+ return $encdata;
+
++/*
+ if (function_exists('mcrypt_module_open') && ! empty($encdata)) {
+ $td = mcrypt_module_open(MCRYPT_BLOWFISH,'',MCRYPT_MODE_ECB,'');
+ $iv = mcrypt_create_iv(mcrypt_enc_get_iv_size($td),MCRYPT_DEV_URANDOM);
+@@ -810,6 +813,7 @@ function blowfish_decrypt($encdata,$secr
+
+ return $decrypted_data;
+ }
++*/
+
+ if (file_exists(LIBDIR.'blowfish.php'))
+ require_once LIBDIR.'blowfish.php';
+@@ -2127,7 +2131,7 @@ function password_types() {
* crypt, ext_des, md5crypt, blowfish, md5, sha, smd5, ssha, sha512, or clear.
* @return string The hashed password.
*/
@@ -9,7 +41,7 @@
if (DEBUG_ENABLED && (($fargs=func_get_args())||$fargs='NOARGS'))
debug_log('Entered (%%)',1,0,__FILE__,__LINE__,__METHOD__,$fargs);
-@@ -2318,7 +2318,7 @@
+@@ -2318,7 +2322,7 @@ function password_check($cryptedpassword
# SHA crypted passwords
case 'sha':
@@ -18,7 +50,7 @@
return true;
else
return false;
-@@ -2327,7 +2327,7 @@
+@@ -2327,7 +2331,7 @@ function password_check($cryptedpassword
# MD5 crypted passwords
case 'md5':
@@ -27,7 +59,7 @@
return true;
else
return false;
-@@ -2392,7 +2392,7 @@
+@@ -2392,7 +2396,7 @@ function password_check($cryptedpassword
# SHA512 crypted passwords
case 'sha512':
@@ -36,7 +68,7 @@
return true;
else
return false;
-@@ -2564,13 +2564,24 @@
+@@ -2564,13 +2568,24 @@ function dn_unescape($dn) {
if (is_array($dn)) {
$a = array();
diff --git a/net/phpldapadmin/files/patch-tools__po__Makefile b/net/phpldapadmin/files/patch-tools__po__Makefile
index fde9a98d085d..efdf4d97aa13 100644
--- a/net/phpldapadmin/files/patch-tools__po__Makefile
+++ b/net/phpldapadmin/files/patch-tools__po__Makefile
@@ -1,5 +1,5 @@
---- ./tools/po/Makefile.orig 2012-10-01 07:54:14.000000000 +0100
-+++ ./tools/po/Makefile 2014-05-03 07:57:44.752575636 +0100
+--- tools/po/Makefile.orig 2012-10-01 06:54:14 UTC
++++ tools/po/Makefile
@@ -1,4 +1,3 @@
-#!/bin/bash
#