aboutsummaryrefslogtreecommitdiff
path: root/net/pim6-tools
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2015-09-07 19:23:26 +0000
committerHiroki Sato <hrs@FreeBSD.org>2015-09-07 19:23:26 +0000
commit3419c789d41e43ce0f20fc4ff1e570b2ae60696b (patch)
tree52f8c2fd4d4da9321a533c1d5925c3f4040a6e48 /net/pim6-tools
parente540880e400d397c1419fd5512823c5cdcae67da (diff)
downloadports-3419c789d41e43ce0f20fc4ff1e570b2ae60696b.tar.gz
ports-3419c789d41e43ce0f20fc4ff1e570b2ae60696b.zip
Notes
Diffstat (limited to 'net/pim6-tools')
-rw-r--r--net/pim6-tools/Makefile23
-rw-r--r--net/pim6-tools/distinfo2
-rw-r--r--net/pim6-tools/files/patch-configure.in31
-rw-r--r--net/pim6-tools/files/patch-mfc-Makefile.am29
-rw-r--r--net/pim6-tools/files/patch-pim6sd-Makefile.am17
-rw-r--r--net/pim6-tools/pkg-descr16
-rw-r--r--net/pim6-tools/pkg-plist13
7 files changed, 131 insertions, 0 deletions
diff --git a/net/pim6-tools/Makefile b/net/pim6-tools/Makefile
new file mode 100644
index 000000000000..91c3b476a87b
--- /dev/null
+++ b/net/pim6-tools/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= pim6
+PORTVERSION= 20061214
+CATEGORIES= net ipv6
+MASTER_SITES= SF/mcast-tools
+PKGNAMESUFFIX= -tools
+DISTNAME= mcast-tools-${PORTVERSION}
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= IPv6 multicast tools
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= autoreconf
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= YACC=${YACC}
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/mfc/mfc.conf.sample ${STAGEDIR}${PREFIX}/etc
+
+.include <bsd.port.mk>
diff --git a/net/pim6-tools/distinfo b/net/pim6-tools/distinfo
new file mode 100644
index 000000000000..2ea786486bdf
--- /dev/null
+++ b/net/pim6-tools/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mcast-tools-20061214.tar.gz) = a34a8290983023df843874fa52386ebef79ebccb4b8155139212979326ca14f4
+SIZE (mcast-tools-20061214.tar.gz) = 395708
diff --git a/net/pim6-tools/files/patch-configure.in b/net/pim6-tools/files/patch-configure.in
new file mode 100644
index 000000000000..8a7963c64c81
--- /dev/null
+++ b/net/pim6-tools/files/patch-configure.in
@@ -0,0 +1,31 @@
+--- configure.in.orig 2006-06-24 08:53:46 UTC
++++ configure.in
+@@ -5,7 +5,7 @@ AC_PREREQ(2.59)
+ AC_INIT(README)
+ AM_CONFIG_HEADER(include/config.h)
+ AM_INIT_AUTOMAKE(mcast-tools, 20050926)
+-SUBDIRS="mcastread mcastsend mfc mtrace6 pim6dd pim6sd pmsft"
++SUBDIRS="mcastread mcastsend mfc mtrace6 pim6sd pmsft"
+ AC_SUBST(SUBDIRS)
+
+ # Checks for programs.
+@@ -145,16 +145,16 @@ main ()
+ exit (1);
+ exit (0);
+ }],
+- [AC_DEFINE(HAVE_ROUTING_SOCKETS)
++ [AC_DEFINE([HAVE_ROUTING_SOCKETS],[1],[foo])
+ UK_METHOD=routesock.o
+ AC_MSG_RESULT(routing socket)],
+- [AC_DEFINE(HAVE_NETLINK)
++ [AC_DEFINE([HAVE_NETLINK],[1],[foo])
+ UK_METHOD=netlink.o
+ AC_MSG_RESULT(netlink)])
+ AC_SUBST(UK_METHOD)
+
+ dnl Checks for RFC3542
+-AC_CHECK_LIB([c], [inet6_opt_init], [AC_DEFINE(HAVE_RFC3542)], )
++AC_CHECK_LIB([c], [inet6_opt_init], [AC_DEFINE([HAVE_RFC3542],[1],[foo])], )
+
+ AC_CONFIG_FILES([Makefile
+ mcastread/Makefile
diff --git a/net/pim6-tools/files/patch-mfc-Makefile.am b/net/pim6-tools/files/patch-mfc-Makefile.am
new file mode 100644
index 000000000000..d852777662a6
--- /dev/null
+++ b/net/pim6-tools/files/patch-mfc-Makefile.am
@@ -0,0 +1,29 @@
+--- mfc/Makefile.am.orig 2005-12-11 05:15:10 UTC
++++ mfc/Makefile.am
+@@ -9,15 +9,19 @@ DISTCLEANFILES = cftoken.c cfparse.c cfp
+
+ # Config file parser (this is necessary because not all yacc generate y.tab.h)
+ cftoken.o: cftoken.c cfparse.h
+- $(COMPILE) -c -o $@ $<
++ $(COMPILE) -c -o $@ cftoken.c
+
+ cfparse.o: cfparse.c
+- $(COMPILE) -c -o $@ $<
++ $(COMPILE) -c -o $@ $?
+
+ cftoken.c: cftoken.l
+- $(LEX) -ocftoken.c $<
++ $(LEX) -o$@ $?
+
+-cfparse.h cfparse.c: cfparse.y
+- $(YACC) -d $< && \
+- mv y.tab.c cfparse.c && \
+- mv y.tab.h cfparse.h
++y.tab.h y.tab.c: cfparse.y
++ $(YACC) -d $?
++
++cfparse.h: y.tab.h
++ mv y.tab.h $@
++
++cfparse.c: y.tab.c
++ mv y.tab.c $@
diff --git a/net/pim6-tools/files/patch-pim6sd-Makefile.am b/net/pim6-tools/files/patch-pim6sd-Makefile.am
new file mode 100644
index 000000000000..6f3e1917a636
--- /dev/null
+++ b/net/pim6-tools/files/patch-pim6sd-Makefile.am
@@ -0,0 +1,17 @@
+--- pim6sd/Makefile.am.orig 2005-12-11 05:15:12 UTC
++++ pim6sd/Makefile.am
+@@ -1,13 +1,8 @@
+ SUBDIRS=.
+-sbin_PROGRAMS= pim6sd
+ sbin_SCRIPTS= pim6stat
+-pim6sd_SOURCES= mld6.c mld6_proto.c mld6v2.c mld6v2_proto.c inet6.c kern.c main.c config.c debug.c vers.c callout.c route.c vif.c timer.c mrt.c pim6.c pim6_proto.c rp.c crc.c trace.c cfparse.y cftoken.l routesock.c netlink.c
+ man1_MANS=pim6stat.1
+-man5_MANS=pim6sd.conf.5
+-man8_MANS=pim6sd.8
+ pim6sd_LIBS=@LIBS@ @LEXLIBS@
+-noinst_HEADERS=callout.h cfparse-defs.h cfparse.h config.h crc.h debug.h defs.h inet6.h kern.h mld6.h mld6_proto.h mld6v2.h mld6v2_proto.h mrt.h pathnames.h pim6.h pim6_proto.h pimd.h route.h routesock.h rp.h timer.h trace.h var.h vif.h vmbuf.h mroute6.h
+-EXTRA_DIST = ${man1_MANS} ${man5_MANS} ${man8_MANS} pim6sd.conf.sample ssm.conf.sample pim6stat BUGS.TODO BUGS.V6 LICENSE.mrouted LICENSE.pim6sd LICENSE.pimd README README.SSM README.first
++EXTRA_DIST = pim6stat
+ DISTCLEANFILES = cftoken.c cfparse.c cfparse.h
+
+ # Config file parser (this is necessary because not all yacc generate y.tab.h)
diff --git a/net/pim6-tools/pkg-descr b/net/pim6-tools/pkg-descr
new file mode 100644
index 000000000000..172893891f0c
--- /dev/null
+++ b/net/pim6-tools/pkg-descr
@@ -0,0 +1,16 @@
+Tools for IPv6 multicast routing including:
+
+ - mcastread
+ an IPv6 multicast receiver
+ - mcastsend
+ an IPv6 multicast sender
+ - mfc
+ an IPv6 multicast routing daemon, which only supports static
+ multicast routing.
+ - pmsft
+ a test program for Multicast Source Filter (MSF) using APIs
+ specified in Socket Interface Extention for MSF (RFC3678).
+ (on a non-IGMPv3/MLDv2-aware kernel, only join/leave
+ operation is supported)
+
+WWW: http://mcast-tools.sourceforge.net/
diff --git a/net/pim6-tools/pkg-plist b/net/pim6-tools/pkg-plist
new file mode 100644
index 000000000000..db668da7ce79
--- /dev/null
+++ b/net/pim6-tools/pkg-plist
@@ -0,0 +1,13 @@
+@sample etc/mfc.conf.sample
+bin/mtrace6
+bin/mcastread
+bin/mcastsend
+bin/pmsft
+sbin/mfc
+sbin/pim6stat
+man/man1/mcastread.1.gz
+man/man1/mcastsend.1.gz
+man/man1/pim6stat.1.gz
+man/man1/pmsft.1.gz
+man/man8/mfc.8.gz
+man/man8/mtrace6.8.gz