aboutsummaryrefslogtreecommitdiff
path: root/net/pimd
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-02-06 12:52:52 +0000
committerJohn Marino <marino@FreeBSD.org>2015-02-06 12:52:52 +0000
commitf3609d50e67444e470b783db9e83f23a3501c1d4 (patch)
tree56fb91d8b107a44769ac35c9a553c5510a5203d6 /net/pimd
parent835267acf605234608afa18b0e866fda5fe4e002 (diff)
downloadports-f3609d50e67444e470b783db9e83f23a3501c1d4.tar.gz
ports-f3609d50e67444e470b783db9e83f23a3501c1d4.zip
Notes
Diffstat (limited to 'net/pimd')
-rw-r--r--net/pimd/Makefile30
-rw-r--r--net/pimd/distinfo2
-rw-r--r--net/pimd/files/pimd.in26
-rw-r--r--net/pimd/pkg-descr4
-rw-r--r--net/pimd/pkg-plist4
5 files changed, 66 insertions, 0 deletions
diff --git a/net/pimd/Makefile b/net/pimd/Makefile
new file mode 100644
index 000000000000..209ce2d924bb
--- /dev/null
+++ b/net/pimd/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= pimd
+PORTVERSION= 2.2.0
+CATEGORIES= net
+
+MAINTAINER= olivier@cochard.me
+COMMENT= Lightweight stand-alone PIM-SM v2 multicast routing daemon
+
+LICENSE= BSD3CLAUSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= troglobit
+GH_COMMIT= d8bd641
+
+USES= tar:bzip2
+HAS_CONFIGURE= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|/etc/|${PREFIX}/etc/|g' ${WRKSRC}/pathnames.h
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pimd ${STAGEDIR}${PREFIX}/sbin/
+ ${INSTALL_DATA} ${WRKSRC}/pimd.conf \
+ ${STAGEDIR}${PREFIX}/etc/pimd.conf.sample
+ ${INSTALL_SCRIPT} ${FILESDIR}/pimd.in \
+ ${STAGEDIR}${PREFIX}/etc/rc.d/pimd
+ ${INSTALL_MAN} ${WRKSRC}/pimd.8 ${STAGEDIR}${PREFIX}/man/man8/
+
+.include <bsd.port.mk>
diff --git a/net/pimd/distinfo b/net/pimd/distinfo
new file mode 100644
index 000000000000..d6c12ca2670a
--- /dev/null
+++ b/net/pimd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pimd-2.2.0.tar.bz2) = d57b10bad740bcb1ca5a7f542b3d8b29455e0ed6b40a8881e4d8f6a431921bd9
+SIZE (pimd-2.2.0.tar.bz2) = 223065
diff --git a/net/pimd/files/pimd.in b/net/pimd/files/pimd.in
new file mode 100644
index 000000000000..80c04ebc3a1e
--- /dev/null
+++ b/net/pimd/files/pimd.in
@@ -0,0 +1,26 @@
+#!/bin/sh
+#
+# PROVIDE: pimd
+# REQUIRE: netif routing
+# KEYWORD: nojail
+
+#
+# Add the following to /etc/rc.conf[.local] to enable this service
+#
+# pimd_enable="YES"
+#
+
+. /etc/rc.subr
+
+pimd_enable=${pimd_enable-"NO"}
+
+name="pimd"
+rcvar=${name}_enable
+
+command="/usr/local/sbin/${name}"
+
+extra_commands=reload
+
+load_rc_config $name
+run_rc_command "$1"
+
diff --git a/net/pimd/pkg-descr b/net/pimd/pkg-descr
new file mode 100644
index 000000000000..8a09e91688a9
--- /dev/null
+++ b/net/pimd/pkg-descr
@@ -0,0 +1,4 @@
+pimd is a lightweight, stand-alone implementation of Protocol Independent
+Multicast-Sparse Mode
+
+WWW: http://troglobit.com/pimd.html
diff --git a/net/pimd/pkg-plist b/net/pimd/pkg-plist
new file mode 100644
index 000000000000..9bf1546dbcaa
--- /dev/null
+++ b/net/pimd/pkg-plist
@@ -0,0 +1,4 @@
+@sample etc/pimd.conf.sample
+etc/rc.d/pimd
+sbin/pimd
+man/man8/pimd.8.gz