aboutsummaryrefslogtreecommitdiff
path: root/net/pimdd
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2006-09-29 11:14:06 +0000
committerBruce M Simpson <bms@FreeBSD.org>2006-09-29 11:14:06 +0000
commitc7588fa72cbf79893f168a8a33189c8e45c43759 (patch)
tree35f2ad681afaba872c294ae997151a4b2932a138 /net/pimdd
parentad110a2709a4d786d9f5b5d4d130e395ee5cabf1 (diff)
downloadports-c7588fa72cbf79893f168a8a33189c8e45c43759.tar.gz
ports-c7588fa72cbf79893f168a8a33189c8e45c43759.zip
Notes
Diffstat (limited to 'net/pimdd')
-rw-r--r--net/pimdd/Makefile34
-rw-r--r--net/pimdd/distinfo3
-rw-r--r--net/pimdd/files/patch-Makefile11
-rw-r--r--net/pimdd/files/patch-config.c20
-rw-r--r--net/pimdd/files/patch-debug.c28
-rw-r--r--net/pimdd/files/patch-pim.c18
-rw-r--r--net/pimdd/files/patch-pimdd.h19
-rw-r--r--net/pimdd/files/patch-trace.c20
-rw-r--r--net/pimdd/pkg-descr5
-rw-r--r--net/pimdd/pkg-plist7
10 files changed, 165 insertions, 0 deletions
diff --git a/net/pimdd/Makefile b/net/pimdd/Makefile
new file mode 100644
index 000000000000..23464308ff43
--- /dev/null
+++ b/net/pimdd/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: pimdd
+# Date created: 18 March 2004
+# Whom: Bruce M Simpson <bms@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pimdd
+PORTVERSION= 0.2.1.0
+CATEGORIES= net
+MASTER_SITES= http://antc.uoregon.edu/PIMDM/
+DISTNAME= pimd-dense
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= \
+ UO Dense Protocol-Independent Multicast (PIM-DM) daemon for IPv4
+
+NO_MAN= defined
+PIMDD_DOCS= pimd-dense.html README CHANGES RELEASE.NOTES
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|/etc/pimd.conf|${PREFIX}/etc/pimd.conf|g' ${WRKSRC}/pathnames.h
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pimdd ${PREFIX}/sbin/pimdd
+ ${INSTALL_DATA} ${WRKSRC}/pimdd.conf ${PREFIX}/etc/pimdd.conf.sample
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ${PIMDD_DOCS}
+ ${INSTALL_MAN} ${WRKSRC}/${i} ${DOCSDIR}/${i}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/pimdd/distinfo b/net/pimdd/distinfo
new file mode 100644
index 000000000000..6ac46442292c
--- /dev/null
+++ b/net/pimdd/distinfo
@@ -0,0 +1,3 @@
+MD5 (pimd-dense.tar.gz) = 5986c447b2c48dc51afe6656c35396cf
+SHA256 (pimd-dense.tar.gz) = ca90076f9bc3e1a7b731588498bf7d8523a652b6d9c3a55f084a433d2721425c
+SIZE (pimd-dense.tar.gz) = 113974
diff --git a/net/pimdd/files/patch-Makefile b/net/pimdd/files/patch-Makefile
new file mode 100644
index 000000000000..df7f0e9d9b2a
--- /dev/null
+++ b/net/pimdd/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig Fri Sep 29 11:53:31 2006
++++ Makefile Fri Sep 29 11:53:50 2006
+@@ -63,7 +63,7 @@
+ #CONFIGCONFIGCONFIG
+ ### Compilation flags for different platforms. Uncomment only one of them
+ ## FreeBSD
+-CFLAGS= -Wall -g -Iinclude/freebsd ${MCAST_INCLUDE} ${SNMPDEF} ${RSRRDEF} ${MISCDEFS} -DFreeBSD -DPIM
++CFLAGS= -Wall -g ${MCAST_INCLUDE} ${SNMPDEF} ${RSRRDEF} ${MISCDEFS} -DFreeBSD -DPIM -Dlog=logit
+
+ ## NetBSD -DNetBSD is done by OS
+ #CFLAGS= -Wall -g -Iinclude/netbsd ${MCAST_INCLUDE} ${SNMPDEF} ${RSRRDEF} ${MISCDEFS} -DPIM
diff --git a/net/pimdd/files/patch-config.c b/net/pimdd/files/patch-config.c
new file mode 100644
index 000000000000..760b41585503
--- /dev/null
+++ b/net/pimdd/files/patch-config.c
@@ -0,0 +1,20 @@
+--- config.c.orig Fri Sep 29 11:55:19 2006
++++ config.c Fri Sep 29 11:55:43 2006
+@@ -343,7 +343,7 @@
+ v->uv_local_pref = n;
+ }
+
+- else if(EQUAL(w, "metric"))
++ else if(EQUAL(w, "metric")) {
+ if(EQUAL((w = next_word(&s)), ""))
+ log(LOG_WARNING, 0,
+ "Missing metric for phyint %s in %s",
+@@ -361,7 +361,7 @@
+ inet_fmt(local, s1), n);
+ v->uv_local_metric = n;
+ }
+-
++ }
+ } /* if not empty */
+ break;
+ }
diff --git a/net/pimdd/files/patch-debug.c b/net/pimdd/files/patch-debug.c
new file mode 100644
index 000000000000..41a8adbb4c0e
--- /dev/null
+++ b/net/pimdd/files/patch-debug.c
@@ -0,0 +1,28 @@
+--- debug.c.orig Fri Sep 29 11:54:42 2006
++++ debug.c Fri Sep 29 11:55:06 2006
+@@ -378,6 +378,7 @@
+ static char fmt[211] = "warning - ";
+ char *msg;
+ struct timeval now;
++ time_t now_sec;
+ struct tm *thyme;
+
+ va_start(ap, format);
+@@ -394,6 +395,7 @@
+ char *msg;
+ char tbuf[20];
+ struct timeval now;
++ time_t now_sec;
+ struct tm *thyme;
+
+ va_start(ap);
+@@ -408,7 +410,8 @@
+ */
+ if (haveterminal && (debug || severity <= LOG_WARNING)) {
+ gettimeofday(&now,NULL);
+- thyme = localtime(&now.tv_sec);
++ now_sec = now.tv_sec;
++ thyme = localtime(&now_sec);
+ if (!debug)
+ fprintf(stderr, "%s: ", progname);
+ fprintf(stderr, "%02d:%02d:%02d.%03ld %s", thyme->tm_hour,
diff --git a/net/pimdd/files/patch-pim.c b/net/pimdd/files/patch-pim.c
new file mode 100644
index 000000000000..47fd15669be7
--- /dev/null
+++ b/net/pimdd/files/patch-pim.c
@@ -0,0 +1,18 @@
+--- pim.c.orig Fri Sep 29 11:54:13 2006
++++ pim.c Fri Sep 29 11:54:28 2006
+@@ -257,7 +257,6 @@
+ pim = (pim_header_t *)(buf + sizeof(struct ip));
+ pim->pim_type = type;
+ pim->pim_vers = PIM_PROTOCOL_VERSION;
+- pim->reserved = 0;
+ pim->pim_cksum = 0;
+ /* TODO: XXX: if start using this code for PIM_REGISTERS, exclude the
+ * encapsulated packet from the checsum.
+@@ -349,7 +348,6 @@
+ pim = (pim_header_t *)(buf + sizeof(struct ip));
+ pim->pim_vers = PIM_PROTOCOL_VERSION;
+ pim->pim_type = type;
+- pim->reserved = 0;
+ pim->pim_cksum = 0;
+
+ bzero((void *)&sdst, sizeof(sdst));
diff --git a/net/pimdd/files/patch-pimdd.h b/net/pimdd/files/patch-pimdd.h
new file mode 100644
index 000000000000..004815c21b6d
--- /dev/null
+++ b/net/pimdd/files/patch-pimdd.h
@@ -0,0 +1,19 @@
+--- pimdd.h.orig Fri Sep 29 11:53:56 2006
++++ pimdd.h Fri Sep 29 11:54:07 2006
+@@ -202,7 +202,7 @@
+
+ #define PIM_ASSERT_RPT_BIT 0x80000000
+
+-
++#if 0
+ /* PIM messages type */
+ #define PIM_HELLO 0
+ #ifndef PIM_REGISTER
+@@ -215,6 +215,7 @@
+ #define PIM_GRAFT 6
+ #define PIM_GRAFT_ACK 7
+ #define PIM_CAND_RP_ADV 8
++#endif
+
+ #define PIM_V2_HELLO PIM_HELLO
+ #define PIM_V2_REGISTER PIM_REGISTER
diff --git a/net/pimdd/files/patch-trace.c b/net/pimdd/files/patch-trace.c
new file mode 100644
index 000000000000..591c042e4d69
--- /dev/null
+++ b/net/pimdd/files/patch-trace.c
@@ -0,0 +1,20 @@
+--- trace.c.orig Fri Sep 29 11:55:16 2006
++++ trace.c Fri Sep 29 11:55:35 2006
+@@ -133,7 +133,7 @@
+ /* determine the routing table entry for this traceroute */
+ mrt = find_route(qry->tr_src, group, MRTF_SG | MRTF_WC | MRTF_PMBR,
+ DONT_CREATE);
+- IF_DEBUG(DEBUG_TRACE)
++ IF_DEBUG(DEBUG_TRACE) {
+ if (mrt != (mrtentry_t *)NULL) {
+ if (mrt->upstream != (pim_nbr_entry_t *)NULL)
+ parent_address = mrt->upstream->address;
+@@ -147,7 +147,7 @@
+ */
+ } else
+ log(LOG_DEBUG, 0, "...no route");
+-
++ }
+ /*
+ * Query type packet - check if rte exists
+ * Check if the query destination is a vif connected to me.
diff --git a/net/pimdd/pkg-descr b/net/pimdd/pkg-descr
new file mode 100644
index 000000000000..53eb9b791648
--- /dev/null
+++ b/net/pimdd/pkg-descr
@@ -0,0 +1,5 @@
+This is the UO implementation of Protocol-Independent Multicast by
+Kurt Windisch.
+
+Bruce
+bms@FreeBSD.org
diff --git a/net/pimdd/pkg-plist b/net/pimdd/pkg-plist
new file mode 100644
index 000000000000..1fd25ad4710a
--- /dev/null
+++ b/net/pimdd/pkg-plist
@@ -0,0 +1,7 @@
+sbin/pimdd
+etc/pimdd.conf.sample
+%%PORTDOCS%%%%DOCSDIR%%/pimd-dense.html
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/RELEASE.NOTES
+%%PORTDOCS%%@dirrm %%DOCSDIR%%