aboutsummaryrefslogtreecommitdiff
path: root/net/pktanon
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-03-12 04:03:16 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-03-12 04:03:16 +0000
commitd3475bbc71ce3597e178d209b517ee04bfdce24f (patch)
tree81af4a625f6fbc3c25a89798e3859c19ac2211f1 /net/pktanon
parent3d77cd661b949de44d2ad361394b05a0d7e1bb73 (diff)
PKtAnon performs network trace anonymization. It is highly configurable
and uses anonymization profiles. Anonymization profiles allow for mapping of arbitrary anonymization primitives to protocol attributes, thus providing high flexibility and easy usability. A huge number of anonymization primitives and network protocols are supported and ready to use for online and offline anonymization. WWW: http://www.tm.uka.de/software/pktanon/
Notes
Notes: svn path=/head/; revision=229919
Diffstat (limited to 'net/pktanon')
-rw-r--r--net/pktanon/Makefile27
-rw-r--r--net/pktanon/distinfo3
-rw-r--r--net/pktanon/pkg-descr8
-rw-r--r--net/pktanon/pkg-plist7
4 files changed, 45 insertions, 0 deletions
diff --git a/net/pktanon/Makefile b/net/pktanon/Makefile
new file mode 100644
index 000000000000..098030fa8744
--- /dev/null
+++ b/net/pktanon/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: pktanon
+# Date created: 9 March 2009
+# Whom: Wesley Shields <wxs@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pktanon
+PORTVERSION= 1.2.2
+CATEGORIES= net
+MASTER_SITES= http://www.tm.uka.de/software/pktanon/download/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-dev
+
+MAINTAINER= wxs@FreeBSD.org
+COMMENT= Network trace anonymizer
+
+LIB_DEPENDS= boost_regex.4:${PORTSDIR}/devel/boost \
+ xerces-c:${PORTSDIR}/textproc/xerces-c2
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include"
+
+post-install:
+ ${MKDIR} ${DATADIR}/profiles
+ (cd ${WRKSRC}/profiles/ && ${COPYTREE_SHARE} \* ${DATADIR}/profiles)
+
+.include <bsd.port.mk>
diff --git a/net/pktanon/distinfo b/net/pktanon/distinfo
new file mode 100644
index 000000000000..0affa65c51d9
--- /dev/null
+++ b/net/pktanon/distinfo
@@ -0,0 +1,3 @@
+MD5 (pktanon-1.2.2-dev.tar.gz) = 3e6d90c6dee64665cd912d89904adcae
+SHA256 (pktanon-1.2.2-dev.tar.gz) = fc1aadfdeab58981d77d3effde94990a16f458bd10a912a4b16a311d9b8c8f92
+SIZE (pktanon-1.2.2-dev.tar.gz) = 173623
diff --git a/net/pktanon/pkg-descr b/net/pktanon/pkg-descr
new file mode 100644
index 000000000000..28d52249afbb
--- /dev/null
+++ b/net/pktanon/pkg-descr
@@ -0,0 +1,8 @@
+PKtAnon performs network trace anonymization. It is highly configurable
+and uses anonymization profiles. Anonymization profiles allow for
+mapping of arbitrary anonymization primitives to protocol attributes,
+thus providing high flexibility and easy usability. A huge number of
+anonymization primitives and network protocols are supported and ready
+to use for online and offline anonymization.
+
+WWW: http://www.tm.uka.de/software/pktanon/
diff --git a/net/pktanon/pkg-plist b/net/pktanon/pkg-plist
new file mode 100644
index 000000000000..0efdad6a0aa6
--- /dev/null
+++ b/net/pktanon/pkg-plist
@@ -0,0 +1,7 @@
+bin/pktanon
+%%DATADIR%%/profiles/settings_high.xml
+%%DATADIR%%/profiles/settings_identity.xml
+%%DATADIR%%/profiles/settings_low.xml
+%%DATADIR%%/profiles/settings_medium.xml
+@dirrm %%DATADIR%%/profiles
+@dirrm %%DATADIR%%