aboutsummaryrefslogtreecommitdiff
path: root/net/plugdaemon
diff options
context:
space:
mode:
authorOliver Eikemeier <eik@FreeBSD.org>2004-06-24 22:46:15 +0000
committerOliver Eikemeier <eik@FreeBSD.org>2004-06-24 22:46:15 +0000
commit0eb80c6bc930fc892ba41646a540563e1ad54d9c (patch)
tree47a7564f8abe7780c9aa002e48e4c22e3d628c07 /net/plugdaemon
parenta9bb02769e4e57f6823fb5c2dadd021d5b259243 (diff)
downloadports-0eb80c6bc930fc892ba41646a540563e1ad54d9c.tar.gz
ports-0eb80c6bc930fc892ba41646a540563e1ad54d9c.zip
Notes
Diffstat (limited to 'net/plugdaemon')
-rw-r--r--net/plugdaemon/Makefile23
-rw-r--r--net/plugdaemon/distinfo1
-rw-r--r--net/plugdaemon/files/patch-Makefile22
-rw-r--r--net/plugdaemon/pkg-descr6
4 files changed, 52 insertions, 0 deletions
diff --git a/net/plugdaemon/Makefile b/net/plugdaemon/Makefile
new file mode 100644
index 000000000000..c6fcd8b0bb73
--- /dev/null
+++ b/net/plugdaemon/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: plugdaemon
+# Date created: Thu Jun 24 12:38:31 PDT 2004
+# Whom: David Thiel <lx@redundancy.redundancy.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= plugdaemon
+PORTVERSION= 2.5.3
+CATEGORIES= net
+MASTER_SITES= http://www.taronga.com/plugdaemon/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= lx@redundancy.redundancy.org
+COMMENT= Plug proxy daemon, forwards TCP/IP connections
+
+MAN1= plug.1
+PLIST_FILES= sbin/plug
+
+post-install:
+ @${STRIP_CMD} ${PREFIX}/sbin/plug
+
+.include <bsd.port.mk>
diff --git a/net/plugdaemon/distinfo b/net/plugdaemon/distinfo
new file mode 100644
index 000000000000..8fd7931ea6db
--- /dev/null
+++ b/net/plugdaemon/distinfo
@@ -0,0 +1 @@
+MD5 (plugdaemon-2.5.3.tgz) = e3c5cc0e0228595bcdca32b98d64f7e8
diff --git a/net/plugdaemon/files/patch-Makefile b/net/plugdaemon/files/patch-Makefile
new file mode 100644
index 000000000000..4eb74b7fa1d3
--- /dev/null
+++ b/net/plugdaemon/files/patch-Makefile
@@ -0,0 +1,22 @@
+--- Makefile.orig Thu Jun 24 12:46:54 2004
++++ Makefile Thu Jun 24 12:49:07 2004
+@@ -10,8 +10,8 @@
+ #CFLAGS=-O2 -Wall -s -static
+ #LFLAGS=-s -static
+ # gcc
+-CC=cc
+-CFLAGS=-O -g -Wall
++CC?=cc
++CFLAGS+=-O -g -Wall
+ LFLAGS=
+ # cc
+ #CC=cc
+@@ -41,6 +41,6 @@
+ tar: $T.tgz
+
+ install: plug
+- install -C -m 0755 plug /usr/local/sbin
+- install -C -m 0644 plug.1 /usr/local/man/man1
++ install -C -m 0755 plug ${PREFIX}/sbin
++ install -C -m 0644 plug.1 ${PREFIX}/man/man1
+
diff --git a/net/plugdaemon/pkg-descr b/net/plugdaemon/pkg-descr
new file mode 100644
index 000000000000..cf016a7b3494
--- /dev/null
+++ b/net/plugdaemon/pkg-descr
@@ -0,0 +1,6 @@
+Plugdaemon acts as a "dumb proxy", forwarding a TCP/IP stream from a port
+on one host to a possibly different port on a separate host. It runs as a
+daemon to reduce latency in setting up a connection, and optionally logs
+every connection via syslog.
+
+WWW: http://www.taronga.com/plugdaemon/