aboutsummaryrefslogtreecommitdiff
path: root/net/pmf
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2010-02-02 19:36:09 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2010-02-02 19:36:09 +0000
commit103995d97481b5802ea6838571c32e223761df05 (patch)
treeddaeb35c6022234458a128899eb6537313a3190d /net/pmf
parenta7df0b6a701d465b329d55f16b98c7bfb3e4297b (diff)
downloadports-103995d97481b5802ea6838571c32e223761df05.tar.gz
ports-103995d97481b5802ea6838571c32e223761df05.zip
Notes
Diffstat (limited to 'net/pmf')
-rw-r--r--net/pmf/Makefile12
-rw-r--r--net/pmf/files/patch-Makefile (renamed from net/pmf/files/patch-ab)4
-rw-r--r--net/pmf/files/patch-c_packages__Makefile (renamed from net/pmf/files/patch-ae)4
-rw-r--r--net/pmf/files/patch-c_packages__safe_malloc__Makefile (renamed from net/pmf/files/patch-c_packages-safe_malloc-Makefile)4
-rw-r--r--net/pmf/files/patch-c_packages__safe_malloc__fatal.c (renamed from net/pmf/files/patch-c_packages-safe_malloc-fatal.c)4
-rw-r--r--net/pmf/files/patch-config.h (renamed from net/pmf/files/patch-ac)16
-rw-r--r--net/pmf/files/patch-error.c6
-rw-r--r--net/pmf/files/patch-main.c (renamed from net/pmf/files/patch-ad)18
-rw-r--r--net/pmf/files/patch-misc.c (renamed from net/pmf/files/patch-af)4
-rw-r--r--net/pmf/files/patch-tty.c4
-rw-r--r--net/pmf/pkg-plist200
11 files changed, 139 insertions, 137 deletions
diff --git a/net/pmf/Makefile b/net/pmf/Makefile
index 92dca2f9ba3c..118e69edd570 100644
--- a/net/pmf/Makefile
+++ b/net/pmf/Makefile
@@ -8,7 +8,8 @@
PORTNAME= pmf
PORTVERSION= 1.13.1
CATEGORIES= net
-MASTER_SITES= http://ftp.ntua.gr/pub/net/mud/lpmud/clients/pmf/
+MASTER_SITES= http://ftp.ntua.gr/pub/net/mud/lpmud/clients/pmf/ \
+ LOCAL/glarkin
MAINTAINER= ports@FreeBSD.org
COMMENT= Padrone's Mud Frontend
@@ -18,22 +19,21 @@ WRKSRC= ${WRKDIR}/pmfdir/src
SYSSRC= ${WRKSRC}/../system_dir
DOCSRC= ${WRKSRC}/../doc
XMPSRC= ${WRKSRC}/../examples
-
-post-patch:
- @${SED} -e 's:%%PREFIX%%:${PREFIX}:g' ${FILESDIR}/pmfrc.default.in \
- > ${SYSSRC}/pmfrc.default
+SUB_FILES= pmfrc.default
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pmf ${PREFIX}/bin
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${SYSSRC}/NEWS ${DATADIR}
- ${INSTALL_DATA} ${SYSSRC}/pmfrc.default ${DATADIR}
+ ${INSTALL_DATA} ${WRKDIR}/pmfrc.default ${DATADIR}
@${MKDIR} ${DATADIR}/helpfiles
${INSTALL_DATA} ${SYSSRC}/helpfiles/.pmfrc ${DATADIR}/helpfiles
${INSTALL_DATA} ${SYSSRC}/helpfiles/* ${DATADIR}/helpfiles
+.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${XMPSRC}/.pmfrc ${EXAMPLESDIR}/dot.pmfrc
${INSTALL_DATA} ${XMPSRC}/* ${EXAMPLESDIR}
+.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${DOCSRC}/* ${DOCSDIR}
diff --git a/net/pmf/files/patch-ab b/net/pmf/files/patch-Makefile
index 0a15da43731f..0eee3c6f16f0 100644
--- a/net/pmf/files/patch-ab
+++ b/net/pmf/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Sun May 23 13:54:05 1993
-+++ Makefile Mon Nov 18 18:08:10 2002
+--- ./Makefile.orig 1993-05-23 07:54:05.000000000 -0400
++++ ./Makefile 2010-02-02 14:21:04.000000000 -0500
@@ -29,12 +29,13 @@
# pmf without GNU readline or without sound.
# Remove one (or both) of "-DGNU_READLINE" and "-DSOUND".
diff --git a/net/pmf/files/patch-ae b/net/pmf/files/patch-c_packages__Makefile
index 12bb270b2d20..a7edd41f4a5a 100644
--- a/net/pmf/files/patch-ae
+++ b/net/pmf/files/patch-c_packages__Makefile
@@ -1,5 +1,5 @@
---- c_packages/Makefile.orig Sun Sep 22 12:13:58 1991
-+++ c_packages/Makefile Fri Feb 11 04:14:00 2000
+--- ./c_packages/Makefile.orig 1991-09-21 23:13:58.000000000 -0400
++++ ./c_packages/Makefile 2010-02-02 14:21:04.000000000 -0500
@@ -8,7 +8,7 @@
for i in $(PACKAGES) ; \
do \
diff --git a/net/pmf/files/patch-c_packages-safe_malloc-Makefile b/net/pmf/files/patch-c_packages__safe_malloc__Makefile
index 2f8e8dc195f3..192b4974692f 100644
--- a/net/pmf/files/patch-c_packages-safe_malloc-Makefile
+++ b/net/pmf/files/patch-c_packages__safe_malloc__Makefile
@@ -1,5 +1,5 @@
---- c_packages/safe_malloc/Makefile.orig Mon Nov 18 18:14:39 2002
-+++ c_packages/safe_malloc/Makefile Mon Nov 18 18:14:58 2002
+--- ./c_packages/safe_malloc/Makefile.orig 1991-09-21 23:13:52.000000000 -0400
++++ ./c_packages/safe_malloc/Makefile 2010-02-02 14:21:04.000000000 -0500
@@ -14,11 +14,11 @@
INCLUDEDIRS =
diff --git a/net/pmf/files/patch-c_packages-safe_malloc-fatal.c b/net/pmf/files/patch-c_packages__safe_malloc__fatal.c
index 2153364e3ceb..a118507a7ece 100644
--- a/net/pmf/files/patch-c_packages-safe_malloc-fatal.c
+++ b/net/pmf/files/patch-c_packages__safe_malloc__fatal.c
@@ -1,5 +1,5 @@
---- c_packages/safe_malloc/fatal.c.orig Mon Nov 18 18:14:28 2002
-+++ c_packages/safe_malloc/fatal.c Mon Nov 18 18:15:21 2002
+--- ./c_packages/safe_malloc/fatal.c.orig 1991-09-21 23:13:52.000000000 -0400
++++ ./c_packages/safe_malloc/fatal.c 2010-02-02 14:21:04.000000000 -0500
@@ -8,8 +8,8 @@
#include "safe_malloc.h"
diff --git a/net/pmf/files/patch-ac b/net/pmf/files/patch-config.h
index 05c960f98efa..97e735dcce28 100644
--- a/net/pmf/files/patch-ac
+++ b/net/pmf/files/patch-config.h
@@ -1,5 +1,5 @@
---- config.h.orig Fri Oct 29 18:25:35 1993
-+++ config.h Tue Aug 15 09:04:26 2000
+--- ./config.h.orig 1993-10-29 05:25:35.000000000 -0400
++++ ./config.h 2010-02-02 14:21:04.000000000 -0500
@@ -35,14 +35,16 @@
* files instead.
* Note that "~" is not expanded in this directory name.
@@ -18,7 +18,7 @@
#define SYSTEM_NEWS_FILE "NEWS"
#define SYSTEM_HELP_DIR "helpfiles"
#define SYSTEM_SOUND_DIR "soundfiles"
-@@ -63,14 +65,20 @@
+@@ -63,16 +65,22 @@
#define X_OUTPUT_PROGRAM "cat"
/* What system? Define one either BSD or SYSV:*/
@@ -33,10 +33,12 @@
# define USE_TIOCGETP
#else
# define USE_TCGETA
-+#endif
-+
-+#ifdef BSD
-+#define _cnt _r
#endif
++#ifdef BSD
++#define _cnt _r
++#endif
++
/* The prompt to print after doing a builtin command. 0 means no prompt.
+ * The prompt variable is initially set to the value of DEFAULT_PROMPT,
+ * but it can of course later be changed with the command "set prompt".
diff --git a/net/pmf/files/patch-error.c b/net/pmf/files/patch-error.c
index 21e5babbf22d..59715da8e8b3 100644
--- a/net/pmf/files/patch-error.c
+++ b/net/pmf/files/patch-error.c
@@ -1,5 +1,5 @@
---- error.c.orig Mon Nov 18 18:08:20 2002
-+++ error.c Mon Nov 18 18:08:48 2002
+--- ./error.c.orig 1991-09-21 23:13:05.000000000 -0400
++++ ./error.c 2010-02-02 14:21:04.000000000 -0500
@@ -15,8 +15,8 @@
#include "pmf.h"
@@ -10,4 +10,4 @@
+extern int sys_nerr; */
/*---------------------------------------------------------------------------*/
-
+
diff --git a/net/pmf/files/patch-ad b/net/pmf/files/patch-main.c
index dc361333ce5d..3c65bfb7da2f 100644
--- a/net/pmf/files/patch-ad
+++ b/net/pmf/files/patch-main.c
@@ -1,5 +1,5 @@
---- main.c.orig Sun Sep 22 12:13:43 1991
-+++ main.c Fri Feb 11 04:14:00 2000
+--- ./main.c.orig 1991-09-21 23:13:43.000000000 -0400
++++ ./main.c 2010-02-02 14:21:04.000000000 -0500
@@ -12,9 +12,9 @@
#include <stdio.h>
#include <sys/types.h>
@@ -11,7 +11,7 @@
#include "safe_malloc.h"
#include "str_galore.h"
#include "config.h"
-@@ -37,7 +38,7 @@
+@@ -37,7 +37,7 @@
extern int stop_printing();
extern int continue_printing();
@@ -20,7 +20,7 @@
#endif
/* Longjmp buffer, jump there after error() or CTRL-C */
-@@ -58,7 +59,7 @@
+@@ -58,7 +58,7 @@
ldisplay("\n");
ldisplay("%s", rl_line_buffer);
rl_redisplay(count, key);
@@ -28,16 +28,16 @@
+ _rl_last_c_pos = rl_end;
}
#endif
-
-@@ -191,7 +192,11 @@
+
+@@ -191,7 +191,11 @@
#endif
-
+
if (debug && exitval) {
+ #if defined(__FreeBSD__) && (__FreeBSD_version >= 500035)
+ signal(SIGABRT, SIG_DFL);
+ #else
- signal(SIGIOT, SIG_DFL);
+ signal(SIGIOT, SIG_DFL);
+ #endif
- abort();
+ abort();
}
else
diff --git a/net/pmf/files/patch-af b/net/pmf/files/patch-misc.c
index ad5d613e1041..31a193e9dc89 100644
--- a/net/pmf/files/patch-af
+++ b/net/pmf/files/patch-misc.c
@@ -1,5 +1,5 @@
---- misc.c.orig Sat Feb 19 21:56:34 2000
-+++ misc.c Sat Feb 19 21:56:43 2000
+--- ./misc.c.orig 1991-09-21 23:13:43.000000000 -0400
++++ ./misc.c 2010-02-02 14:21:04.000000000 -0500
@@ -16,7 +16,7 @@
#include "config.h"
#include "globals.h"
diff --git a/net/pmf/files/patch-tty.c b/net/pmf/files/patch-tty.c
index 9ad3aed2838d..67edbbaf9e07 100644
--- a/net/pmf/files/patch-tty.c
+++ b/net/pmf/files/patch-tty.c
@@ -1,5 +1,5 @@
---- tty.c Fri Oct 29 10:09:06 1993
-+++ tty.c Mon Mar 26 20:02:26 2007
+--- ./tty.c.orig 1993-10-29 05:09:06.000000000 -0400
++++ ./tty.c 2010-02-02 14:21:04.000000000 -0500
@@ -18,6 +18,9 @@
/* Added by dodurham@stimpy.ualr.edu for Linux machines */
#ifdef SYSV
diff --git a/net/pmf/pkg-plist b/net/pmf/pkg-plist
index 9667297666e5..eda4f128f81e 100644
--- a/net/pmf/pkg-plist
+++ b/net/pmf/pkg-plist
@@ -1,101 +1,101 @@
bin/pmf
-%%PORTDOCS%%share/doc/pmf/mud-clients.FAQ
-%%PORTDOCS%%share/doc/pmf/mud-rwho.FAQ
-%%PORTDOCS%%share/doc/pmf/mud.FAQ
-%%PORTDOCS%%share/doc/pmf/mudlist.18oct93
-%%PORTDOCS%%share/doc/pmf/pmf.doc
-%%PORTDOCS%%share/doc/pmf/resource-usage
-share/examples/pmf/dot.pmfrc
-share/examples/pmf/pmf-sparc-sound
-share/examples/pmf/sample-robot
-share/pmf/NEWS
-share/pmf/pmfrc.default
-share/pmf/helpfiles/!!
-share/pmf/helpfiles/!number
-share/pmf/helpfiles/!str
-share/pmf/helpfiles/!string
-share/pmf/helpfiles/+action
-share/pmf/helpfiles/+alias
-share/pmf/helpfiles/+beep
-share/pmf/helpfiles/+cd
-share/pmf/helpfiles/+connect
-share/pmf/helpfiles/+cryptsay
-share/pmf/helpfiles/+crypttell
-share/pmf/helpfiles/+debuglog
-share/pmf/helpfiles/+disconnect
-share/pmf/helpfiles/+dump
-share/pmf/helpfiles/+echo
-share/pmf/helpfiles/+gag
-share/pmf/helpfiles/+getfile
-share/pmf/helpfiles/+help
-share/pmf/helpfiles/+history
-share/pmf/helpfiles/+last
-share/pmf/helpfiles/+log
-share/pmf/helpfiles/+perform
-share/pmf/helpfiles/+putfile
-share/pmf/helpfiles/+quit
-share/pmf/helpfiles/+quote
-share/pmf/helpfiles/+receive
-share/pmf/helpfiles/+send
-share/pmf/helpfiles/+set
-share/pmf/helpfiles/+sound
-share/pmf/helpfiles/+source
-share/pmf/helpfiles/+status
-share/pmf/helpfiles/+system
-share/pmf/helpfiles/+unaction
-share/pmf/helpfiles/+unactionall
-share/pmf/helpfiles/+unalias
-share/pmf/helpfiles/+ungag
-share/pmf/helpfiles/+unset
-share/pmf/helpfiles/+unsound
-share/pmf/helpfiles/.pmfrc
-share/pmf/helpfiles/242
-share/pmf/helpfiles/?
-share/pmf/helpfiles/CTRL-C
-share/pmf/helpfiles/CTRL-D
-share/pmf/helpfiles/CTRL-Z
-share/pmf/helpfiles/FRONT242
-share/pmf/helpfiles/Padrone
-share/pmf/helpfiles/README
-share/pmf/helpfiles/achtung
-share/pmf/helpfiles/bug
-share/pmf/helpfiles/can_gag_fight
-share/pmf/helpfiles/cryptkey
-share/pmf/helpfiles/debug
-share/pmf/helpfiles/documentation
-share/pmf/helpfiles/echo
-share/pmf/helpfiles/frontcd
-share/pmf/helpfiles/frontecho
-share/pmf/helpfiles/fronthelp
-share/pmf/helpfiles/frontquit
-share/pmf/helpfiles/frontset
-share/pmf/helpfiles/frontstatus
-share/pmf/helpfiles/frontunset
-share/pmf/helpfiles/help
-share/pmf/helpfiles/history
-share/pmf/helpfiles/host
-share/pmf/helpfiles/ignoreeof
-share/pmf/helpfiles/init
-share/pmf/helpfiles/lines_to_save
-share/pmf/helpfiles/options
-share/pmf/helpfiles/padrone
-share/pmf/helpfiles/pmf
-share/pmf/helpfiles/port
-share/pmf/helpfiles/prompt
-share/pmf/helpfiles/quit
-share/pmf/helpfiles/replace_control
-share/pmf/helpfiles/robot
-share/pmf/helpfiles/screen_length
-share/pmf/helpfiles/show_receive
-share/pmf/helpfiles/slash_commands
-share/pmf/helpfiles/sound
-share/pmf/helpfiles/source
-share/pmf/helpfiles/source-code
-share/pmf/helpfiles/status
-share/pmf/helpfiles/substitute_history
-share/pmf/helpfiles/variables
-share/pmf/helpfiles/verbose
-@dirrm share/pmf/helpfiles
-@dirrm share/pmf
-@dirrm share/examples/pmf
-%%PORTDOCS%%@dirrm share/doc/pmf
+%%PORTDOCS%%%%DOCSDIR%%/mud-clients.FAQ
+%%PORTDOCS%%%%DOCSDIR%%/mud-rwho.FAQ
+%%PORTDOCS%%%%DOCSDIR%%/mud.FAQ
+%%PORTDOCS%%%%DOCSDIR%%/mudlist.18oct93
+%%PORTDOCS%%%%DOCSDIR%%/pmf.doc
+%%PORTDOCS%%%%DOCSDIR%%/resource-usage
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dot.pmfrc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pmf-sparc-sound
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sample-robot
+%%DATADIR%%/NEWS
+%%DATADIR%%/pmfrc.default
+%%DATADIR%%/helpfiles/!!
+%%DATADIR%%/helpfiles/!number
+%%DATADIR%%/helpfiles/!str
+%%DATADIR%%/helpfiles/!string
+%%DATADIR%%/helpfiles/+action
+%%DATADIR%%/helpfiles/+alias
+%%DATADIR%%/helpfiles/+beep
+%%DATADIR%%/helpfiles/+cd
+%%DATADIR%%/helpfiles/+connect
+%%DATADIR%%/helpfiles/+cryptsay
+%%DATADIR%%/helpfiles/+crypttell
+%%DATADIR%%/helpfiles/+debuglog
+%%DATADIR%%/helpfiles/+disconnect
+%%DATADIR%%/helpfiles/+dump
+%%DATADIR%%/helpfiles/+echo
+%%DATADIR%%/helpfiles/+gag
+%%DATADIR%%/helpfiles/+getfile
+%%DATADIR%%/helpfiles/+help
+%%DATADIR%%/helpfiles/+history
+%%DATADIR%%/helpfiles/+last
+%%DATADIR%%/helpfiles/+log
+%%DATADIR%%/helpfiles/+perform
+%%DATADIR%%/helpfiles/+putfile
+%%DATADIR%%/helpfiles/+quit
+%%DATADIR%%/helpfiles/+quote
+%%DATADIR%%/helpfiles/+receive
+%%DATADIR%%/helpfiles/+send
+%%DATADIR%%/helpfiles/+set
+%%DATADIR%%/helpfiles/+sound
+%%DATADIR%%/helpfiles/+source
+%%DATADIR%%/helpfiles/+status
+%%DATADIR%%/helpfiles/+system
+%%DATADIR%%/helpfiles/+unaction
+%%DATADIR%%/helpfiles/+unactionall
+%%DATADIR%%/helpfiles/+unalias
+%%DATADIR%%/helpfiles/+ungag
+%%DATADIR%%/helpfiles/+unset
+%%DATADIR%%/helpfiles/+unsound
+%%DATADIR%%/helpfiles/.pmfrc
+%%DATADIR%%/helpfiles/242
+%%DATADIR%%/helpfiles/?
+%%DATADIR%%/helpfiles/CTRL-C
+%%DATADIR%%/helpfiles/CTRL-D
+%%DATADIR%%/helpfiles/CTRL-Z
+%%DATADIR%%/helpfiles/FRONT242
+%%DATADIR%%/helpfiles/Padrone
+%%DATADIR%%/helpfiles/README
+%%DATADIR%%/helpfiles/achtung
+%%DATADIR%%/helpfiles/bug
+%%DATADIR%%/helpfiles/can_gag_fight
+%%DATADIR%%/helpfiles/cryptkey
+%%DATADIR%%/helpfiles/debug
+%%DATADIR%%/helpfiles/documentation
+%%DATADIR%%/helpfiles/echo
+%%DATADIR%%/helpfiles/frontcd
+%%DATADIR%%/helpfiles/frontecho
+%%DATADIR%%/helpfiles/fronthelp
+%%DATADIR%%/helpfiles/frontquit
+%%DATADIR%%/helpfiles/frontset
+%%DATADIR%%/helpfiles/frontstatus
+%%DATADIR%%/helpfiles/frontunset
+%%DATADIR%%/helpfiles/help
+%%DATADIR%%/helpfiles/history
+%%DATADIR%%/helpfiles/host
+%%DATADIR%%/helpfiles/ignoreeof
+%%DATADIR%%/helpfiles/init
+%%DATADIR%%/helpfiles/lines_to_save
+%%DATADIR%%/helpfiles/options
+%%DATADIR%%/helpfiles/padrone
+%%DATADIR%%/helpfiles/pmf
+%%DATADIR%%/helpfiles/port
+%%DATADIR%%/helpfiles/prompt
+%%DATADIR%%/helpfiles/quit
+%%DATADIR%%/helpfiles/replace_control
+%%DATADIR%%/helpfiles/robot
+%%DATADIR%%/helpfiles/screen_length
+%%DATADIR%%/helpfiles/show_receive
+%%DATADIR%%/helpfiles/slash_commands
+%%DATADIR%%/helpfiles/sound
+%%DATADIR%%/helpfiles/source
+%%DATADIR%%/helpfiles/source-code
+%%DATADIR%%/helpfiles/status
+%%DATADIR%%/helpfiles/substitute_history
+%%DATADIR%%/helpfiles/variables
+%%DATADIR%%/helpfiles/verbose
+@dirrm %%DATADIR%%/helpfiles
+@dirrm %%DATADIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%