aboutsummaryrefslogtreecommitdiff
path: root/net/pmf
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2002-11-24 11:10:21 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2002-11-24 11:10:21 +0000
commitb5bea64f245a1ba6f344cb628c7e1a665a9da730 (patch)
tree535a683c719e3ab8b384e6dcf41b5fe50568c6ef /net/pmf
parent7a04ddb3716c8e5b07c30510439aaca70a780ba3 (diff)
downloadports-b5bea64f245a1ba6f344cb628c7e1a665a9da730.tar.gz
ports-b5bea64f245a1ba6f344cb628c7e1a665a9da730.zip
Notes
Diffstat (limited to 'net/pmf')
-rw-r--r--net/pmf/files/patch-ab6
-rw-r--r--net/pmf/files/patch-c_packages-safe_malloc-Makefile16
-rw-r--r--net/pmf/files/patch-c_packages-safe_malloc-fatal.c13
-rw-r--r--net/pmf/files/patch-error.c13
4 files changed, 45 insertions, 3 deletions
diff --git a/net/pmf/files/patch-ab b/net/pmf/files/patch-ab
index 5a4fd2cf4989..0a15da43731f 100644
--- a/net/pmf/files/patch-ab
+++ b/net/pmf/files/patch-ab
@@ -1,5 +1,5 @@
---- Makefile.orig Sun May 23 20:54:05 1993
-+++ Makefile Fri Feb 11 04:02:29 2000
+--- Makefile.orig Sun May 23 13:54:05 1993
++++ Makefile Mon Nov 18 18:08:10 2002
@@ -29,12 +29,13 @@
# pmf without GNU readline or without sound.
# Remove one (or both) of "-DGNU_READLINE" and "-DSOUND".
@@ -30,7 +30,7 @@
# Distribution: CFLAGS = -O
# Maximum debug: CFLAGS = -g -pg -DDEBUG -pipe
-CFLAGS = -O
-+CFLAGS += -D_ANSI_SOURCE -DSYSTEM_DIR=\"${PREFIX}/share/pmf\"
++CFLAGS += -DSYSTEM_DIR=\"${PREFIX}/share/pmf\"
######################################################################
diff --git a/net/pmf/files/patch-c_packages-safe_malloc-Makefile b/net/pmf/files/patch-c_packages-safe_malloc-Makefile
new file mode 100644
index 000000000000..2f8e8dc195f3
--- /dev/null
+++ b/net/pmf/files/patch-c_packages-safe_malloc-Makefile
@@ -0,0 +1,16 @@
+--- c_packages/safe_malloc/Makefile.orig Mon Nov 18 18:14:39 2002
++++ c_packages/safe_malloc/Makefile Mon Nov 18 18:14:58 2002
+@@ -14,11 +14,11 @@
+ INCLUDEDIRS =
+
+ # CC = gcc -traditional
+-CC = cc
++CC ?= cc
+
+ # Distribution: CFLAGS = -O
+ # Maximum debug: CFLAGS = -g -pg -DDEBUG -pipe
+-CFLAGS = -O
++#CFLAGS = -O
+
+ all: $(OBJECTS)
+
diff --git a/net/pmf/files/patch-c_packages-safe_malloc-fatal.c b/net/pmf/files/patch-c_packages-safe_malloc-fatal.c
new file mode 100644
index 000000000000..2153364e3ceb
--- /dev/null
+++ b/net/pmf/files/patch-c_packages-safe_malloc-fatal.c
@@ -0,0 +1,13 @@
+--- c_packages/safe_malloc/fatal.c.orig Mon Nov 18 18:14:28 2002
++++ c_packages/safe_malloc/fatal.c Mon Nov 18 18:15:21 2002
+@@ -8,8 +8,8 @@
+ #include "safe_malloc.h"
+
+ extern int errno;
+-extern char *sys_errlist[];
+-extern int sys_nerr;
++/*extern char *sys_errlist[];
++extern int sys_nerr;*/
+
+ fatal(fmt, a1, a2, a3, a4, a5)
+ char *fmt, *a1, *a2, *a3, *a4, *a5;
diff --git a/net/pmf/files/patch-error.c b/net/pmf/files/patch-error.c
new file mode 100644
index 000000000000..21e5babbf22d
--- /dev/null
+++ b/net/pmf/files/patch-error.c
@@ -0,0 +1,13 @@
+--- error.c.orig Mon Nov 18 18:08:20 2002
++++ error.c Mon Nov 18 18:08:48 2002
+@@ -15,8 +15,8 @@
+ #include "pmf.h"
+
+ extern int errno;
+-extern char *sys_errlist[];
+-extern int sys_nerr;
++/* extern char *sys_errlist[];
++extern int sys_nerr; */
+
+ /*---------------------------------------------------------------------------*/
+