aboutsummaryrefslogtreecommitdiff
path: root/net/poptop/Makefile
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-11-28 12:44:11 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-11-28 12:44:11 +0000
commit9969531d0929fa07ff7dd61b0378659f4cf39564 (patch)
tree5d141ba743aee81042d23a41bcff9f45ff693276 /net/poptop/Makefile
parent13ce0a8a00c584213f13eef8f342c13e8408d598 (diff)
Update to 1.2.3
PR: ports/88260 Submitted by: Serge Maslov <serge@maslov.biz> Approved by: Oleg M. Golovanov <olmi@rentech.ru> (maintainer, timeout 26 days)
Notes
Notes: svn path=/head/; revision=149774
Diffstat (limited to 'net/poptop/Makefile')
-rw-r--r--net/poptop/Makefile40
1 files changed, 15 insertions, 25 deletions
diff --git a/net/poptop/Makefile b/net/poptop/Makefile
index aedce37f323c..65ad4baa44b2 100644
--- a/net/poptop/Makefile
+++ b/net/poptop/Makefile
@@ -6,35 +6,22 @@
#
PORTNAME= poptop
-PORTVERSION= 1.2.1
-PORTREVISION= 0
+PORTVERSION= 1.2.3
CATEGORIES= net
-MASTER_SITES= http://jaist.dl.sourceforge.net/sourceforge/poptop/ \
- http://easynews.dl.sourceforge.net/sourceforge/poptop/ \
- http://nchc.dl.sourceforge.net/sourceforge/poptop/ \
- http://optusnet.dl.sourceforge.net/sourceforge/poptop/ \
- http://mesh.dl.sourceforge.net/sourceforge/poptop/ \
- http://switch.dl.sourceforge.net/sourceforge/poptop/ \
- http://kent.dl.sourceforge.net/sourceforge/poptop/ \
- http://puzzle.dl.sourceforge.net/sourceforge/poptop/ \
- http://cogent.dl.sourceforge.net/sourceforge/poptop/ \
- http://citkit.dl.sourceforge.net/sourceforge/poptop/ \
- http://belnet.dl.sourceforge.net/sourceforge/poptop/ \
- ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= pptpd-${PORTVERSION:S/.b/-b/}
MAINTAINER= olmi@rentech.ru
COMMENT= Windows 9x compatible PPTP (VPN) server
-WRKSRC= ${WRKDIR}/pptpd-${PORTVERSION}
-
-USE_GETOPT_LONG= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
- AUTOHEADER="${TRUE}" \
+ AUTOHEADER="${TRUE}"
+
+USE_RC_SUBR= pptpd.sh
MAN5= pptpd.conf.5
MAN8= pptpd.8 pptpctrl.8
@@ -43,16 +30,19 @@ MAN8= pptpd.8 pptpctrl.8
CONFIGURE_ARGS+= --with-bsdppp
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500000
+USE_GETOPT_LONG= yes
+.endif
+
post-patch:
-.for file in bcrelay.c pptpd.c
- @${REINPLACE_CMD} -e 's|"out_getopt\.h"|<getopt.h>|g' ${WRKSRC}/${file}
-.endfor
- @${REINPLACE_CMD} -e "s#%%PREFIX%%#${PREFIX}#" ${WRKSRC}/pptpd.8 ${WRKSRC}/pptpd.conf.5
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/pptpctrl.c
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/pptpd.8
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/pptpd.conf.5
post-install:
${INSTALL_DATA} ${WRKSRC}/samples/pptpd.conf \
${PREFIX}/etc/pptpd.conf.sample
- ${INSTALL_SCRIPT} ${FILESDIR}/pptpd.sh \
- ${PREFIX}/etc/rc.d/pptpd.sh.sample
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>