aboutsummaryrefslogtreecommitdiff
path: root/net/poptop
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2008-11-27 22:36:52 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2008-11-27 22:36:52 +0000
commit67bd9e35861e2369f97d7fb2a1309937908b9291 (patch)
treec7b28b59db5d7f2391b63e5d3ef8fdb941df8647 /net/poptop
parent5b7e27c17dc1a76b26c0bab94c53a47496e42237 (diff)
downloadports-67bd9e35861e2369f97d7fb2a1309937908b9291.tar.gz
ports-67bd9e35861e2369f97d7fb2a1309937908b9291.zip
Notes
Diffstat (limited to 'net/poptop')
-rw-r--r--net/poptop/Makefile4
-rw-r--r--net/poptop/files/patch-plugins_Makefile16
-rw-r--r--net/poptop/files/patch-pptpd.c6
3 files changed, 21 insertions, 5 deletions
diff --git a/net/poptop/Makefile b/net/poptop/Makefile
index 4777c945ddac..1755b7335f21 100644
--- a/net/poptop/Makefile
+++ b/net/poptop/Makefile
@@ -7,7 +7,7 @@
PORTNAME= poptop
PORTVERSION= 1.3.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,9 +18,9 @@ COMMENT= Windows 9x compatible PPTP (VPN) server
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
+MAKE_ENV+= CC="${CC}" CXX="${CXX}" CFLAGS="${CFLAGS}"
USE_RC_SUBR= pptpd.sh
diff --git a/net/poptop/files/patch-plugins_Makefile b/net/poptop/files/patch-plugins_Makefile
new file mode 100644
index 000000000000..1fcd6e5f89a5
--- /dev/null
+++ b/net/poptop/files/patch-plugins_Makefile
@@ -0,0 +1,16 @@
+--- plugins/Makefile.orig 2006-08-03 04:02:01.000000000 +0200
++++ plugins/Makefile 2008-11-27 22:19:48.000000000 +0100
+@@ -1,10 +1,10 @@
+-CC = gcc
+-COPTS = -O2 -g
++CC ?= gcc
++CPP ?= $(CXX)
+ CFLAGS = $(COPTS) -I.. -I../../include -fPIC
+ LDFLAGS = -shared
+ LDADD = -lutil
+ INSTALL = install -o root
+-prefix = /usr/local
++prefix = $(PREFIX)
+
+ PLUGINS = pptpd-logwtmp.so
+
diff --git a/net/poptop/files/patch-pptpd.c b/net/poptop/files/patch-pptpd.c
index c45f48c77063..9bf3035505fc 100644
--- a/net/poptop/files/patch-pptpd.c
+++ b/net/poptop/files/patch-pptpd.c
@@ -1,5 +1,5 @@
---- pptpd.c.orig Tue Sep 5 01:17:25 2006
-+++ pptpd.c Tue Jul 31 08:19:38 2007
+--- pptpd.c.orig 2006-09-05 01:17:25.000000000 +0200
++++ pptpd.c 2008-11-27 22:09:53.000000000 +0100
@@ -98,18 +98,21 @@
printf(" [-i] [--noipparam] Suppress the passing of the client's IP address\n");
printf(" to PPP, which is done by default otherwise.\n");
@@ -22,7 +22,7 @@
#endif
printf(" [-t] [--stimeout seconds] Specifies the timeout for the first packet. This is a DOS protection\n");
- printf(" (default is 10).\n");
-+ printf(" (default is %s).\n",STIMEOUT_DEFAULT);
++ printf(" (default is %d).\n",STIMEOUT_DEFAULT);
printf(" [-v] [--version] Displays the pptpd version number.\n");
printf(" [-w] [--logwtmp] Update wtmp as users login.\n");
printf(" [-C] [--connections n] Limit on number of connections.\n");