aboutsummaryrefslogtreecommitdiff
path: root/net/pptpclient
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-10-02 22:21:20 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-10-02 22:21:20 +0000
commitc544753526b5b25085dfdb9836f27b5c02781264 (patch)
treea34a2f555b682b8c446184f4ca5db1fde4732fd3 /net/pptpclient
parent41c302eabddc73741b2cd883f9d125818fea62d9 (diff)
Notes
Diffstat (limited to 'net/pptpclient')
-rw-r--r--net/pptpclient/Makefile6
-rw-r--r--net/pptpclient/distinfo4
-rw-r--r--net/pptpclient/files/patch-pptp_ctrl.c20
3 files changed, 25 insertions, 5 deletions
diff --git a/net/pptpclient/Makefile b/net/pptpclient/Makefile
index 4db56a5cdda5..e8f4af427d87 100644
--- a/net/pptpclient/Makefile
+++ b/net/pptpclient/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: pptpclient
-# Date created: 19 June 1999
-# Whom: John Polstra <jdp@freebsd.org>
+# Date created: 19 June 1999
+# Whom: John Polstra <jdp@freebsd.org>
#
# $FreeBSD$
#
PORTNAME= pptpclient
-PORTVERSION= 1.6.0
+PORTVERSION= 1.7.0
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pptpclient
diff --git a/net/pptpclient/distinfo b/net/pptpclient/distinfo
index 3f298d4faf9f..719eb26e3bf2 100644
--- a/net/pptpclient/distinfo
+++ b/net/pptpclient/distinfo
@@ -1,2 +1,2 @@
-MD5 (pptp-1.6.0.tar.gz) = 9a706327fb9827541d7c86d48ceb9631
-SIZE (pptp-1.6.0.tar.gz) = 225956
+MD5 (pptp-1.7.0.tar.gz) = 0bc7dbd1c265e4263008fa7883de58dd
+SIZE (pptp-1.7.0.tar.gz) = 227699
diff --git a/net/pptpclient/files/patch-pptp_ctrl.c b/net/pptpclient/files/patch-pptp_ctrl.c
new file mode 100644
index 000000000000..51aa84471f35
--- /dev/null
+++ b/net/pptpclient/files/patch-pptp_ctrl.c
@@ -0,0 +1,20 @@
+--- pptp_ctrl.c.orig Fri Sep 30 21:56:59 2005
++++ pptp_ctrl.c Fri Sep 30 21:57:27 2005
+@@ -457,6 +457,8 @@
+ void pptp_fd_set(PPTP_CONN * conn, fd_set * read_set, fd_set * write_set,
+ int * max_fd)
+ {
++ int sig_fd;
++
+ assert(conn && conn->call);
+ /* Add fd to write_set if there are outstanding writes. */
+ if (conn->write_size > 0)
+@@ -465,7 +467,7 @@
+ FD_SET(conn->inet_sock, read_set);
+ if (*max_fd < conn->inet_sock) *max_fd = conn->inet_sock;
+ /* Add signal pipe file descriptor to set */
+- int sig_fd = sigpipe_fd();
++ sig_fd = sigpipe_fd();
+ FD_SET(sig_fd, read_set);
+ if (*max_fd < sig_fd) *max_fd = sig_fd;
+ }