aboutsummaryrefslogtreecommitdiff
path: root/net/pptpclient
diff options
context:
space:
mode:
authorThomas Quinot <thomas@FreeBSD.org>2003-08-14 10:11:01 +0000
committerThomas Quinot <thomas@FreeBSD.org>2003-08-14 10:11:01 +0000
commitb88484ef9d16f65f05481349acc4aee24ff6da8c (patch)
treee2bfaee9e43d93f4b52a33737aeaa1f7eaaed09a /net/pptpclient
parentebdc9229acc070e4d2c1708a979ba7a36e4a6462 (diff)
downloadports-b88484ef9d16f65f05481349acc4aee24ff6da8c.tar.gz
ports-b88484ef9d16f65f05481349acc4aee24ff6da8c.zip
Notes
Diffstat (limited to 'net/pptpclient')
-rw-r--r--net/pptpclient/Makefile23
-rw-r--r--net/pptpclient/distinfo2
-rw-r--r--net/pptpclient/files/patch-aa19
3 files changed, 18 insertions, 26 deletions
diff --git a/net/pptpclient/Makefile b/net/pptpclient/Makefile
index cd21d9023f68..a59958390c4d 100644
--- a/net/pptpclient/Makefile
+++ b/net/pptpclient/Makefile
@@ -6,41 +6,32 @@
#
PORTNAME= pptpclient
-PORTVERSION= 1.1.0
-PORTREVISION= 1
+PORTVERSION= 1.3.1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pptpclient
-DISTNAME= pptp-linux-1.1.0
-DISTFILES= pptp-linux-1.1.0-1.tar.gz
+DISTNAME= pptp-linux-1.3.1
MAINTAINER= thomas@cuivre.fr.eu.org
COMMENT= PPTP client for establishing a VPN link with an NT server
USE_GETOPT_LONG=yes
+MAN8= pptp.8
+
.include <bsd.port.pre.mk>
MAKE_ARGS= DEBUG=""
.if ${OSVERSION} < 500041
MAKE_ARGS+= INCLUDE="${CPPFLAGS}" \
- LIBS="${LDFLAGS}"
+ LDFLAGS="${LDFLAGS}"
.endif
-GUNZIP_CMD= ${GZIP_CMD} ${EXTRACT_BEFORE_ARGS}
-
-do-extract:
- @${RM} -rf ${WRKDIR}
- @${MKDIR} ${WRKDIR}
- @(cd ${WRKDIR} && \
- ${GUNZIP_CMD} ${_DISTDIR}/${DISTFILES} | tar -xf - && \
- ${GUNZIP_CMD} `basename ${DISTFILES} .tar.gz`/${DISTNAME}.tar.gz | \
- tar -xf -)
-
do-install:
- cd ${WRKSRC} ; ${INSTALL_PROGRAM} pptp ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/pptp ${PREFIX}/sbin
${MKDIR} ${PREFIX}/share/examples/pptpclient
${INSTALL_DATA} ${FILESDIR}/README ${PREFIX}/share/examples/pptpclient
${INSTALL_DATA} ${FILESDIR}/ppp.conf ${PREFIX}/share/examples/pptpclient
+ ${INSTALL_MAN} ${WRKSRC}/pptp.8 ${PREFIX}/man/man8
.include <bsd.port.post.mk>
diff --git a/net/pptpclient/distinfo b/net/pptpclient/distinfo
index 1e7f0904a746..47642653b812 100644
--- a/net/pptpclient/distinfo
+++ b/net/pptpclient/distinfo
@@ -1 +1 @@
-MD5 (pptp-linux-1.1.0-1.tar.gz) = 03e340eb0a9118a8de94eef21560d6c9
+MD5 (pptp-linux-1.3.1.tar.gz) = b24ca05422c0e62d7a26edbbec604a89
diff --git a/net/pptpclient/files/patch-aa b/net/pptpclient/files/patch-aa
index 15d16760f727..62682c293005 100644
--- a/net/pptpclient/files/patch-aa
+++ b/net/pptpclient/files/patch-aa
@@ -1,6 +1,6 @@
---- Makefile.orig Mon Mar 11 09:36:52 2002
-+++ Makefile Thu Jun 13 15:20:18 2002
-@@ -2,14 +2,14 @@
+--- Makefile.orig Wed Jun 11 10:42:07 2003
++++ Makefile Wed Aug 13 14:48:47 2003
+@@ -4,7 +4,7 @@
#################################################################
# CHANGE THIS LINE to point to the location of your pppd binary.
@@ -8,12 +8,13 @@
+PPPD = /usr/sbin/ppp
#################################################################
- CC = gcc
- RM = rm -f
+ BINDIR=$(DESTDIR)/usr/sbin
+@@ -15,7 +15,7 @@
+ OPTIMIZE= -O0
DEBUG = -g
INCLUDE =
--CFLAGS = -Wall -O1 $(DEBUG) $(INCLUDE)
-+CFLAGS = -Wall -O1 $(DEBUG) $(INCLUDE) -DUSER_PPP
- LIBS =
- LDFLAGS = -lutil
+-CFLAGS = -Wall $(OPTIMIZE) $(DEBUG) $(INCLUDE)
++CFLAGS = -Wall $(OPTIMIZE) $(DEBUG) $(INCLUDE) -DUSER_PPP
+ LIBS = -lutil
+ LDFLAGS =