aboutsummaryrefslogtreecommitdiff
path: root/net/prosearch
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2007-12-16 11:52:15 +0000
committerBeech Rintoul <beech@FreeBSD.org>2007-12-16 11:52:15 +0000
commit2d72143e57a85803b9de7a4988f733ae33bddb23 (patch)
tree4788195c457bbb43e375a7a63b9a1d4dc308985d /net/prosearch
parent7dfa2a2b78ff17d440166753b4f980b437d8307d (diff)
downloadports-2d72143e57a85803b9de7a4988f733ae33bddb23.tar.gz
ports-2d72143e57a85803b9de7a4988f733ae33bddb23.zip
Notes
Diffstat (limited to 'net/prosearch')
-rw-r--r--net/prosearch/Makefile88
-rw-r--r--net/prosearch/distinfo3
-rw-r--r--net/prosearch/files/pkg-message.in19
-rw-r--r--net/prosearch/pkg-descr3
-rw-r--r--net/prosearch/pkg-plist130
5 files changed, 243 insertions, 0 deletions
diff --git a/net/prosearch/Makefile b/net/prosearch/Makefile
new file mode 100644
index 000000000000..b9bbc5d54e10
--- /dev/null
+++ b/net/prosearch/Makefile
@@ -0,0 +1,88 @@
+# New ports collection makefile for: prosearch
+# Date created: 20 May 2006
+# Whom: Oleg Alexeenkov <proler@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= prosearch
+PORTVERSION= 0.17.2
+CATEGORIES= net www
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= pro-search
+DISTNAME= pro-search-0.17.2.tar
+EXTRACT_SUFX= .bz2
+
+MAINTAINER= proler@gmail.com
+COMMENT= Powerful file search
+
+USE_BZIP2= yes
+SUB_FILES= pkg-message
+SUB_LIST= SEARCHDIR=${SEARCHDIR}
+NO_BUILD= yes
+SEARCHDIR?= www/search
+PLIST_SUB+= SEARCHDIR=${SEARCHDIR}
+
+#todo
+# user and group for crawler
+OPTIONS= \
+ CRAWLER "With crawler deps " on \
+ SAMBA " crawler with SAMBA " on \
+ RSYNC " crawler with RSYNC " off \
+ DB "With database deps " on \
+ WEB "With web deps " on \
+ MOD_PERL2 " With MOD_PERL2 " on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_WEB)
+USE_APACHE= 2.0+
+.endif
+
+.if defined(WITH_MOD_PERL2)
+RUN_DEPENDS+=\
+ ${LOCALBASE}/${APACHEMODDIR}/mod_perl.so:${PORTSDIR}/www/mod_perl2
+.endif
+
+.if defined(WITH_CRAWLER) || defined(WITH_WEB) || defined(WITH_DB)
+USE_MYSQL= YES
+.endif
+
+.if defined(WITH_CRAWLER) || defined(WITH_WEB)
+USE_PERL5_RUN= YES
+RUN_DEPENDS+=\
+${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+.endif
+
+.if defined(WITH_CRAWLER)
+RUN_DEPENDS+=\
+${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+nmap:${PORTSDIR}/security/nmap
+
+.endif
+.if defined(WITH_SAMBA)
+RUN_DEPENDS+= smbclient:${PORTSDIR}/net/samba3
+.endif
+
+.if defined(WITH_RSYNC)
+RUN_DEPENDS+= rsync:${PORTSDIR}/net/rsync
+.endif
+
+.if defined(WITH_DB)
+RUN_DEPENDS+=\
+${LOCALBASE}/libexec/mysqld:${PORTSDIR}/databases/mysql${MYSQL_VER}-server \
+mysqlhotcopy:${PORTSDIR}/databases/mysql${MYSQL_VER}-scripts
+.endif
+
+WRKSRC= ${WRKDIR}/search
+
+do-install:
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${PREFIX}/${SEARCHDIR}/
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${SEARCHDIR}
+ @${ECHO_CMD} @exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} \
+ ${SEARCHDIR:S|^${PREFIX}/|%D/|} >> ${TMPPLIST}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/net/prosearch/distinfo b/net/prosearch/distinfo
new file mode 100644
index 000000000000..b15ec5a441f5
--- /dev/null
+++ b/net/prosearch/distinfo
@@ -0,0 +1,3 @@
+MD5 (pro-search-0.17.2.tar.bz2) = a7f35c16979ee55f52c1cc73f065f662
+SHA256 (pro-search-0.17.2.tar.bz2) = 35ffecd39b86a93d126cdb2d77e5874b206fa893ef00299fba20359b040409ab
+SIZE (pro-search-0.17.2.tar.bz2) = 218030
diff --git a/net/prosearch/files/pkg-message.in b/net/prosearch/files/pkg-message.in
new file mode 100644
index 000000000000..7836b3716f8b
--- /dev/null
+++ b/net/prosearch/files/pkg-message.in
@@ -0,0 +1,19 @@
+=======================================================================
+Pro-search is now installed. If you intall it for the first time,
+you may have to follow this steps to make it work correctly:
+
+1. Create the MySQL database:
+# mysqladmin --user=root create prosearch
+2. Create a mysql user/password for prosearch:
+ (change user and/or password if requered)
+# echo "GRANT ALL ON prosearch.* TO prosearch@localhost IDENTIFIED BY 'prosearch'; FLUSH PRIVILEGES;" | mysql
+4.# cp %%PREFIX%%/%%SEARCHDIR%%/config.pl.dist %%PREFIX%%/%%SEARCHDIR%%/config.pl
+5.# ee %%PREFIX%%/%%SEARCHDIR%%/config.pl
+6. install the default prosearch database:
+# perl crawler.pl install
+7. Add alias in apache config for the prosearch web dir:
+Alias /search "%%PREFIX%%/%%SEARCHDIR%%/web"
+or
+# cp %%PREFIX%%/%%SEARCHDIR%%/tools/search.conf %%PREFIX%%/etc/apache22/Includes/
+# ee %%PREFIX%%/etc/apache22/Includes/search.conf
+=======================================================================
diff --git a/net/prosearch/pkg-descr b/net/prosearch/pkg-descr
new file mode 100644
index 000000000000..844af21b37b6
--- /dev/null
+++ b/net/prosearch/pkg-descr
@@ -0,0 +1,3 @@
+File search and navigation system
+
+WWW: http://sourceforge.net/projects/pro-search
diff --git a/net/prosearch/pkg-plist b/net/prosearch/pkg-plist
new file mode 100644
index 000000000000..f07fc05bd922
--- /dev/null
+++ b/net/prosearch/pkg-plist
@@ -0,0 +1,130 @@
+@comment @unexec if diff -q %D/%%SEARCHDIR%%/config.pl %D/%%SEARCHDIR%%/config.pl.dist; then rm %D/%%SEARCHDIR%%/config.pl; fi
+@comment #@exec if [ ! -f %B/%%SEARCHDIR%%/config.pl ]; then cp %B/%%SEARCHDIR%%/config.pl.dist %B/%%SEARCHDIR%%/config.pl; fi
+@comment #@unexec if diff -q %%PREFIX%%/etc/apache%%APACHE_VERSION%%/Includes/search.conf %D/%%SEARCHDIR%%/tools/search.conf; then rm %%PREFIX%%/etc/apache%%APACHE_VERSION%%/Includes/search.conf; fi
+@comment #@exec if [ ! -f %%PREFIX%%/etc/apache%%APACHE_VERSION%%/Includes/search.conf ]; then cp %B/%%SEARCHDIR%%/tools/search.conf %%PREFIX%%/etc/apache%%APACHE_VERSION%%/Includes/search.conf; fi
+@comment #@unexec rm %%PREFIX%%/www/apache%%APACHE_VERSION%%/data/search
+@comment #@exec touch %%PREFIX%%/www/apache%%APACHE_VERSION%%/data/search
+@comment @unexec rmdir %%SEARCHDIR%%/tmp 2>/dev/null || true
+@comment @unexec rmdir %%SEARCHDIR%%/var 2>/dev/null || true
+%%SEARCHDIR%%/010.search.purge
+%%SEARCHDIR%%/AUTHORS
+%%SEARCHDIR%%/confdef.pl
+%%SEARCHDIR%%/config.pl.dist
+%%SEARCHDIR%%/COPYING
+%%SEARCHDIR%%/crawler.pl
+%%SEARCHDIR%%/search.sh.dist
+%%SEARCHDIR%%/showactive
+%%SEARCHDIR%%/showalive
+%%SEARCHDIR%%/TODO
+%%SEARCHDIR%%/WHATSNEW
+%%SEARCHDIR%%/dcppp/dcppp.pm
+%%SEARCHDIR%%/dcppp/dcppp/clicli.pm
+%%SEARCHDIR%%/dcppp/dcppp/clihub.pm
+%%SEARCHDIR%%/dcppp/dcppp/hubcli.pm
+%%SEARCHDIR%%/dcppp/dcppp/hubhub.pm
+%%SEARCHDIR%%/doc/Makefile
+%%SEARCHDIR%%/doc/cuted.old
+%%SEARCHDIR%%/doc/doc.css
+%%SEARCHDIR%%/doc/doc.html
+%%SEARCHDIR%%/doc/doc.sgml
+%%SEARCHDIR%%/doc/doc.txt
+%%SEARCHDIR%%/doc/html2txt.pl
+%%SEARCHDIR%%/doc/make-cygwin.cmd
+%%SEARCHDIR%%/lib/psmisc.pm
+%%SEARCHDIR%%/lib/lib.js
+%%SEARCHDIR%%/lib/player.js
+%%SEARCHDIR%%/lib/psconn.pm
+%%SEARCHDIR%%/lib/pssql.pm
+%%SEARCHDIR%%/lib/psweb.pm
+%%SEARCHDIR%%/modules/chat/chatdef.pl
+%%SEARCHDIR%%/tools/cp_auto_gen.pl
+%%SEARCHDIR%%/tools/grant.sql
+%%SEARCHDIR%%/tools/search.conf
+%%SEARCHDIR%%/tools/size.sh
+%%SEARCHDIR%%/tools/test
+%%SEARCHDIR%%/tools/test.zip
+%%SEARCHDIR%%/tools/tidy
+%%SEARCHDIR%%/tools/pro-search/Makefile
+%%SEARCHDIR%%/tools/pro-search/pkg-descr
+%%SEARCHDIR%%/tools/pro-search/pkg-plist
+%%SEARCHDIR%%/tools/pro-search/files/pkg-message.in
+%%SEARCHDIR%%/web/.htaccess.dist
+%%SEARCHDIR%%/web/about.htm
+%%SEARCHDIR%%/web/base.css
+%%SEARCHDIR%%/web/boolean.htm
+%%SEARCHDIR%%/web/config.pl.dist
+%%SEARCHDIR%%/web/crawlrul.htm
+%%SEARCHDIR%%/web/help.js
+%%SEARCHDIR%%/web/help_en.js
+%%SEARCHDIR%%/web/help_ru.js
+%%SEARCHDIR%%/web/index.cgi
+%%SEARCHDIR%%/web/JsHttpRequest.js
+%%SEARCHDIR%%/web/JsHttpRequest.pm
+%%SEARCHDIR%%/web/newstyle.css
+%%SEARCHDIR%%/web/regexp.htm
+%%SEARCHDIR%%/web/robots.txt.dist
+%%SEARCHDIR%%/web/search.css
+%%SEARCHDIR%%/web/search1.css
+%%SEARCHDIR%%/web/search1.js
+%%SEARCHDIR%%/web/search2.css
+%%SEARCHDIR%%/web/dcppp/dcppp.pm
+%%SEARCHDIR%%/web/dcppp/dcppp/clicli.pm
+%%SEARCHDIR%%/web/dcppp/dcppp/clihub.pm
+%%SEARCHDIR%%/web/dcppp/dcppp/hubcli.pm
+%%SEARCHDIR%%/web/dcppp/dcppp/hubhub.pm
+%%SEARCHDIR%%/web/img/archive.png
+%%SEARCHDIR%%/web/img/audio.png
+%%SEARCHDIR%%/web/img/bat.png
+%%SEARCHDIR%%/web/img/cd.png
+%%SEARCHDIR%%/web/img/chm.png
+%%SEARCHDIR%%/web/img/dchub.png
+%%SEARCHDIR%%/web/img/dcuser.png
+%%SEARCHDIR%%/web/img/dir.png
+%%SEARCHDIR%%/web/img/doc.png
+%%SEARCHDIR%%/web/img/exec.png
+%%SEARCHDIR%%/web/img/file.png
+%%SEARCHDIR%%/web/img/firefox.png
+%%SEARCHDIR%%/web/img/ftp.png
+%%SEARCHDIR%%/web/img/gif.png
+%%SEARCHDIR%%/web/img/ie.png
+%%SEARCHDIR%%/web/img/image.png
+%%SEARCHDIR%%/web/img/ini.png
+%%SEARCHDIR%%/web/img/mov.png
+%%SEARCHDIR%%/web/img/nrg.png
+%%SEARCHDIR%%/web/img/opera.png
+%%SEARCHDIR%%/web/img/pdf.png
+%%SEARCHDIR%%/web/img/ppt.png
+%%SEARCHDIR%%/web/img/psd.png
+%%SEARCHDIR%%/web/img/res.png
+%%SEARCHDIR%%/web/img/swf.png
+%%SEARCHDIR%%/web/img/text.png
+%%SEARCHDIR%%/web/img/unk.png
+%%SEARCHDIR%%/web/img/url.png
+%%SEARCHDIR%%/web/img/video.png
+%%SEARCHDIR%%/web/img/wmv.png
+%%SEARCHDIR%%/web/img/xls.png
+%%SEARCHDIR%%/web/img/xml.png
+%%SEARCHDIR%%/web/lib/psmisc.pm
+%%SEARCHDIR%%/web/lib/lib.js
+%%SEARCHDIR%%/web/lib/player.js
+%%SEARCHDIR%%/web/lib/psconn.pm
+%%SEARCHDIR%%/web/lib/pssql.pm
+%%SEARCHDIR%%/web/lib/psweb.pm
+@dirrm %%SEARCHDIR%%/dcppp/dcppp
+@dirrm %%SEARCHDIR%%/modules/chat
+@dirrm %%SEARCHDIR%%/tools/pro-search/files
+@dirrm %%SEARCHDIR%%/tools/pro-search
+@dirrm %%SEARCHDIR%%/web/dcppp/dcppp
+@dirrm %%SEARCHDIR%%/web/dcppp
+@dirrm %%SEARCHDIR%%/web/img
+@dirrm %%SEARCHDIR%%/web/lib
+@dirrm %%SEARCHDIR%%/dcppp
+@dirrm %%SEARCHDIR%%/doc
+@dirrm %%SEARCHDIR%%/example
+@dirrm %%SEARCHDIR%%/lib
+@dirrm %%SEARCHDIR%%/modules
+@dirrm %%SEARCHDIR%%/tools
+@dirrmtry %%SEARCHDIR%%/tmp
+@dirrmtry %%SEARCHDIR%%/var
+@dirrmtry %%SEARCHDIR%%/web
+@dirrmtry %%SEARCHDIR%%