aboutsummaryrefslogtreecommitdiff
path: root/net/prosearch
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2016-05-30 17:47:59 +0000
committerRene Ladan <rene@FreeBSD.org>2016-05-30 17:47:59 +0000
commitac3963d11b948759b7ce8973c556ce0f8fc7bd96 (patch)
tree5de3c76c758d517368943ef2004d088eca0333e4 /net/prosearch
parent6a0fa26547bfb69378a3b3d422701b4e1c1ae13f (diff)
downloadports-ac3963d11b948759b7ce8973c556ce0f8fc7bd96.tar.gz
ports-ac3963d11b948759b7ce8973c556ce0f8fc7bd96.zip
Notes
Diffstat (limited to 'net/prosearch')
-rw-r--r--net/prosearch/Makefile33
1 files changed, 15 insertions, 18 deletions
diff --git a/net/prosearch/Makefile b/net/prosearch/Makefile
index d3d50a7f02b8..e13c5f4ff9e4 100644
--- a/net/prosearch/Makefile
+++ b/net/prosearch/Makefile
@@ -2,7 +2,7 @@
PORTNAME= prosearch
PORTVERSION= 0.19.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net www
MASTER_SITES= http://pro.setun.net/search/download/ SF/pro-search/pro-search/${PORTVERSION}
@@ -22,26 +22,25 @@ NO_ARCH= yes
SEARCHDIR?= www/search
PLIST_SUB+= SEARCHDIR=${SEARCHDIR} WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
-SAMBA_PORT?= net/samba36
-
-#todo
-# user and group for crawler, nginx
+#TODO user and group for crawler
OPTIONS_DEFINE= CRAWLER SAMBA RSYNC APACHE MOD_PERL2 MOD_FASTCGI \
- DB MYSQL MARIA PGSQL PGPP SQLITE SPHINX
+ DB MYSQL PGSQL PGPP SQLITE SPHINX
OPTIONS_DEFAULT= CRAWLER SAMBA APACHE DB MYSQL
-CRAWLER_DESC= With crawler deps (nmap, p5-libwww)
+CRAWLER_DESC= With crawler (nmap, p5-libwww)
SAMBA_DESC= crawler with SAMBA (file://)
RSYNC_DESC= crawler with RSYNC
APACHE_DESC= With web server apache2.2+
MOD_PERL2_DESC= With MOD_PERL2
MOD_FASTCGI_DESC= With MOD_FASTCGI
-DB_DESC= With database server deps
-MARIA_DESC= maria (mysql replace)
+DB_DESC= With both database server and client
+#MARIA_DESC= mariaDB
PGPP_DESC= postgres pure Perl connection driver
SPHINX_DESC= sphinx fulltext search engine
+#NGINX_DESC= With web server (NGINX)
-# NGINX "With web server deps (NGINX)" off
-
+#RG1_DESC= Database backend
+#OPTIONS_RADIO= RG1
+#OPTIONS_RADIO_RG1= MYSQL MARIA
.include <bsd.port.options.mk>
RUN_DEPENDS+=\
@@ -57,9 +56,7 @@ nmap:security/nmap \
p5-Net-DirectConnect>=0:net-p2p/p5-Net-DirectConnect
.endif
-.if ${PORT_OPTIONS:MSAMBA}
-RUN_DEPENDS+= smbclient:net/samba-smbclient
-.endif
+SAMBA_RUN_DEPENDS=smbclient:net/samba44
.if ${PORT_OPTIONS:MRSYNC}
RUN_DEPENDS+= rsync:net/rsync
@@ -92,24 +89,24 @@ searchd:textproc/sphinxsearch-devel
.endif
.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= client
+USES+= mysql
RUN_DEPENDS+=\
p5-DBD-mysql>=0:databases/p5-DBD-mysql
.endif
.if ${PORT_OPTIONS:MDB} && ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= server
+USES+= mysql:server
.endif
.if ${PORT_OPTIONS:MMARIA}
RUN_DEPENDS+=\
p5-DBD-mysql>=0:databases/p5-DBD-mysql \
-${LOCALBASE}bin/mysql:databases/mariadb-client
+${LOCALBASE}bin/mysql:databases/mariadb100-client
.endif
.if ${PORT_OPTIONS:MDB} && ${PORT_OPTIONS:MMARIA}
RUN_DEPENDS+=\
-${LOCALBASE}/libexec/mysqld:databases/mariadb-server
+${LOCALBASE}/libexec/mysqld:databases/mariadb100-server
.endif
.if ${PORT_OPTIONS:MPGSQL}