aboutsummaryrefslogtreecommitdiff
path: root/net/psi/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2005-05-19 05:51:29 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2005-05-19 05:51:29 +0000
commitac365e7fac0c9a21d14ef1411a13559122a58199 (patch)
treec1ebe625fafecb238cb7949b2837ab0ad03cd52f /net/psi/Makefile
parent54d74f05d7532c7056fddd6e51429a1be865a1db (diff)
downloadports-ac365e7fac0c9a21d14ef1411a13559122a58199.tar.gz
ports-ac365e7fac0c9a21d14ef1411a13559122a58199.zip
Notes
Diffstat (limited to 'net/psi/Makefile')
-rw-r--r--net/psi/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/net/psi/Makefile b/net/psi/Makefile
index 3408aac1b0fd..72cda488f54a 100644
--- a/net/psi/Makefile
+++ b/net/psi/Makefile
@@ -34,6 +34,10 @@ CONFIGURE_ARGS= --prefix=${PREFIX} --qtdir=${X11BASE} \
MAKE_ARGS+= QTDIR=${X11BASE} \
QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++
+OPTIONS= KDE "Enable KDE tray support" on
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_KDE)
LIB_DEPENDS= kdecore:${PORTSDIR}/x11/kdelibs3
_NO_KDE_CONFTARGET_HACK= yes
@@ -43,15 +47,6 @@ CONFIGURE_ARGS+= --disable-kde
PLIST_SUB+= KDE="@comment "
.endif
-pre-everything::
- @${ECHO} "============================================================="
- @${ECHO}
- @${ECHO} "You can build ${PKGNAME} with the following options:"
- @${ECHO}
- @${ECHO} "WITH_KDE enable kde tray support"
- @${ECHO}
- @${ECHO} "============================================================="
-
pre-install:
.if defined(WITH_KDE)
@for size in 16x16 32x32 48x48; do \
@@ -62,4 +57,4 @@ pre-install:
post-install:
${STRIP_CMD} ${PREFIX}/bin/psi
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>