aboutsummaryrefslogtreecommitdiff
path: root/net/psi
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2004-01-11 17:38:02 +0000
committerPete Fritchman <petef@FreeBSD.org>2004-01-11 17:38:02 +0000
commite059d8e5804d52fbe485ece949aa0d03b697e409 (patch)
tree2ed25813115c1710a38eba569a8d644b0f4bb98b /net/psi
parent886ae5bd0533a1f63ca6189e2e73b6e51830ab66 (diff)
downloadports-e059d8e5804d52fbe485ece949aa0d03b697e409.tar.gz
ports-e059d8e5804d52fbe485ece949aa0d03b697e409.zip
Notes
Diffstat (limited to 'net/psi')
-rw-r--r--net/psi/Makefile7
-rw-r--r--net/psi/files/patch-configure60
2 files changed, 60 insertions, 7 deletions
diff --git a/net/psi/Makefile b/net/psi/Makefile
index 5dac924338bb..b08115c3f766 100644
--- a/net/psi/Makefile
+++ b/net/psi/Makefile
@@ -7,6 +7,7 @@
PORTNAME= psi
PORTVERSION= 0.9.1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,11 +18,9 @@ COMMENT= A Qt-based Jabber client
HAS_CONFIGURE= yes
USE_X_PREFIX= yes
USE_BZIP2= yes
-USE_GMAKE= yes
USE_QT_VER= 3
-CONFIGURE_ENV= QTDIR=${X11BASE} \
- QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++
-CONFIGURE_ARGS= --prefix=${PREFIX}
+CONFIGURE_ENV= QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++
+CONFIGURE_ARGS= --prefix=${PREFIX} --qtdir=${X11BASE} --disable-kde
MAKE_ARGS+= QTDIR=${X11BASE} \
QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++
diff --git a/net/psi/files/patch-configure b/net/psi/files/patch-configure
index 8fa391c8090c..2c7345835f8e 100644
--- a/net/psi/files/patch-configure
+++ b/net/psi/files/patch-configure
@@ -1,9 +1,49 @@
$FreeBSD$
-Hack configure to eat autogenerated qt options and to fix a bashism (type -p).
+Hack configure to eat autogenerated qt options, to fix a bashism (type -p),
+to avoid using expr, and to do the main Makefile make(1) compatible.
---- configure.orig Wed Dec 10 03:10:03 2003
-+++ configure Wed Jan 7 16:30:11 2004
+--- configure.orig Wed Dec 10 01:10:03 2003
++++ configure Sat Jan 10 15:52:00 2004
+@@ -27,32 +27,32 @@
+ while [ $# -gt 0 ]; do
+ case "$1" in
+ --prefix=*)
+- PREFIX=`expr "${1}" : "--prefix=\(.*\)"`
++ PREFIX="${1#--prefix=}"
+ shift
+ ;;
+
+ --bindir=*)
+- BINDIR=`expr "${1}" : "--bindir=\(.*\)"`
++ BINDIR="${1#--bindir=}"
+ shift
+ ;;
+
+ --libdir=*)
+- LIBDIR=`expr "${1}" : "--libdir=\(.*\)"`
++ LIBDIR="${1#--libdir=}"
+ shift
+ ;;
+
+ --qtdir=*)
+- QTDIR=`expr "${1}" : "--qtdir=\(.*\)"`
++ QTDIR="${1#--qtdir=}"
+ shift
+ ;;
+
+ --with-zlib-inc=*)
+- QC_WITH_ZLIB_INC=`expr "${1}" : "--with-zlib-inc=\(.*\)"`
++ QC_WITH_ZLIB_INC="${1#--with-zlib-inc=}"
+ shift
+ ;;
+
+ --with-zlib-lib=*)
+- QC_WITH_ZLIB_LIB=`expr "${1}" : "--with-zlib-lib=\(.*\)"`
++ QC_WITH_ZLIB_LIB="${1#--with-zlib-lib=}"
+ shift
+ ;;
+
@@ -81,6 +81,8 @@
shift
;;
@@ -22,3 +62,17 @@ Hack configure to eat autogenerated qt options and to fix a bashism (type -p).
if [ -x "$qm" ]; then
if [ "$QC_DEBUG" = "Y" ]; then
echo qmake found in $qm
+@@ -917,13 +919,6 @@
+ echo
+ exit 1;
+ fi
+-cat >Makefile.tmp <<EOT
+-export QTDIR = $QTDIR
+-EOT
+-cat Makefile >> Makefile.tmp
+-rm -f Makefile
+-cp -f Makefile.tmp Makefile
+-rm -f Makefile.tmp
+
+ echo
+ echo Good, your configure finished. Now run \'make\'.