aboutsummaryrefslogtreecommitdiff
path: root/net/pvm++/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-12-22 13:38:32 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-12-22 13:38:32 +0000
commitf004bf7ce17bb8700f07832c6b78ac649bdb3221 (patch)
tree3f4cd9d60ab9258e2696139f4a030495ec6e98f7 /net/pvm++/Makefile
parent088118876dc9c1f5799bd2bfe25a46fc3bce39b9 (diff)
downloadports-f004bf7ce17bb8700f07832c6b78ac649bdb3221.tar.gz
ports-f004bf7ce17bb8700f07832c6b78ac649bdb3221.zip
Notes
Diffstat (limited to 'net/pvm++/Makefile')
-rw-r--r--net/pvm++/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/net/pvm++/Makefile b/net/pvm++/Makefile
index 1c7403f86b76..456443177d8b 100644
--- a/net/pvm++/Makefile
+++ b/net/pvm++/Makefile
@@ -8,6 +8,7 @@
PORTNAME= pvm++
PORTVERSION= 0.6.0
+PORTREVISION= 1
CATEGORIES= net parallel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://pvm-plus-plus.sourceforge.net/pub/%SUBDIR%/ \
@@ -16,16 +17,19 @@ MASTER_SITE_SUBDIR= ${PORTNAME:S:+:-plus:g}
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/bin/pvm:${PORTSDIR}/net/pvm
+BUILD_DEPENDS= ${LOCALBASE}/lib/libpvm3.a:${PORTSDIR}/net/pvm
-GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --with-pvm-incs=${LOCALBASE}/include \
+ --with-pvm-libs=${LOCALBASE}/lib
INSTALLS_SHLIB= yes
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/pvm++
- @${CP} ${WRKSRC}/doc/*.png ${WRKSRC}/doc/*.html ${PREFIX}/share/doc/pvm++
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.png ${DOCSDIR}
.endif
.include <bsd.port.mk>