aboutsummaryrefslogtreecommitdiff
path: root/net/pxe-pdhcp
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2013-06-03 04:26:24 +0000
committerHiroki Sato <hrs@FreeBSD.org>2013-06-03 04:26:24 +0000
commit8b5bbb8c9d594411938e606bcfe1d0e596c74749 (patch)
tree888f938c20c1bbf06b68e627fa014ba13f87803d /net/pxe-pdhcp
parent3ca58bde3a020c62e01fac4e82d8f0270e5c447f (diff)
downloadports-8b5bbb8c9d594411938e606bcfe1d0e596c74749.tar.gz
ports-8b5bbb8c9d594411938e606bcfe1d0e596c74749.zip
Notes
Diffstat (limited to 'net/pxe-pdhcp')
-rw-r--r--net/pxe-pdhcp/Makefile28
-rw-r--r--net/pxe-pdhcp/distinfo2
-rw-r--r--net/pxe-pdhcp/files/Makefile.in22
-rw-r--r--net/pxe-pdhcp/files/pxe-pdhcp.894
-rw-r--r--net/pxe-pdhcp/pkg-descr8
5 files changed, 154 insertions, 0 deletions
diff --git a/net/pxe-pdhcp/Makefile b/net/pxe-pdhcp/Makefile
new file mode 100644
index 000000000000..96321a63a645
--- /dev/null
+++ b/net/pxe-pdhcp/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= pxe-pdhcp
+PORTVERSION= 0.0.2007
+CATEGORIES= net
+MASTER_SITES= http://people.allbsd.org/~hrs/FreeBSD/
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Preboot Execution Environment server
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/README.md
+
+WRKSRC= ${WRKDIR}/frsyuki-${PORTNAME}-a201b88
+SUB_FILES= Makefile
+MAKE_JOBS_SAFE= yes
+MAKE_ENV= PORTDOCS=${PORT_OPTIONS:MDOCS}
+PLIST_FILES= sbin/${PORTNAME}
+
+PORTDOCS= README.md
+MAN8= ${PORTNAME}.8
+
+OPTIONS_DEFINE= DOCS
+
+post-extract: apply-slist
+ @${INSTALL_DATA} ${WRKDIR}/Makefile ${FILESDIR}/${PORTNAME}.8 ${WRKSRC}
+
+.include <bsd.port.mk>
diff --git a/net/pxe-pdhcp/distinfo b/net/pxe-pdhcp/distinfo
new file mode 100644
index 000000000000..4a8ad05148d3
--- /dev/null
+++ b/net/pxe-pdhcp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pxe-pdhcp-0.0.2007.tar.gz) = 7a3afce183abcd23619c52c037477c1ba99fe440bb6ea3e15233c7a475f69a5a
+SIZE (pxe-pdhcp-0.0.2007.tar.gz) = 8134
diff --git a/net/pxe-pdhcp/files/Makefile.in b/net/pxe-pdhcp/files/Makefile.in
new file mode 100644
index 000000000000..16abce10396e
--- /dev/null
+++ b/net/pxe-pdhcp/files/Makefile.in
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PROG= pxe-pdhcp
+SRCS= pdhcp.c pxe-pdhcp.c
+MAN= ${PROG}.8
+NO_MANCOMPRESS=
+
+PREFIX?= /usr/local
+LOCALBASE?= /usr/local
+MANDIR?= ${PREFIX}/man/man
+BINDIR?= ${PREFIX}/sbin
+
+.if !empty(PORTDOCS)
+FILES= README.md
+FILESDIR?= ${PREFIX}/share/doc/${PROG}
+
+beforeinstall:
+ mkdir -p ${FILESDIR}
+.endif
+
+.include <bsd.prog.mk>
+
diff --git a/net/pxe-pdhcp/files/pxe-pdhcp.8 b/net/pxe-pdhcp/files/pxe-pdhcp.8
new file mode 100644
index 000000000000..0668732b3c94
--- /dev/null
+++ b/net/pxe-pdhcp/files/pxe-pdhcp.8
@@ -0,0 +1,94 @@
+.\" Copyright (c) 2007 FURUHASHI Sadayuki
+.\"
+.\" Permission is hereby granted, free of charge, to any person
+.\" obtaining a copy of this software and associated documentation
+.\" files (the "Software"), to deal in the Software without
+.\" restriction, including without limitation the rights to use, copy,
+.\" modify, merge, publish, distribute, sublicense, and/or sell copies
+.\" of the Software, and to permit persons to whom the Software is
+.\" furnished to do so, subject to the following conditions:
+.\"
+.\" The above copyright notice and this permission notice shall be
+.\" included in all copies or substantial portions of the Software.
+.\"
+.\" THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+.\" EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+.\" MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+.\" NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+.\" HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+.\" WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+.\" OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+.\" DEALINGS IN THE SOFTWARE.
+.\"
+.\" dhcp.h is provided by ISC-DHCP copyright by Internet Systems
+.\" Consortium licensed under MIT license. the original software and
+.\" related information is available at
+.\" https://www.isc.org/software/dhcp/.
+.\"
+.\" $FreeBSD$
+.\"
+.Dd June 3, 2013
+.Dt PXE-PDHCP
+.Os
+.Sh NAME
+.Nm pxe-pdhcp
+.Nd "An implementation of Preboot Execution Environment (PXE) server"
+.Sh SYNOPSIS
+.Nm
+.Op Fl d
+.Op Fl i Ar interface
+.Op Fl l Ar listen_address
+.Op Fl t Ar tftp_address
+.Op Fl b Ar broadcast address
+.Op Ar nbp_name
+.Sh DESCRIPTION
+The
+.Nm
+is an implementation of Preboot Execution Environment (PXE) server.
+.Nm
+works with DHCP server running on another host. The DHCP server
+doesn't need to be configured for any PXE specific options.
+This means that you can set up network boot environment without
+re-configuring existent DHCP server.
+.Pp
+.Nm
+listens on two well-known ports (67/udp and 68/udp) so the root
+privilege is needed to run.
+.Pp
+With
+.Fl d
+option,
+.Nm
+runs on foreground.
+This option is useful for debugging.
+.Pp
+Specify nework interface name
+.Pq Li eth0 for example, on Linux
+to
+.Fl i
+option.
+.Pp
+If the network interface has more than one IP address,
+use
+.Fl l ,
+.Fl t ,
+.Fl b
+options.
+.Fl i
+or
+.Po Fl l ,
+.Fl t
+and
+.Fl b
+option
+.Pc
+is required.
+.Pp
+Finally specify the path of Network Bootstrap Program on the TFTP server to
+.Ar nbp name
+option.
+It will be
+.Li pxelinux.0
+if you are using PXELINUX.
+.Sh AUTHORS
+.An FURUHASHI Sadayuki
diff --git a/net/pxe-pdhcp/pkg-descr b/net/pxe-pdhcp/pkg-descr
new file mode 100644
index 000000000000..6f68e03b8fa1
--- /dev/null
+++ b/net/pxe-pdhcp/pkg-descr
@@ -0,0 +1,8 @@
+An implementation of Preboot Execution Environment (PXE) server.
+
+pxe-pdhcp works with DHCP server running on another host. The DHCP
+server doesn't need to be configured for any PXE specific
+options. This means that you can set up network boot environment
+without re-configuring existent DHCP server.
+
+WWW: https://github.com/frsyuki/pxe-pdhcp