aboutsummaryrefslogtreecommitdiff
path: root/net/pxe
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2002-10-11 00:03:19 +0000
committerAnders Nordby <anders@FreeBSD.org>2002-10-11 00:03:19 +0000
commit6e17e6bb4ce6f9332aa8ccdd11ae185f9f31b0b7 (patch)
treef9f2ae0c72e0c11f8196fbf7ec6bfa7473cf8ec3 /net/pxe
parent53fa9783e9a36e1385b109375a5f5d255cd0c090 (diff)
downloadports-6e17e6bb4ce6f9332aa8ccdd11ae185f9f31b0b7.tar.gz
ports-6e17e6bb4ce6f9332aa8ccdd11ae185f9f31b0b7.zip
Notes
Diffstat (limited to 'net/pxe')
-rw-r--r--net/pxe/Makefile2
-rw-r--r--net/pxe/distinfo2
-rw-r--r--net/pxe/files/patch-logfile.cc17
3 files changed, 19 insertions, 2 deletions
diff --git a/net/pxe/Makefile b/net/pxe/Makefile
index 5d571a9e33d6..a39bea528e21 100644
--- a/net/pxe/Makefile
+++ b/net/pxe/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pxe
-PORTVERSION= 1.2
+PORTVERSION= 1.3
CATEGORIES= net
MASTER_SITES= http://www.kano.org.uk/projects/pxe/ \
ftp://ftp.nuug.no/pub/anders/distfiles/
diff --git a/net/pxe/distinfo b/net/pxe/distinfo
index f9a51b6ea930..a6f414ac7e54 100644
--- a/net/pxe/distinfo
+++ b/net/pxe/distinfo
@@ -1 +1 @@
-MD5 (pxe-1.2.tar.gz) = c7a9573e986ef62900a7b90b740bfe0b
+MD5 (pxe-1.3.tar.gz) = 3866c86ddada2bd4a4a01bb8b79cc951
diff --git a/net/pxe/files/patch-logfile.cc b/net/pxe/files/patch-logfile.cc
new file mode 100644
index 000000000000..5eed667bbc70
--- /dev/null
+++ b/net/pxe/files/patch-logfile.cc
@@ -0,0 +1,17 @@
+--- logfile.cc.orig Wed Oct 2 22:41:50 2002
++++ logfile.cc Wed Oct 2 22:42:09 2002
+@@ -58,12 +58,13 @@
+ {
+ /* open the file */
+ umask(077);
+- logfile = new std::fstream(filename, std::ios::out|std::ios::app, 0644);
++ logfile = new std::fstream(filename, std::ios::out|std::ios::app);
+ if(logfile == NULL)
+ {
+ std::cerr << "Error: LogFile::Open:open(): " << strerror(errno) <<"\n";
+ exit(-1);
+ }
++ chmod(filename, 0644);
+ }
+
+