aboutsummaryrefslogtreecommitdiff
path: root/net/pxe
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-24 14:52:34 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-24 14:52:34 +0000
commitde4790f57a5e8587ec6a27a69869a598cd164fa0 (patch)
tree97aa8de3c834193c2469ed8bd5dd3399fd1590ba /net/pxe
parent271ed02c800400de75616beac425bfdd1b543aea (diff)
downloadports-de4790f57a5e8587ec6a27a69869a598cd164fa0.tar.gz
ports-de4790f57a5e8587ec6a27a69869a598cd164fa0.zip
Notes
Diffstat (limited to 'net/pxe')
-rw-r--r--net/pxe/Makefile27
-rw-r--r--net/pxe/pkg-plist8
2 files changed, 12 insertions, 23 deletions
diff --git a/net/pxe/Makefile b/net/pxe/Makefile
index 372265249cec..05e1c514906a 100644
--- a/net/pxe/Makefile
+++ b/net/pxe/Makefile
@@ -18,25 +18,22 @@ CONFIGURE_ARGS+= --with-config=${PREFIX}/etc/pxe.conf \
--with-log=/var/log/pxe.log \
--with-setuid=nobody
-DOCS= Changes INSTALL LICENCE README THANKS
+PORTDOCS= Changes INSTALL LICENCE README THANKS
+PLIST_FILES= sbin/pxe etc/pxe.conf.sample
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= DOCS
post-patch:
- ${REINPLACE_CMD} -e 's|/tmp/pxe.pid|/var/run/pxe.pid|' ${WRKSRC}/autoconf.h.in
+ ${REINPLACE_CMD} -e 's|/tmp/pxe.pid|/var/run/pxe.pid|' \
+ ${WRKSRC}/autoconf.h.in
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/pxe ${PREFIX}/sbin/
- ${INSTALL_DATA} ${WRKSRC}/pxe.conf ${PREFIX}/etc/pxe.conf.sample
-.if !defined(NOPORTDOCS)
- @${INSTALL} -d -m 0755 ${DOCSDIR}
-.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+ ${INSTALL_PROGRAM} ${WRKSRC}/pxe ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_DATA} ${WRKSRC}/pxe.conf \
+ ${STAGEDIR}${PREFIX}/etc/pxe.conf.sample
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
-post-install:
- ${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pxe/pkg-plist b/net/pxe/pkg-plist
deleted file mode 100644
index df1295d12564..000000000000
--- a/net/pxe/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-sbin/pxe
-etc/pxe.conf.sample
-%%PORTDOCS%%share/doc/pxe/Changes
-%%PORTDOCS%%share/doc/pxe/INSTALL
-%%PORTDOCS%%share/doc/pxe/LICENCE
-%%PORTDOCS%%share/doc/pxe/README
-%%PORTDOCS%%share/doc/pxe/THANKS
-%%PORTDOCS%%@dirrm share/doc/pxe