aboutsummaryrefslogtreecommitdiff
path: root/net/py-bittorrent-devel
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-10-12 12:28:54 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-10-12 12:28:54 +0000
commitadf6f31761b912e89c2f52cbd0ce5a3ae6a0c832 (patch)
tree195902867590192451c0165dcaea57e8e76078cf /net/py-bittorrent-devel
parent282c97a3b5cf9d3b24f025ce9cc9a6ab11069132 (diff)
downloadports-adf6f31761b912e89c2f52cbd0ce5a3ae6a0c832.tar.gz
ports-adf6f31761b912e89c2f52cbd0ce5a3ae6a0c832.zip
Notes
Diffstat (limited to 'net/py-bittorrent-devel')
-rw-r--r--net/py-bittorrent-devel/Makefile23
-rw-r--r--net/py-bittorrent-devel/distinfo4
-rw-r--r--net/py-bittorrent-devel/files/extra-psyco-patch-bittorrent-console.py24
-rw-r--r--net/py-bittorrent-devel/files/extra-psyco-patch-bittorrent-curses.py24
-rw-r--r--net/py-bittorrent-devel/files/extra-psyco-patch-bittorrent-tracker.py24
-rw-r--r--net/py-bittorrent-devel/files/extra-psyco-patch-bittorrent.py24
-rw-r--r--net/py-bittorrent-devel/files/extra-psyco-patch-changetracker-console.py24
-rw-r--r--net/py-bittorrent-devel/files/extra-psyco-patch-launchmany-console.py24
-rw-r--r--net/py-bittorrent-devel/files/extra-psyco-patch-launchmany-curses.py24
-rw-r--r--net/py-bittorrent-devel/files/extra-psyco-patch-maketorrent-console.py24
-rw-r--r--net/py-bittorrent-devel/files/extra-psyco-patch-maketorrent.py24
-rw-r--r--net/py-bittorrent-devel/files/extra-psyco-patch-torrentinfo-console.py24
-rw-r--r--net/py-bittorrent-devel/files/patch-BitTorrent__RawServer_twisted.py11
-rw-r--r--net/py-bittorrent-devel/pkg-plist8
14 files changed, 139 insertions, 147 deletions
diff --git a/net/py-bittorrent-devel/Makefile b/net/py-bittorrent-devel/Makefile
index 17a07e618812..0f802199eae1 100644
--- a/net/py-bittorrent-devel/Makefile
+++ b/net/py-bittorrent-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= BitTorrent
-PORTVERSION= 4.1.4
-PORTREVISION= 1
+PORTVERSION= 4.1.6
PORTEPOCH= 1
CATEGORIES?= net python
MASTER_SITES= http://www.bittorrent.com/dl/ \
@@ -20,6 +19,7 @@ MAINTAINER= lioux@FreeBSD.org
COMMENT?= A peer-to-peer tool for distributing files written in Python
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/dns/__init__.py:${PORTSDIR}/dns/py-dnspython \
+ ${PYTHON_SITELIBDIR}/twisted/plugins/__init__.py:${PORTSDIR}/devel/py-twistedCore \
${PYTHON_SITELIBDIR}/Crypto/__init__.py:${PORTSDIR}/security/py-pycrypto
USE_PYTHON= yes
@@ -56,8 +56,6 @@ WITHOUT_PSYCO= yes
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pygtk.py:${PORTSDIR}/x11-toolkits/py-gtk2
PLIST_FILES+= \
- bin/maketorrent \
- bin/bittorrent \
share/pixmaps/BitTorrent/bittorrent.ico \
share/pixmaps/BitTorrent/broken.png \
share/pixmaps/BitTorrent/finished.png \
@@ -69,7 +67,10 @@ PLIST_FILES+= \
share/pixmaps/BitTorrent/play.png \
share/pixmaps/BitTorrent/queued.png \
share/pixmaps/BitTorrent/remove.png \
- share/pixmaps/BitTorrent/running.png
+ share/pixmaps/BitTorrent/running.png \
+ share/pixmaps/BitTorrent/status-natted.png \
+ share/pixmaps/BitTorrent/status-running.png \
+ share/pixmaps/BitTorrent/status-stopped.png
PLIST_SUB+= GUI=""
.else
@@ -81,7 +82,7 @@ PLIST_SUB+= GUI="@comment "
.ifndef(WITHOUT_PSYCO)
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
-EXTRA_PATCHES+= \
+EXTRA_PATCHES+= \
${FILESDIR}/extra-psyco-patch-bittorrent-console.py \
${FILESDIR}/extra-psyco-patch-bittorrent-curses.py \
${FILESDIR}/extra-psyco-patch-bittorrent-tracker.py \
@@ -92,11 +93,6 @@ EXTRA_PATCHES+= \
${FILESDIR}/extra-psyco-patch-maketorrent-console.py \
${FILESDIR}/extra-psyco-patch-maketorrent.py \
${FILESDIR}/extra-psyco-patch-torrentinfo-console.py
-
-PLIST_FILES+= \
- ${PYTHON_SITELIBDIR:S|^${PYTHONBASE}/||}/BitTorrent/PSYCO.py \
- ${PYTHON_SITELIBDIR:S|^${PYTHONBASE}/||}/BitTorrent/PSYCO.pyc \
- ${PYTHON_SITELIBDIR:S|^${PYTHONBASE}/||}/BitTorrent/PSYCO.pyo
.endif
pre-everything::
@@ -113,11 +109,8 @@ post-patch:
${XARGS} -x -n 10 \
${REINPLACE_CMD} -E \
-e 's|whrandom|random|' \
+ -e 's|reuse=False|reuse=True|' \
-e 's|/usr/bin/env python.*|${LOCALBASE}/bin/python|'
-.ifndef(WITHOUT_PSYCO)
-# activate psyco optimization
- @${ECHO_CMD} 'psyco = 1' > ${WRKSRC}/BitTorrent/PSYCO.py
-.endif
post-install:
# set proper permissions
diff --git a/net/py-bittorrent-devel/distinfo b/net/py-bittorrent-devel/distinfo
index 021a117e674d..0f52b8a6ea0f 100644
--- a/net/py-bittorrent-devel/distinfo
+++ b/net/py-bittorrent-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (BitTorrent-4.1.4.tar.gz) = 1d0f85eb5cd4ac219853e2e6709f5847
-SIZE (BitTorrent-4.1.4.tar.gz) = 2016856
+MD5 (BitTorrent-4.1.6.tar.gz) = ba371b39ee6bce98775e6c346d5e8b58
+SIZE (BitTorrent-4.1.6.tar.gz) = 2313097
diff --git a/net/py-bittorrent-devel/files/extra-psyco-patch-bittorrent-console.py b/net/py-bittorrent-devel/files/extra-psyco-patch-bittorrent-console.py
index 06fdd83e5526..17e63fdd1a00 100644
--- a/net/py-bittorrent-devel/files/extra-psyco-patch-bittorrent-console.py
+++ b/net/py-bittorrent-devel/files/extra-psyco-patch-bittorrent-console.py
@@ -1,18 +1,16 @@
---- bittorrent-console.py.orig Tue Aug 23 22:49:16 2005
-+++ bittorrent-console.py Tue Aug 23 22:49:55 2005
-@@ -14,6 +14,15 @@
+--- bittorrent-console.py Wed Oct 12 01:08:15 2005
++++ bittorrent-console.py Wed Oct 12 07:57:46 2005
+@@ -14,6 +14,13 @@
from __future__ import division
-+from BitTorrent import PSYCO
-+if PSYCO.psyco:
-+ try:
-+ import psyco
-+ assert psyco.__version__ >= 0x010300f0
-+ psyco.full()
-+ except:
-+ pass
++try:
++ import psyco
++ assert psyco.__version__ >= 0x010300f0
++ psyco.full()
++except:
++ pass
+
- import gettext
- gettext.install('bittorrent', 'locale')
+ from BitTorrent.platform import install_translation
+ install_translation()
diff --git a/net/py-bittorrent-devel/files/extra-psyco-patch-bittorrent-curses.py b/net/py-bittorrent-devel/files/extra-psyco-patch-bittorrent-curses.py
index 51f59f66073a..b46155e5bcb9 100644
--- a/net/py-bittorrent-devel/files/extra-psyco-patch-bittorrent-curses.py
+++ b/net/py-bittorrent-devel/files/extra-psyco-patch-bittorrent-curses.py
@@ -1,18 +1,16 @@
---- bittorrent-curses.py.orig Tue Aug 23 22:49:16 2005
-+++ bittorrent-curses.py Tue Aug 23 22:49:59 2005
-@@ -15,6 +15,15 @@
+--- bittorrent-curses.py Wed Oct 12 01:08:15 2005
++++ bittorrent-curses.py Wed Oct 12 07:57:28 2005
+@@ -15,6 +15,13 @@
from __future__ import division
-+from BitTorrent import PSYCO
-+if PSYCO.psyco:
-+ try:
-+ import psyco
-+ assert psyco.__version__ >= 0x010300f0
-+ psyco.full()
-+ except:
-+ pass
++try:
++ import psyco
++ assert psyco.__version__ >= 0x010300f0
++ psyco.full()
++except:
++ pass
+
- import gettext
- gettext.install('bittorrent', 'locale')
+ from BitTorrent.platform import install_translation
+ install_translation()
diff --git a/net/py-bittorrent-devel/files/extra-psyco-patch-bittorrent-tracker.py b/net/py-bittorrent-devel/files/extra-psyco-patch-bittorrent-tracker.py
index 384b9ba883a7..d2e5b60d36d2 100644
--- a/net/py-bittorrent-devel/files/extra-psyco-patch-bittorrent-tracker.py
+++ b/net/py-bittorrent-devel/files/extra-psyco-patch-bittorrent-tracker.py
@@ -1,18 +1,16 @@
---- bittorrent-tracker.py.orig Tue Aug 23 22:49:16 2005
-+++ bittorrent-tracker.py Tue Aug 23 22:50:14 2005
-@@ -12,6 +12,15 @@
+--- bittorrent-tracker.py Wed Oct 12 01:08:15 2005
++++ bittorrent-tracker.py Wed Oct 12 07:57:55 2005
+@@ -12,6 +12,13 @@
# Written by Bram Cohen
-+from BitTorrent import PSYCO
-+if PSYCO.psyco:
-+ try:
-+ import psyco
-+ assert psyco.__version__ >= 0x010300f0
-+ psyco.full()
-+ except:
-+ pass
++try:
++ import psyco
++ assert psyco.__version__ >= 0x010300f0
++ psyco.full()
++except:
++ pass
+
if __name__ == '__main__':
- import gettext
- gettext.install('bittorrent', 'locale')
+ from BitTorrent.platform import install_translation
+ install_translation()
diff --git a/net/py-bittorrent-devel/files/extra-psyco-patch-bittorrent.py b/net/py-bittorrent-devel/files/extra-psyco-patch-bittorrent.py
index 87111677207f..d4d8ba81d578 100644
--- a/net/py-bittorrent-devel/files/extra-psyco-patch-bittorrent.py
+++ b/net/py-bittorrent-devel/files/extra-psyco-patch-bittorrent.py
@@ -1,18 +1,16 @@
---- bittorrent.py.orig Tue Aug 23 22:49:16 2005
-+++ bittorrent.py Tue Aug 23 22:50:20 2005
-@@ -14,6 +14,15 @@
+--- bittorrent.py Wed Oct 12 01:08:18 2005
++++ bittorrent.py Wed Oct 12 07:58:12 2005
+@@ -14,6 +14,13 @@
from __future__ import division
-+from BitTorrent import PSYCO
-+if PSYCO.psyco:
-+ try:
-+ import psyco
-+ assert psyco.__version__ >= 0x010300f0
-+ psyco.full()
-+ except:
-+ pass
++try:
++ import psyco
++ assert psyco.__version__ >= 0x010300f0
++ psyco.full()
++except:
++ pass
+
- from BitTorrent.platform import locale_root
+ from BitTorrent.platform import install_translation
+ install_translation()
- import gettext
diff --git a/net/py-bittorrent-devel/files/extra-psyco-patch-changetracker-console.py b/net/py-bittorrent-devel/files/extra-psyco-patch-changetracker-console.py
index 050a3bb2fe3c..8e8ded07a1f0 100644
--- a/net/py-bittorrent-devel/files/extra-psyco-patch-changetracker-console.py
+++ b/net/py-bittorrent-devel/files/extra-psyco-patch-changetracker-console.py
@@ -1,18 +1,16 @@
---- changetracker-console.py.orig Tue Aug 23 22:49:16 2005
-+++ changetracker-console.py Tue Aug 23 22:50:25 2005
-@@ -12,6 +12,15 @@
+--- changetracker-console.py Wed Oct 12 01:08:18 2005
++++ changetracker-console.py Wed Oct 12 07:58:18 2005
+@@ -12,6 +12,13 @@
# Written by Henry 'Pi' James and Bram Cohen
-+from BitTorrent import PSYCO
-+if PSYCO.psyco:
-+ try:
-+ import psyco
-+ assert psyco.__version__ >= 0x010300f0
-+ psyco.full()
-+ except:
-+ pass
++try:
++ import psyco
++ assert psyco.__version__ >= 0x010300f0
++ psyco.full()
++except:
++ pass
+
- import gettext
- gettext.install('bittorrent', 'locale')
+ from BitTorrent.platform import install_translation
+ install_translation()
diff --git a/net/py-bittorrent-devel/files/extra-psyco-patch-launchmany-console.py b/net/py-bittorrent-devel/files/extra-psyco-patch-launchmany-console.py
index d6957efec28e..0a885f9d4c2d 100644
--- a/net/py-bittorrent-devel/files/extra-psyco-patch-launchmany-console.py
+++ b/net/py-bittorrent-devel/files/extra-psyco-patch-launchmany-console.py
@@ -1,18 +1,16 @@
---- launchmany-console.py.orig Tue Aug 23 22:49:16 2005
-+++ launchmany-console.py Tue Aug 23 22:50:30 2005
-@@ -12,6 +12,15 @@
+--- launchmany-console.py Wed Oct 12 01:08:27 2005
++++ launchmany-console.py Wed Oct 12 07:58:23 2005
+@@ -12,6 +12,13 @@
# Written by John Hoffman
-+from BitTorrent import PSYCO
-+if PSYCO.psyco:
-+ try:
-+ import psyco
-+ assert psyco.__version__ >= 0x010300f0
-+ psyco.full()
-+ except:
-+ pass
++try:
++ import psyco
++ assert psyco.__version__ >= 0x010300f0
++ psyco.full()
++except:
++ pass
+
if __name__ == '__main__':
- import gettext
- gettext.install('bittorrent', 'locale')
+ from BitTorrent.platform import install_translation
+ install_translation()
diff --git a/net/py-bittorrent-devel/files/extra-psyco-patch-launchmany-curses.py b/net/py-bittorrent-devel/files/extra-psyco-patch-launchmany-curses.py
index af976bfae13f..6f73f927141b 100644
--- a/net/py-bittorrent-devel/files/extra-psyco-patch-launchmany-curses.py
+++ b/net/py-bittorrent-devel/files/extra-psyco-patch-launchmany-curses.py
@@ -1,18 +1,16 @@
---- launchmany-curses.py.orig Tue Aug 23 22:49:16 2005
-+++ launchmany-curses.py Tue Aug 23 22:50:36 2005
-@@ -14,6 +14,15 @@
+--- launchmany-curses.py Wed Oct 12 01:08:27 2005
++++ launchmany-curses.py Wed Oct 12 07:58:27 2005
+@@ -14,6 +14,13 @@
from __future__ import division
-+from BitTorrent import PSYCO
-+if PSYCO.psyco:
-+ try:
-+ import psyco
-+ assert psyco.__version__ >= 0x010300f0
-+ psyco.full()
-+ except:
-+ pass
++try:
++ import psyco
++ assert psyco.__version__ >= 0x010300f0
++ psyco.full()
++except:
++ pass
+
- import gettext
- gettext.install('bittorrent', 'locale')
+ from BitTorrent.platform import install_translation
+ install_translation()
diff --git a/net/py-bittorrent-devel/files/extra-psyco-patch-maketorrent-console.py b/net/py-bittorrent-devel/files/extra-psyco-patch-maketorrent-console.py
index cf8c08f18e64..476f36587378 100644
--- a/net/py-bittorrent-devel/files/extra-psyco-patch-maketorrent-console.py
+++ b/net/py-bittorrent-devel/files/extra-psyco-patch-maketorrent-console.py
@@ -1,18 +1,16 @@
---- maketorrent-console.py.orig Tue Aug 23 22:49:16 2005
-+++ maketorrent-console.py Tue Aug 23 22:50:41 2005
-@@ -12,6 +12,15 @@
+--- maketorrent-console.py Wed Oct 12 01:08:27 2005
++++ maketorrent-console.py Wed Oct 12 07:58:31 2005
+@@ -12,6 +12,13 @@
# Written by Bram Cohen
-+from BitTorrent import PSYCO
-+if PSYCO.psyco:
-+ try:
-+ import psyco
-+ assert psyco.__version__ >= 0x010300f0
-+ psyco.full()
-+ except:
-+ pass
++try:
++ import psyco
++ assert psyco.__version__ >= 0x010300f0
++ psyco.full()
++except:
++ pass
+
if __name__ == '__main__':
- import gettext
- gettext.install('bittorrent', 'locale')
+ from BitTorrent.platform import install_translation
+ install_translation()
diff --git a/net/py-bittorrent-devel/files/extra-psyco-patch-maketorrent.py b/net/py-bittorrent-devel/files/extra-psyco-patch-maketorrent.py
index 59218397b371..9675c99cda69 100644
--- a/net/py-bittorrent-devel/files/extra-psyco-patch-maketorrent.py
+++ b/net/py-bittorrent-devel/files/extra-psyco-patch-maketorrent.py
@@ -1,18 +1,16 @@
---- maketorrent.py.orig Tue Aug 23 22:49:16 2005
-+++ maketorrent.py Tue Aug 23 22:50:45 2005
-@@ -14,6 +14,15 @@
+--- maketorrent.py Wed Oct 12 01:08:27 2005
++++ maketorrent.py Wed Oct 12 07:58:35 2005
+@@ -14,6 +14,13 @@
from __future__ import division
-+from BitTorrent import PSYCO
-+if PSYCO.psyco:
-+ try:
-+ import psyco
-+ assert psyco.__version__ >= 0x010300f0
-+ psyco.full()
-+ except:
-+ pass
++try:
++ import psyco
++ assert psyco.__version__ >= 0x010300f0
++ psyco.full()
++except:
++ pass
+
- import gettext
- gettext.install('bittorrent', 'locale')
+ from BitTorrent.platform import install_translation
+ install_translation()
diff --git a/net/py-bittorrent-devel/files/extra-psyco-patch-torrentinfo-console.py b/net/py-bittorrent-devel/files/extra-psyco-patch-torrentinfo-console.py
index c8a19d96f6e1..bf6128eb8b65 100644
--- a/net/py-bittorrent-devel/files/extra-psyco-patch-torrentinfo-console.py
+++ b/net/py-bittorrent-devel/files/extra-psyco-patch-torrentinfo-console.py
@@ -1,18 +1,16 @@
---- torrentinfo-console.py.orig Tue Aug 23 22:49:16 2005
-+++ torrentinfo-console.py Tue Aug 23 22:50:55 2005
-@@ -12,6 +12,15 @@
+--- torrentinfo-console.py Wed Oct 12 01:08:50 2005
++++ torrentinfo-console.py Wed Oct 12 07:58:48 2005
+@@ -12,6 +12,13 @@
# Written by Henry 'Pi' James, Loring Holden and Matt Chisholm
-+from BitTorrent import PSYCO
-+if PSYCO.psyco:
-+ try:
-+ import psyco
-+ assert psyco.__version__ >= 0x010300f0
-+ psyco.full()
-+ except:
-+ pass
++try:
++ import psyco
++ assert psyco.__version__ >= 0x010300f0
++ psyco.full()
++except:
++ pass
+
- import gettext
- gettext.install('bittorrent', 'locale')
+ from BitTorrent.platform import install_translation
+ install_translation()
diff --git a/net/py-bittorrent-devel/files/patch-BitTorrent__RawServer_twisted.py b/net/py-bittorrent-devel/files/patch-BitTorrent__RawServer_twisted.py
new file mode 100644
index 000000000000..60de146ee9ac
--- /dev/null
+++ b/net/py-bittorrent-devel/files/patch-BitTorrent__RawServer_twisted.py
@@ -0,0 +1,11 @@
+--- BitTorrent/RawServer_twisted.py.orig Wed Oct 12 08:56:50 2005
++++ BitTorrent/RawServer_twisted.py Wed Oct 12 09:01:36 2005
+@@ -565,7 +565,7 @@
+ bindaddr = None
+ if do_bind:
+ bindaddr = self.config['bind']
+- if bindaddr and len(binadder) >= 0:
++ if bindaddr and len(bindaddr) >= 0:
+ bindaddr = (bindaddr, 0)
+ else:
+ bindaddr = None
diff --git a/net/py-bittorrent-devel/pkg-plist b/net/py-bittorrent-devel/pkg-plist
index c2da855132e7..0ab4e72b9933 100644
--- a/net/py-bittorrent-devel/pkg-plist
+++ b/net/py-bittorrent-devel/pkg-plist
@@ -1,9 +1,11 @@
+bin/bittorrent
bin/bittorrent-console
bin/bittorrent-curses
bin/bittorrent-tracker
bin/changetracker-console
bin/launchmany-console
bin/launchmany-curses
+bin/maketorrent
bin/maketorrent-console
bin/torrentinfo-console
%%PYTHON_SITELIBDIR%%/BitTorrent/Choker.py
@@ -63,6 +65,12 @@ bin/torrentinfo-console
%%PYTHON_SITELIBDIR%%/BitTorrent/RawServer.py
%%PYTHON_SITELIBDIR%%/BitTorrent/RawServer.pyc
%%PYTHON_SITELIBDIR%%/BitTorrent/RawServer.pyo
+%%PYTHON_SITELIBDIR%%/BitTorrent/RawServer_magic.py
+%%PYTHON_SITELIBDIR%%/BitTorrent/RawServer_magic.pyc
+%%PYTHON_SITELIBDIR%%/BitTorrent/RawServer_magic.pyo
+%%PYTHON_SITELIBDIR%%/BitTorrent/RawServer_twisted.py
+%%PYTHON_SITELIBDIR%%/BitTorrent/RawServer_twisted.pyc
+%%PYTHON_SITELIBDIR%%/BitTorrent/RawServer_twisted.pyo
%%PYTHON_SITELIBDIR%%/BitTorrent/Rerequester.py
%%PYTHON_SITELIBDIR%%/BitTorrent/Rerequester.pyc
%%PYTHON_SITELIBDIR%%/BitTorrent/Rerequester.pyo