aboutsummaryrefslogtreecommitdiff
path: root/net/py-bittorrent
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-12-10 18:51:16 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-12-10 18:51:16 +0000
commit1aaf9c5b598f17553b64e3dc5716b4ba27d4fc71 (patch)
tree3793274392d5add54af1f3f591ce7690fdd49c8e /net/py-bittorrent
parent61985d199d6f716419384313b8dd2481a1c5c2f2 (diff)
downloadports-1aaf9c5b598f17553b64e3dc5716b4ba27d4fc71.tar.gz
ports-1aaf9c5b598f17553b64e3dc5716b4ba27d4fc71.zip
Notes
Diffstat (limited to 'net/py-bittorrent')
-rw-r--r--net/py-bittorrent/Makefile6
-rw-r--r--net/py-bittorrent/files/patch-BitTorrent::zurllib.py18
2 files changed, 21 insertions, 3 deletions
diff --git a/net/py-bittorrent/Makefile b/net/py-bittorrent/Makefile
index f3ad85dea2a2..22549d3887e8 100644
--- a/net/py-bittorrent/Makefile
+++ b/net/py-bittorrent/Makefile
@@ -7,7 +7,7 @@
PORTNAME= BitTorrent
PORTVERSION= 3.4.2
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES?= net python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
@@ -44,9 +44,9 @@ pre-everything::
@${ECHO_MSG} '===> Define WITHOUT_GUI to disable GUI installation'
.endif
-post-extract:
+#post-extract:
# patch to work with python 2.4
- @${CP} ${FILESDIR}/zurllib.py ${WRKSRC}/BitTorrent
+# @${CP} ${FILESDIR}/zurllib.py ${WRKSRC}/BitTorrent
post-patch:
@${FIND} ${WRKSRC} -type f | \
diff --git a/net/py-bittorrent/files/patch-BitTorrent::zurllib.py b/net/py-bittorrent/files/patch-BitTorrent::zurllib.py
new file mode 100644
index 000000000000..deca5e24f028
--- /dev/null
+++ b/net/py-bittorrent/files/patch-BitTorrent::zurllib.py
@@ -0,0 +1,18 @@
+--- BitTorrent/zurllib.py.orig Thu Dec 9 10:36:43 2004
++++ BitTorrent/zurllib.py Thu Dec 9 10:38:19 2004
+@@ -35,7 +35,14 @@
+ if DEBUG:
+ pprint.pprint(headers.dict)
+ url = fp.url
+- return addinfourldecompress(fp, headers, url)
++ resp = addinfourldecompress(fp, headers, url)
++ # As of Python 2.4 http_open response also has 'code' and 'msg'
++ # members, and HTTPErrorProcessor breaks if they don't exist.
++ if 'code' in dir(fp):
++ resp.code = fp.code
++ if 'msg' in dir(fp):
++ resp.msg = fp.msg
++ return resp
+
+
+ class addinfourldecompress(addinfourl):