aboutsummaryrefslogtreecommitdiff
path: root/net/py-kombu/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2011-03-18 04:46:07 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2011-03-18 04:46:07 +0000
commit47b1472b7021a90739c507b9e28ae207e38c2ee0 (patch)
tree660e82afd5ed64968a0dafd7e94bc9b35a16c33a /net/py-kombu/Makefile
parentec32805f1d51d04a9771c627760a7a7969268bc5 (diff)
Kombu is an AMQP messaging framework for Python.
The aim of Kombu is to make messaging in Python as easy as possible by providing an idiomatic high-level interface for the AMQP protocol, and also provide proven and tested solutions to common messaging problems. Features: * Allows application authors to support several message server solutions by using pluggable transports. * Supports automatic encoding, serialization and compression of message payloads. * Consistent exception handling across transports. * The ability to ensure that an operation is performed by gracefully handling connection and channel errrors. * Several annoyances with amqplib has been fixed, like supporting timeouts and the ability to wait for events on more than one channel. WWW: http://github.com/ask/kombu
Notes
Notes: svn path=/head/; revision=271221
Diffstat (limited to 'net/py-kombu/Makefile')
-rw-r--r--net/py-kombu/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/net/py-kombu/Makefile b/net/py-kombu/Makefile
new file mode 100644
index 000000000000..a0322b4f4b5b
--- /dev/null
+++ b/net/py-kombu/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: kombu
+# Date created: 18 March 2011
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kombu
+PORTVERSION= 1.0.5
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= An AMQP messaging framework for Python
+
+LICESNSE= BSD
+
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.mk>