aboutsummaryrefslogtreecommitdiff
path: root/net/py-ldap2/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-04-05 07:57:56 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-04-05 07:57:56 +0000
commit54828a3421a2aa981d28ef490575b6733b26da91 (patch)
treec9ed7f8de4bed523843baa0885ed0f233f5b2cd6 /net/py-ldap2/Makefile
parent3c61ccaa65f8bb12f07339251a9b478f4dfa2f83 (diff)
downloadports-54828a3421a2aa981d28ef490575b6733b26da91.tar.gz
ports-54828a3421a2aa981d28ef490575b6733b26da91.zip
Notes
Diffstat (limited to 'net/py-ldap2/Makefile')
-rw-r--r--net/py-ldap2/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/net/py-ldap2/Makefile b/net/py-ldap2/Makefile
index acc10bde5984..f56271717b1d 100644
--- a/net/py-ldap2/Makefile
+++ b/net/py-ldap2/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= ldap2
-PORTVERSION= 2.0.10
+PORTVERSION= 2.0.11
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= python-ldap
@@ -19,18 +19,17 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_OPENLDAP= yes
USE_REINPLACE= yes
-WANT_OPENLDAP_VER= 22
-REPLACE_ARGS= -e 's=/opt/openldap-OPENLDAP_REL_ENG_2_3/include=${LOCALBASE}/include='
+REPLACE_ARGS= -e 's=/usr/local/openldap-REL_ENG_2_1/lib=${LOCALBASE}/lib=' \
+ -e 's=/usr/local/openldap-REL_ENG_2_1/include=${LOCALBASE}/include='
.if defined(WITH_SASL)
WANT_OPENLDAP_SASL= yes
-REPLACE_ARGS+= -e 's=/opt/sasl/include/sasl=${LOCALBASE}/include/sasl=' \
- -e 's=/opt/openldap-OPENLDAP_REL_ENG_2_3/lib=${LOCALBASE}/lib ${LOCALBASE}/lib/sasl2='
-CONFLICTS+= openldap22-client-2.*
+REPLACE_ARGS+= -e 's=/usr/local/cyrus-sasl/lib=${LOCALBASE}/lib/sasl2=' \
+ -e 's=/usr/local/cyrus-sasl/include=${LOCALBASE}/include/sasl2='
+CONFLICTS+= openldap2[23]-client-2.*
.else
-REPLACE_ARGS+= -e 's=ldap_r lber ssl crypto sasl2=ldap_r lber ssl crypto=' \
- -e 's=/opt/openldap-OPENLDAP_REL_ENG_2_3/lib=${LOCALBASE}/lib='
+REPLACE_ARGS+= -e 's=ldap_r lber sasl2 ssl crypto=ldap_r lber ssl crypto='
.endif
pre-everything::