aboutsummaryrefslogtreecommitdiff
path: root/net/py-maxminddb
diff options
context:
space:
mode:
authorJohannes Jost Meixner <xmj@FreeBSD.org>2015-05-15 20:24:49 +0000
committerJohannes Jost Meixner <xmj@FreeBSD.org>2015-05-15 20:24:49 +0000
commit495d6132088b86c98313b5a2850923c7774c752b (patch)
tree7081c491478bc663455bcb8b45a3047306b60b0d /net/py-maxminddb
parent0ab67218db20bfe22408f2c40a53f74346bbac24 (diff)
downloadports-495d6132088b86c98313b5a2850923c7774c752b.tar.gz
ports-495d6132088b86c98313b5a2850923c7774c752b.zip
Notes
Diffstat (limited to 'net/py-maxminddb')
-rw-r--r--net/py-maxminddb/Makefile29
-rw-r--r--net/py-maxminddb/distinfo2
-rw-r--r--net/py-maxminddb/pkg-descr4
3 files changed, 35 insertions, 0 deletions
diff --git a/net/py-maxminddb/Makefile b/net/py-maxminddb/Makefile
new file mode 100644
index 000000000000..fea1c32c9933
--- /dev/null
+++ b/net/py-maxminddb/Makefile
@@ -0,0 +1,29 @@
+# Created by: Olivier Cochard-Labbé <olivier@cochard.me>
+# $FreeBSD$
+
+PORTNAME= maxminddb
+PORTVERSION= 1.2.0
+CATEGORIES= net python geography
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-Python-${PORTVERSION}
+
+MAINTAINER= olivier@cochard.me
+COMMENT= Python module for reading MaxMind DB file
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ipaddr>0:${PORTSDIR}/devel/py-ipaddr
+LIB_DEPENDS= libmaxminddb.so:${PORTSDIR}/net/libmaxminddb
+
+USE_GITHUB= yes
+GH_ACCOUNT= maxmind
+GH_PROJECT= MaxMind-DB-Reader-python
+GH_TAGNAME= v${PORTVERSION}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+CPPFLAGS+= -I${LOCALBASE}/include
+
+.include <bsd.port.mk>
diff --git a/net/py-maxminddb/distinfo b/net/py-maxminddb/distinfo
new file mode 100644
index 000000000000..863af1bf828f
--- /dev/null
+++ b/net/py-maxminddb/distinfo
@@ -0,0 +1,2 @@
+SHA256 (maxminddb-Python-1.2.0_GH0.tar.gz) = dfb1953dba1ba9bf4a470554d5cf57d68124138b7c12f77a6a40c66613f24c8f
+SIZE (maxminddb-Python-1.2.0_GH0.tar.gz) = 28920
diff --git a/net/py-maxminddb/pkg-descr b/net/py-maxminddb/pkg-descr
new file mode 100644
index 000000000000..82205925ca74
--- /dev/null
+++ b/net/py-maxminddb/pkg-descr
@@ -0,0 +1,4 @@
+Python module for reading MaxMind DB files. The module includes both a pure
+Python reader and a C extension.
+
+WWW: https://github.com/maxmind/MaxMind-DB-Reader-python