aboutsummaryrefslogtreecommitdiff
path: root/net/py-netifaces
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /net/py-netifaces
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Notes
Notes: svn path=/head/; revision=455210
Diffstat (limited to 'net/py-netifaces')
-rw-r--r--net/py-netifaces/Makefile11
-rw-r--r--net/py-netifaces/distinfo6
2 files changed, 10 insertions, 7 deletions
diff --git a/net/py-netifaces/Makefile b/net/py-netifaces/Makefile
index bd6f08fd18ca..67ee95185331 100644
--- a/net/py-netifaces/Makefile
+++ b/net/py-netifaces/Makefile
@@ -1,18 +1,21 @@
-# Created by: Stanislav Svirid <count@211.ru>
+# Created by: Muhammad Moinur Rahman <bofh@FreeBSD.org>
# $FreeBSD$
PORTNAME= netifaces
-PORTVERSION= 0.10.5
+PORTVERSION= 0.10.6
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= count@211.ru
-COMMENT= Getting network addresses from Python
+MAINTAINER= bofh@FreeBSD.org
+COMMENT= Getting network addresses from Python 3
LICENSE= MIT
USES= python
USE_PYTHON= autoplist distutils
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/netifaces.so
+
.include <bsd.port.mk>
diff --git a/net/py-netifaces/distinfo b/net/py-netifaces/distinfo
index 0e2115a2cc12..5ecdf46f2a00 100644
--- a/net/py-netifaces/distinfo
+++ b/net/py-netifaces/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1478617707
-SHA256 (netifaces-0.10.5.tar.gz) = 59d8ad52dd3116fcb6635e175751b250dc783fb011adba539558bd764e5d628b
-SIZE (netifaces-0.10.5.tar.gz) = 24879
+TIMESTAMP = 1505758293
+SHA256 (netifaces-0.10.6.tar.gz) = 0c4da523f36d36f1ef92ee183f2512f3ceb9a9d2a45f7d19cda5a42c6689ebe0
+SIZE (netifaces-0.10.6.tar.gz) = 25166