aboutsummaryrefslogtreecommitdiff
path: root/net/py-novaclient/Makefile
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2011-12-09 08:26:43 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2011-12-09 08:26:43 +0000
commite245cb0dd45d96f691405881223352da381b6882 (patch)
treec5e1c5e0bed1d23d9daf59ba9124ce302545bc6c /net/py-novaclient/Makefile
parent952b34a731bd5e909933cb45ca4228f27b13591d (diff)
downloadports-e245cb0dd45d96f691405881223352da381b6882.tar.gz
ports-e245cb0dd45d96f691405881223352da381b6882.zip
Notes
Diffstat (limited to 'net/py-novaclient/Makefile')
-rw-r--r--net/py-novaclient/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/net/py-novaclient/Makefile b/net/py-novaclient/Makefile
new file mode 100644
index 000000000000..f1b32a4c479a
--- /dev/null
+++ b/net/py-novaclient/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: py-novaclient
+# Date created: 2011-12-08
+# Whom: Roman Bogorodskiy <novel@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= novaclient
+PORTVERSION= 2.6.8
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= novel@FreeBSD.org
+COMMENT= Client for the OpenStack Nova API
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}argparse>=0:${PORTSDIR}/devel/py-argparse \
+ ${PYTHON_PKGNAMEPREFIX}prettytable>=0:${PORTSDIR}/devel/py-prettytable \
+ ${PYTHON_SITELIBDIR}/httplib2/__init__.py:${PORTSDIR}/www/py-httplib2
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+PYDISTUTILS_NOEGGINFO= yes
+PYDISTUTILS_PKGNAME= python-${PORTNAME}
+
+PLIST_FILES= bin/nova \
+ ${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;}/${PYEASYINSTALL_EGG}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,install_requires.*,,' ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>