aboutsummaryrefslogtreecommitdiff
path: root/net/py-pcap
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2008-12-04 10:28:10 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2008-12-04 10:28:10 +0000
commit0343ffb626ed37909f4bb074178ffbf73b5c83b8 (patch)
treeaf024a2fc1a94005b3924a6f8d9d17f621e6cc75 /net/py-pcap
parent4af2b44ff03d7771249dd0aeda60b3d9a01a5f44 (diff)
downloadports-0343ffb626ed37909f4bb074178ffbf73b5c83b8.tar.gz
ports-0343ffb626ed37909f4bb074178ffbf73b5c83b8.zip
Notes
Diffstat (limited to 'net/py-pcap')
-rw-r--r--net/py-pcap/Makefile12
-rw-r--r--net/py-pcap/distinfo9
-rw-r--r--net/py-pcap/files/patch-mk-constants.py10
-rw-r--r--net/py-pcap/files/patch-setup.py23
4 files changed, 6 insertions, 48 deletions
diff --git a/net/py-pcap/Makefile b/net/py-pcap/Makefile
index f87a3ebca46e..302b22de5d10 100644
--- a/net/py-pcap/Makefile
+++ b/net/py-pcap/Makefile
@@ -6,15 +6,13 @@
#
PORTNAME= pcap
-PORTVERSION= 0.5
+PORTVERSION= 0.6.2
CATEGORIES= net python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://people.freebsd.org/~perky/distfiles/:local
MASTER_SITE_SUBDIR= pylibpcap
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTFILES= pylibpcap-${PORTVERSION}.tar.gz \
- pylibpcap-doc.i.1.4:local
-EXTRACT_ONLY= pylibpcap-${PORTVERSION}.tar.gz
+DISTNAME= pylibpcap-${PORTVERSION}
MAINTAINER= perky@FreeBSD.org
COMMENT= Python interface to LBL Packet Capture library (libpcap)
@@ -25,15 +23,11 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_PYTHON_PREFIX= yes
PYDISTUTILS_PKGNAME= pylibpcap
-WRKSRC= ${WRKDIR}/pylibpcap-${PORTVERSION}
.include <bsd.port.pre.mk>
.if ( ${OSVERSION} < 500038 )
-IGNORE= "needs libpcap 0.7 or higher"
+IGNORE= needs libpcap 0.7 or higher
.endif
-post-extract:
- ${INSTALL_DATA} ${DISTDIR}/pylibpcap-doc.i.1.4 ${WRKSRC}/doc.i
-
.include <bsd.port.post.mk>
diff --git a/net/py-pcap/distinfo b/net/py-pcap/distinfo
index b27871726679..2975bfaf8056 100644
--- a/net/py-pcap/distinfo
+++ b/net/py-pcap/distinfo
@@ -1,6 +1,3 @@
-MD5 (pylibpcap-0.5.tar.gz) = 3720289b8de89954de125c3f657ca7ac
-SHA256 (pylibpcap-0.5.tar.gz) = c91845d71bd06e4857736a0748b3e94ba2f86eafd2c52a22b6013d6b7fddcac7
-SIZE (pylibpcap-0.5.tar.gz) = 22784
-MD5 (pylibpcap-doc.i.1.4) = eb095e3a75a5d55fb803a9f225f14f4b
-SHA256 (pylibpcap-doc.i.1.4) = a20188fe8e5567d91b943c2380f2e69a50fc680c826a54d60c354bf77393950e
-SIZE (pylibpcap-doc.i.1.4) = 6584
+MD5 (pylibpcap-0.6.2.tar.gz) = 45793c31fe008fa508a9a51d744e9d00
+SHA256 (pylibpcap-0.6.2.tar.gz) = 0cdb507eaf27e7d6f4e3ee74a5986e14728fd8161785350d201a12198c19fcc6
+SIZE (pylibpcap-0.6.2.tar.gz) = 49021
diff --git a/net/py-pcap/files/patch-mk-constants.py b/net/py-pcap/files/patch-mk-constants.py
deleted file mode 100644
index a04f8e57d855..000000000000
--- a/net/py-pcap/files/patch-mk-constants.py
+++ /dev/null
@@ -1,10 +0,0 @@
---- mk-constants.py.orig Sun Mar 19 17:21:07 2006
-+++ mk-constants.py Sun Mar 19 17:21:41 2006
-@@ -79,6 +79,7 @@
- rcs = ' $Id: mk-constants.py,v 1.2 2004/06/07 05:34:49 wiml Exp $\n'
- fp.write(string.replace(rcs, '$', ''))
- fp.write(' Do not edit this file directly, it will be overwritten \n*/\n\n')
-+fp.write('#define SWIG_PY_INT 1\n')
- fp.write('static struct swig_const_info const pcapmodule_DLT[] = {\n')
- for dlt in linktypes:
- fp.write('#ifdef %s\n' % (dlt,))
diff --git a/net/py-pcap/files/patch-setup.py b/net/py-pcap/files/patch-setup.py
deleted file mode 100644
index 8224fe1c6d1f..000000000000
--- a/net/py-pcap/files/patch-setup.py
+++ /dev/null
@@ -1,23 +0,0 @@
---- setup.py.orig Mon Jul 4 08:14:31 2005
-+++ setup.py Mon Oct 10 23:40:45 2005
-@@ -75,7 +75,7 @@
- new_sources.append(source)
- return new_sources
-
-- def swig_sources(self, sources):
-+ def swig_sources(self, sources, ext=None):
-
- """Walk the list of source files in 'sources', looking for SWIG
- interface (.i) files. Run SWIG on all that are found, and
-@@ -121,11 +121,6 @@
- self.announce("swigging %s to %s" % (source, target))
- self.spawn(swig_cmd + ["-o", target, source])
-
-- self.announce('doc-ifying swig-generated source file %s' % target)
-- self.spawn(['./build-tools/docify.py', target])
--
-- self.announce('doc-ifying swig-generated shadow class file %s' % 'pcap.py')
-- self.spawn(['./build-tools/docify-shadow.py', 'pcap.py'])
-
- return new_sources
-