aboutsummaryrefslogtreecommitdiff
path: root/net/py-pypcap
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2007-03-24 19:23:00 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2007-03-24 19:23:00 +0000
commitb1d0538273c7866baa5273767880648c55d870a1 (patch)
tree31e97bad19a8100c46945165609a01d36e7831d3 /net/py-pypcap
parent79294b1acf4805274507cf09d6618ca9aad0044f (diff)
downloadports-b1d0538273c7866baa5273767880648c55d870a1.tar.gz
ports-b1d0538273c7866baa5273767880648c55d870a1.zip
Notes
Diffstat (limited to 'net/py-pypcap')
-rw-r--r--net/py-pypcap/Makefile2
-rw-r--r--net/py-pypcap/files/patch-pcap.pyx36
2 files changed, 1 insertions, 37 deletions
diff --git a/net/py-pypcap/Makefile b/net/py-pypcap/Makefile
index 12abfdc62772..f84d84e784d4 100644
--- a/net/py-pypcap/Makefile
+++ b/net/py-pypcap/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pypcap
PORTVERSION= 1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net python
MASTER_SITES= http://pypcap.googlecode.com/files/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/net/py-pypcap/files/patch-pcap.pyx b/net/py-pypcap/files/patch-pcap.pyx
deleted file mode 100644
index 369a5bc52249..000000000000
--- a/net/py-pypcap/files/patch-pcap.pyx
+++ /dev/null
@@ -1,36 +0,0 @@
-*** pcap.pyx Mon Oct 17 08:00:11 2005
---- /Users/gnn/src/pypcap-1.1.new/pcap.pyx Fri Jun 23 18:22:03 2006
-***************
-*** 61,66 ****
---- 64,70 ----
- int pcap_stats(pcap_t *p, pcap_stat *ps)
- char *pcap_geterr(pcap_t *p)
- void pcap_close(pcap_t *p)
-+ int pcap_inject(pcap_t *p, char *buf, int size)
- int bpf_filter(bpf_insn *insns, char *buf, int len, int caplen)
-
- cdef extern from "pcap_ex.h":
-***************
-*** 313,318 ****
---- 318,338 ----
- elif n == -2:
- break
-
-+ def inject(self, packet, len):
-+ """Inject a packet onto an interface.
-+ May or may not work depending on platform.
-+
-+ Arguments:
-+
-+ packet -- a pointer to the packet in memory
-+ """
-+ cdef int n
-+ n = pcap_inject(self.__pcap, packet, len)
-+ if (n < 0):
-+ raise OSError, pcap_geterr(self.__pcap)
-+
-+ return n
-+
- def geterr(self):
- """Return the last error message associated with this handle."""
- return pcap_geterr(self.__pcap)