aboutsummaryrefslogtreecommitdiff
path: root/net/py-pysmb
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2015-11-14 19:23:10 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2015-11-14 19:23:10 +0000
commitf43e269fbf2abe171399498037e40310c72f4c6c (patch)
treea5b4fd873c3a0b4b5b16863859e29291d23a34e4 /net/py-pysmb
parent9e6893470d61181f6ce09b529fcbae91a01275cc (diff)
downloadports-f43e269fbf2abe171399498037e40310c72f4c6c.tar.gz
ports-f43e269fbf2abe171399498037e40310c72f4c6c.zip
Notes
Diffstat (limited to 'net/py-pysmb')
-rw-r--r--net/py-pysmb/Makefile31
-rw-r--r--net/py-pysmb/distinfo2
-rw-r--r--net/py-pysmb/pkg-descr12
3 files changed, 45 insertions, 0 deletions
diff --git a/net/py-pysmb/Makefile b/net/py-pysmb/Makefile
new file mode 100644
index 000000000000..24d406ac7a43
--- /dev/null
+++ b/net/py-pysmb/Makefile
@@ -0,0 +1,31 @@
+# Created by: ijliao
+# $FreeBSD$
+
+PORTNAME= pysmb
+PORTVERSION= 1.1.16
+CATEGORIES= net python
+MASTER_SITES= http://miketeo.net/files/Projects/${PORTNAME}/ \
+ CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= SMB/CIFS library written in Python
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>=0:${PORTSDIR}/devel/py-asn1
+
+OPTIONS_DEFINE= DOCS
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+PORTDOCS= *
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/docs/html/ && ${COPYTREE_SHARE} _modules/ ${STAGEDIR}${DOCSDIR}/)
+ (cd ${WRKSRC}/docs/html/ && ${COPYTREE_SHARE} _static/ ${STAGEDIR}${DOCSDIR}/)
+ (cd ${WRKSRC}/docs/html/ && ${COPYTREE_SHARE} api/ ${STAGEDIR}${DOCSDIR}/)
+ (cd ${WRKSRC}/docs/html/ && ${CP} *.html ${STAGEDIR}${DOCSDIR}/)
+ (cd ${WRKSRC}/docs/html/ && ${CP} *.js ${STAGEDIR}${DOCSDIR}/)
+
+.include <bsd.port.mk>
diff --git a/net/py-pysmb/distinfo b/net/py-pysmb/distinfo
new file mode 100644
index 000000000000..280626d8fc13
--- /dev/null
+++ b/net/py-pysmb/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pysmb-1.1.16.tar.gz) = 0f192279b12d3fb38f7ece55d9cd8f573fcf5e6319f78e9b387a30d0baf0da4c
+SIZE (pysmb-1.1.16.tar.gz) = 1551617
diff --git a/net/py-pysmb/pkg-descr b/net/py-pysmb/pkg-descr
new file mode 100644
index 000000000000..f2d949d2c1d1
--- /dev/null
+++ b/net/py-pysmb/pkg-descr
@@ -0,0 +1,12 @@
+pysmb is an experimental SMB/CIFS library written in Python.
+It implements the client-side SMB/CIFS protocol which allows your Python
+application to access and transfer files to/from SMB/CIFS shared folders
+like your Windows file sharing and Samba folders.
+It was tested with Windows XP SP3, Windows Vista, Windows 7 and Samba 3.x.
+
+Modules
+ smb - Contains all the SMB operations and constants
+ nmb - Contains some of the NetBIOS over TCP/IP operations which is
+ necessary for the smb module to operate.
+
+WWW: http://miketeo.net/wp/index.php/projects/pysmb