aboutsummaryrefslogtreecommitdiff
path: root/net/py-python-cinderclient/Makefile
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2016-12-17 15:31:09 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2016-12-17 15:31:09 +0000
commitd6c193775fdf46e61d24f521a23fff0671bde21e (patch)
tree29f57aff9831dd2fa116afc517e2ba47e80e769b /net/py-python-cinderclient/Makefile
parentfcd13a66d67b0433da6e61a62da5cbd16fcbd94b (diff)
downloadports-d6c193775fdf46e61d24f521a23fff0671bde21e.tar.gz
ports-d6c193775fdf46e61d24f521a23fff0671bde21e.zip
Notes
Diffstat (limited to 'net/py-python-cinderclient/Makefile')
-rw-r--r--net/py-python-cinderclient/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/net/py-python-cinderclient/Makefile b/net/py-python-cinderclient/Makefile
new file mode 100644
index 000000000000..d72263b38fa1
--- /dev/null
+++ b/net/py-python-cinderclient/Makefile
@@ -0,0 +1,31 @@
+# Created by: Alexander Nusov <alexander.nusov@nfvexpress.com>
+# $FreeBSD$
+
+PORTNAME= python-cinderclient
+PORTVERSION= 1.9.0
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= alexander.nusov@nfvexpress.com
+COMMENT= Client for the OpenStack Cinder API
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=1.6:devel/py-pbr
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>=2.3.4:devel/py-babel \
+ ${PYTHON_PKGNAMEPREFIX}prettytable>=0:devel/py-prettytable \
+ ${PYTHON_PKGNAMEPREFIX}keystoneauth1>=2.10.0:devel/py-keystoneauth1 \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.10.0:www/py-requests \
+ ${PYTHON_PKGNAMEPREFIX}simplejson>=2.2.0:devel/py-simplejson \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}oslo.i18n>=2.1.0:devel/py-oslo.i18n \
+ ${PYTHON_PKGNAMEPREFIX}oslo.utils>=3.16.0:devel/py-oslo.utils
+
+USES= python shebangfix
+SHEBANG_FILES= cinderclient/tests/functional/hooks/post_test_hook.sh
+USE_PYTHON= distutils autoplist noegginfo
+NO_ARCH= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,install_requires.*,,' ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>