aboutsummaryrefslogtreecommitdiff
path: root/net/py-python-cinderclient/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-01-08 14:51:14 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-01-08 14:51:14 +0000
commita7af2f1ad6eaafaededaf79516a72bd7557f7fc1 (patch)
tree1734ecaca2f6e2497cecbb424b75941424545b75 /net/py-python-cinderclient/Makefile
parent667e92c20f9b9cde663c1d9488c651f98911a0ec (diff)
downloadports-a7af2f1ad6eaafaededaf79516a72bd7557f7fc1.tar.gz
ports-a7af2f1ad6eaafaededaf79516a72bd7557f7fc1.zip
Notes
Diffstat (limited to 'net/py-python-cinderclient/Makefile')
-rw-r--r--net/py-python-cinderclient/Makefile28
1 files changed, 8 insertions, 20 deletions
diff --git a/net/py-python-cinderclient/Makefile b/net/py-python-cinderclient/Makefile
index 0cb54b069c50..47920387c14b 100644
--- a/net/py-python-cinderclient/Makefile
+++ b/net/py-python-cinderclient/Makefile
@@ -2,45 +2,33 @@
# $FreeBSD$
PORTNAME= python-cinderclient
-PORTVERSION= 3.5.0
-PORTREVISION= 2
+PORTVERSION= 5.0.0
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Client for the OpenStack Cinder API
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= OpenStack Block Storage API Client Library
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=2.0.0:devel/py-pbr@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Babel>=2.3.4:devel/py-babel@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}keystoneauth1>=3.3.0:devel/py-keystoneauth1@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}keystoneauth1>=3.4.0:devel/py-keystoneauth1@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}oslo.i18n>=3.15.3:devel/py-oslo.i18n@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}oslo.utils>=3.33.0:devel/py-oslo.utils@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pbr>=2.0.0:devel/py-pbr@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}prettytable>=0.7.1:devel/py-prettytable@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}prettytable>=0.7.1<0.8:devel/py-prettytable@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.14.2:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}simplejson>=3.5.1:devel/py-simplejson@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.10.0:devel/py-six@${PY_FLAVOR}
USES= python shebangfix
USE_PYTHON= autoplist concurrent distutils
-SHEBANG_FILES= cinderclient/tests/functional/hooks/post_test_hook.sh
NO_ARCH= yes
-PORTDOCS= *
-
-OPTIONS_DEFINE= DOCS
-DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openstackdocstheme>=1.17.0:textproc/py-openstackdocstheme@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}reno>=2.5.0:textproc/py-reno@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}sphinx>=1.6.2:textproc/py-sphinx@${PY_FLAVOR}
-DOCS_VARS= PYDISTUTILS_BUILD_TARGET+="build_sphinx -a -E"
-
-post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- (cd ${WRKSRC}/doc/build/html && \
- ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} \
- "! -name .buildinfo -and ! -name objects.inv")
+
+SHEBANG_GLOB= *.sh
.include <bsd.port.mk>