aboutsummaryrefslogtreecommitdiff
path: root/net/py-ripe.atlas.sagan/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2015-12-11 13:20:37 +0000
committerMartin Wilke <miwi@FreeBSD.org>2015-12-11 13:20:37 +0000
commitcb17eafaa6666e746f80245c91340d4ed9348892 (patch)
tree3462a3e0829a1a1a159774dc329157abe73634f5 /net/py-ripe.atlas.sagan/Makefile
parente9d406f45b55dd85f07515d94631b9bef5e7085a (diff)
Notes
Diffstat (limited to 'net/py-ripe.atlas.sagan/Makefile')
-rw-r--r--net/py-ripe.atlas.sagan/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/net/py-ripe.atlas.sagan/Makefile b/net/py-ripe.atlas.sagan/Makefile
new file mode 100644
index 000000000000..d4d7c472cdfb
--- /dev/null
+++ b/net/py-ripe.atlas.sagan/Makefile
@@ -0,0 +1,23 @@
+# Created by: Massimiliano Stucchi <mstucchi@ripe.net>
+# $FreeBSD$
+
+PORTNAME= ripe.atlas.sagan
+PORTVERSION= 1.1.6
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= mstucchi@ripe.net
+COMMENT= Parsing library for RIPE Atlas measurement results
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>0:${PORTSDIR}/devel/py-dateutil \
+ ${PYTHON_PKGNAMEPREFIX}pytz>=0:${PORTSDIR}/devel/py-pytz \
+ ${PYTHON_PKGNAMEPREFIX}ipy>=0:${PORTSDIR}/net-mgmt/py-ipy
+
+USES= python
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+.include <bsd.port.mk>