aboutsummaryrefslogtreecommitdiff
path: root/net/py-smb/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-01-11 13:21:41 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-01-11 13:21:41 +0000
commit4353065d4497ff950eb138b9a6caee4de325b231 (patch)
tree490bda80de957df058fa2e15540052ff04699e95 /net/py-smb/Makefile
parent9db822d0688daee6d1824261b5ca54187a4e7b59 (diff)
downloadports-4353065d4497ff950eb138b9a6caee4de325b231.tar.gz
ports-4353065d4497ff950eb138b9a6caee4de325b231.zip
Notes
Diffstat (limited to 'net/py-smb/Makefile')
-rw-r--r--net/py-smb/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/net/py-smb/Makefile b/net/py-smb/Makefile
new file mode 100644
index 000000000000..744140e7cc1d
--- /dev/null
+++ b/net/py-smb/Makefile
@@ -0,0 +1,37 @@
+# ex:ts=8
+# Ports collection makefile for: pysmb
+# Date created: Jan 11, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= smb
+PORTVERSION= 0.3.1
+CATEGORIES= net python
+MASTER_SITES= http://miketeo.net/projects/pysmb/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pysmb-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PYTHON= yes
+WRKSRC= ${WRKDIR}/pysmb
+NO_BUILD= yes
+
+do-install:
+.for file in nmb.py smb.py
+ ${INSTALL_SCRIPT} ${WRKSRC}/${file} ${PYTHON_SITELIBDIR}
+.endfor
+.for file in nmbquery smbcp smbdu smblistshare
+ ${INSTALL_SCRIPT} ${WRKSRC}/${file} ${PREFIX}/bin
+.endfor
+ @${MKDIR} ${PREFIX}/share/py-smb
+ ${CP} ${WRKSRC}/extra/*.reg ${PREFIX}/share/py-smb
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/py-smb
+ ${CP} ${WRKSRC}/README ${PREFIX}/share/doc/py-smb
+ ${CP} ${WRKSRC}/docs/*.html ${WRKSRC}/docs/*.gif ${PREFIX}/share/doc/py-smb
+.endif
+
+.include <bsd.port.mk>