aboutsummaryrefslogtreecommitdiff
path: root/net/py-spreadmodule
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2002-11-16 22:35:13 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2002-11-16 22:35:13 +0000
commitaaa015a1be3a03ad32b2c65e8c5e53b552496036 (patch)
treeb028bcc6b77dab6a41e2c9f432bd1cf346a9287c /net/py-spreadmodule
parent1420ecfec719ed058b8eae0a9e4199f568a270d1 (diff)
downloadports-aaa015a1be3a03ad32b2c65e8c5e53b552496036.tar.gz
ports-aaa015a1be3a03ad32b2c65e8c5e53b552496036.zip
Notes
Diffstat (limited to 'net/py-spreadmodule')
-rw-r--r--net/py-spreadmodule/Makefile7
-rw-r--r--net/py-spreadmodule/distinfo2
-rw-r--r--net/py-spreadmodule/files/patch-setup.py11
3 files changed, 16 insertions, 4 deletions
diff --git a/net/py-spreadmodule/Makefile b/net/py-spreadmodule/Makefile
index 1a01ce722ef2..7d650e83b649 100644
--- a/net/py-spreadmodule/Makefile
+++ b/net/py-spreadmodule/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= spreadmodule
-PORTVERSION= 1.2
+PORTVERSION= 1.3
CATEGORIES= net python
MASTER_SITES= http://www.python.org/other/spread/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,12 +15,13 @@ EXTRACT_SUFX= .tgz
MAINTAINER= joshua@roughtrade.net
-BUILD_DEPENDS= ${LOCALBASE}/lib/libsp.a:${PORTSDIR}/net/spread
+LIB_DEPENDS= spread.1:${PORTSDIR}/net/spread
+USE_REINPLACE= yes
USE_PYTHON= yes
USE_PYDISTUTILS=yes
post-patch:
- @${PERL} -pi -e 's,/usr/local,${PREFIX},g' ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},g' ${WRKSRC}/setup.py
.include <bsd.port.mk>
diff --git a/net/py-spreadmodule/distinfo b/net/py-spreadmodule/distinfo
index 5c7b52303db3..b30a48fb7ac6 100644
--- a/net/py-spreadmodule/distinfo
+++ b/net/py-spreadmodule/distinfo
@@ -1 +1 @@
-MD5 (SpreadModule-1.2.tgz) = dec9b45f8e3891f9afc5939932be59ac
+MD5 (SpreadModule-1.3.tgz) = c43e484f46cdd9aeac4942bdcf320c44
diff --git a/net/py-spreadmodule/files/patch-setup.py b/net/py-spreadmodule/files/patch-setup.py
new file mode 100644
index 000000000000..4146ced38b83
--- /dev/null
+++ b/net/py-spreadmodule/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py 10 Sep 2002 13:13:11 -0000 1.1.1.1
++++ setup.py 10 Sep 2002 13:14:03 -0000 1.2
+@@ -21,7 +21,7 @@
+ ext = Extension('spread', ['spreadmodule.c'],
+ include_dirs = [SPREAD_DIR + "/include"],
+ library_dirs = [SPREAD_DIR + "/lib"],
+- libraries = ['tsp'],
++ libraries = ['tspread'],
+ )
+
+ setup(name = "Spread API for Python",