aboutsummaryrefslogtreecommitdiff
path: root/net/py-twitter-tools
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-12-26 02:53:35 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2014-12-26 02:53:35 +0000
commitbc277369428c7ac3ba9268413f5f803a16fb7f5e (patch)
tree6734f5d9ab22163ed1d655dd1f05127d81861370 /net/py-twitter-tools
parentbf6d784ae7b142b79ad9ddd93bc36ca625b1f131 (diff)
Notes
Diffstat (limited to 'net/py-twitter-tools')
-rw-r--r--net/py-twitter-tools/Makefile12
-rw-r--r--net/py-twitter-tools/distinfo4
-rw-r--r--net/py-twitter-tools/files/patch-setup.py22
3 files changed, 33 insertions, 5 deletions
diff --git a/net/py-twitter-tools/Makefile b/net/py-twitter-tools/Makefile
index 1fa292985715..95707c463958 100644
--- a/net/py-twitter-tools/Makefile
+++ b/net/py-twitter-tools/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= twitter
-PORTVERSION= 1.14.1
+PORTVERSION= 1.15.0
CATEGORIES= net python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
PKGNAMESUFFIX= -tools
@@ -10,14 +10,20 @@ PKGNAMESUFFIX= -tools
MAINTAINER= koobs@FreeBSD.org
COMMENT= Python API and command-line toolset for Twitter
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:${PORTSDIR}/devel/py-nose
+
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
USES= python
USE_PYTHON= distutils autoplist
USE_GITHUB= yes
+
GH_ACCOUNT= sixohsix
-GH_PROJECT= twitter
GH_TAGNAME= ${DISTNAME}
-GH_COMMIT= 5712410
+GH_COMMIT= bb26b5d
+
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>
diff --git a/net/py-twitter-tools/distinfo b/net/py-twitter-tools/distinfo
index 735591ca8c20..3ddde18e6381 100644
--- a/net/py-twitter-tools/distinfo
+++ b/net/py-twitter-tools/distinfo
@@ -1,2 +1,2 @@
-SHA256 (twitter-1.14.1.tar.gz) = 8e20d4fe5c30d5f2d9a32b5a925a4426a8a43167b80e4e98404a05e8bb1210b6
-SIZE (twitter-1.14.1.tar.gz) = 39459
+SHA256 (twitter-1.15.0.tar.gz) = f0cf4d8ec60a26bbec9fb9a2455f037c8e47746c12e9a1bc9ce3f373014a1774
+SIZE (twitter-1.15.0.tar.gz) = 41853
diff --git a/net/py-twitter-tools/files/patch-setup.py b/net/py-twitter-tools/files/patch-setup.py
new file mode 100644
index 000000000000..fcfabc925fc8
--- /dev/null
+++ b/net/py-twitter-tools/files/patch-setup.py
@@ -0,0 +1,22 @@
+--- setup.py.orig 2014-12-26 02:42:01 UTC
++++ setup.py
+@@ -9,6 +9,10 @@ install_requires = [
+ if sys.version_info < (2,7):
+ install_requires.append('argparse')
+
++tests_require = [
++ 'nose',
++]
++
+ setup(name='twitter',
+ version=version,
+ description="An API and command-line toolset for Twitter (twitter.com)",
+@@ -39,6 +43,8 @@ setup(name='twitter',
+ include_package_data=True,
+ zip_safe=True,
+ install_requires=install_requires,
++ tests_require=tests_require,
++ test_suite = 'nose.collector',
+ entry_points="""
+ # -*- Entry points: -*-
+ [console_scripts]