aboutsummaryrefslogtreecommitdiff
path: root/net/py-twitter/Makefile
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-02-08 19:11:12 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-02-08 19:11:12 +0000
commitd28087cce34b54c8058aa56f725f867a926e9e74 (patch)
tree7389bd4cafd263aa75cd927ab0bbba0bf248d2d0 /net/py-twitter/Makefile
parent8f1a8b5762b9ae41a85d64e3546a833329fb4c28 (diff)
downloadports-d28087cce34b54c8058aa56f725f867a926e9e74.tar.gz
ports-d28087cce34b54c8058aa56f725f867a926e9e74.zip
Notes
Diffstat (limited to 'net/py-twitter/Makefile')
-rw-r--r--net/py-twitter/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/net/py-twitter/Makefile b/net/py-twitter/Makefile
index cfcda99a5178..c05209e2dc92 100644
--- a/net/py-twitter/Makefile
+++ b/net/py-twitter/Makefile
@@ -1,25 +1,22 @@
-# ex:ts=8
-# Ports collection makefile for: py-twitter
-# Date created: Apr 13, 2007
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= twitter
-PORTVERSION= 0.8.2
+PORTVERSION= 0.8.5
CATEGORIES= net python
MASTER_SITES= GOOGLE_CODE
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= python-${PORTNAME}-${PORTVERSION}
MAINTAINER= python@FreeBSD.org
-COMMENT= A python wrapper around the Twitter API
+COMMENT= Python wrapper around the Twitter API
+
+LICENSE= AL2
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}simplejson>0:${PORTSDIR}/devel/py-simplejson \
- ${PYTHON_PKGNAMEPREFIX}oauth2>0:${PORTSDIR}/net/py-oauth2
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}simplejson>0:${PORTSDIR}/devel/py-simplejson \
- ${PYTHON_PKGNAMEPREFIX}oauth2>0:${PORTSDIR}/net/py-oauth2
+ ${PYTHON_PKGNAMEPREFIX}oauth2>0:${PORTSDIR}/net/py-oauth2 \
+ ${PYTHON_PKGNAMEPREFIX}httplib2>0:${PORTSDIR}/www/py-httplib2
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PROJECTHOST= python-twitter
USE_PYTHON= yes