aboutsummaryrefslogtreecommitdiff
path: root/net/py-txamqp/Makefile
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2009-08-19 13:15:14 +0000
committerBruce M Simpson <bms@FreeBSD.org>2009-08-19 13:15:14 +0000
commit878b649c501d3128bf8f7827d539f477f7c17200 (patch)
tree4a181c475ceca16cf58e45d0e4d05a19cde3db1b /net/py-txamqp/Makefile
parent1452f36a56d08d1156373e23f08b8b7217349be4 (diff)
downloadports-878b649c501d3128bf8f7827d539f477f7c17200.tar.gz
ports-878b649c501d3128bf8f7827d539f477f7c17200.zip
Notes
Diffstat (limited to 'net/py-txamqp/Makefile')
-rw-r--r--net/py-txamqp/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/net/py-txamqp/Makefile b/net/py-txamqp/Makefile
index 96eb8f654e0b..1ddfc176f166 100644
--- a/net/py-txamqp/Makefile
+++ b/net/py-txamqp/Makefile
@@ -6,32 +6,32 @@
#
PORTNAME= txamqp
-PORTVERSION= 0.2.1
+PORTVERSION= 0.3
CATEGORIES= net python
-MASTER_SITES= http://launchpadlibrarian.net/20320545/ \
+MASTER_SITES= http://launchpadlibrarian.net/30388120/ \
# http://launchpad.net/txamqp/trunk/${PORTVERSION}/+download/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= python-${PORTNAME}-${PORTVERSION}
+DISTNAME= python-${PORTNAME}_${PORTVERSION}.orig
MAINTAINER= bms@FreeBSD.org
COMMENT= Twisted Python library for the AMQP messaging protocol
-USE_BZIP2= yes
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/thrift/__init__.py:${PORTSDIR}/devel/py-thrift
+
USE_PYTHON= 2.5+
-USE_PYDISTUTILS= yes
+USE_PYDISTUTILS= easy_install
USE_TWISTED= yes
+WRKSRC= ${WRKDIR}/python-${PORTNAME}-${PORTVERSION}
+
PYDISTUTILS_PKGNAME= txAMQP
-PYDISTUTILS_PKGVERSION= 0.2
+PYDISTUTILS_PKGVERSION= 0.3
PLIST_SUB= PORTNAME="${PORTNAME}"
-# TODO: Install AMQP spec files in a separate leaf port.
# TODO: Install txAMQP examples.
-# TODO: Build and re-introduce Thrift runtime dependencies.
-post-install:
- @${ECHO_MSG}
- @${ECHO_MSG} "Note: Thrift is not yet supported, Python bindings need fixed."
- @${ECHO_MSG}
+# Don't try to install Twisted yourself, txAMQP. thx!
+do-patch:
+ @${REINPLACE_CMD} -e '/install_requires/s/^/#/' ${WRKSRC}/setup.py
.include <bsd.port.mk>