aboutsummaryrefslogtreecommitdiff
path: root/net/py-txamqp
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2009-07-04 19:17:11 +0000
committerBruce M Simpson <bms@FreeBSD.org>2009-07-04 19:17:11 +0000
commit1e5447a9bc7f84b573166aaccc37bd3fee0f5908 (patch)
tree0167da4e73dc5607d74fa2948f45c688a4524ac9 /net/py-txamqp
parent37bb6161f08acfd9933a15742cca8ef7892ee01f (diff)
downloadports-1e5447a9bc7f84b573166aaccc37bd3fee0f5908.tar.gz
ports-1e5447a9bc7f84b573166aaccc37bd3fee0f5908.zip
Notes
Diffstat (limited to 'net/py-txamqp')
-rw-r--r--net/py-txamqp/Makefile37
-rw-r--r--net/py-txamqp/distinfo3
-rw-r--r--net/py-txamqp/pkg-descr6
-rw-r--r--net/py-txamqp/pkg-plist44
4 files changed, 90 insertions, 0 deletions
diff --git a/net/py-txamqp/Makefile b/net/py-txamqp/Makefile
new file mode 100644
index 000000000000..96eb8f654e0b
--- /dev/null
+++ b/net/py-txamqp/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: txamqp
+# Date created: 2009-07-04
+# Whom: Bruce Simpson
+#
+# $FreeBSD$
+#
+
+PORTNAME= txamqp
+PORTVERSION= 0.2.1
+CATEGORIES= net python
+MASTER_SITES= http://launchpadlibrarian.net/20320545/ \
+ # http://launchpad.net/txamqp/trunk/${PORTVERSION}/+download/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= Twisted Python library for the AMQP messaging protocol
+
+USE_BZIP2= yes
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= yes
+USE_TWISTED= yes
+
+PYDISTUTILS_PKGNAME= txAMQP
+PYDISTUTILS_PKGVERSION= 0.2
+PLIST_SUB= PORTNAME="${PORTNAME}"
+
+# TODO: Install AMQP spec files in a separate leaf port.
+# TODO: Install txAMQP examples.
+# TODO: Build and re-introduce Thrift runtime dependencies.
+
+post-install:
+ @${ECHO_MSG}
+ @${ECHO_MSG} "Note: Thrift is not yet supported, Python bindings need fixed."
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>
diff --git a/net/py-txamqp/distinfo b/net/py-txamqp/distinfo
new file mode 100644
index 000000000000..fd9fe5e0eafb
--- /dev/null
+++ b/net/py-txamqp/distinfo
@@ -0,0 +1,3 @@
+MD5 (python-txamqp-0.2.1.tar.bz2) = be9b24f0423552dcad9ff1b0385c000c
+SHA256 (python-txamqp-0.2.1.tar.bz2) = 80900586068f4ab1462f4c35e03e5d271c7def319fe83d37706ee63bd794bbd3
+SIZE (python-txamqp-0.2.1.tar.bz2) = 80530
diff --git a/net/py-txamqp/pkg-descr b/net/py-txamqp/pkg-descr
new file mode 100644
index 000000000000..97ff278e9cd7
--- /dev/null
+++ b/net/py-txamqp/pkg-descr
@@ -0,0 +1,6 @@
+This project contains all the necessary code to connect, send and
+receive messages to/from an AMQP-compliant peer or broker (Qpid,
+OpenAMQ, RabbitMQ) using Twisted. It also includes support for using
+Thrift RPC over AMQP in Twisted applications.
+
+WWW: https://launchpad.net/txamqp
diff --git a/net/py-txamqp/pkg-plist b/net/py-txamqp/pkg-plist
new file mode 100644
index 000000000000..1997b5541ede
--- /dev/null
+++ b/net/py-txamqp/pkg-plist
@@ -0,0 +1,44 @@
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/client.py
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/client.pyc
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/client.pyo
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/codec.py
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/codec.pyc
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/codec.pyo
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/connection.py
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/connection.pyc
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/connection.pyo
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/content.py
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/content.pyc
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/content.pyo
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/contrib/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/contrib/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/contrib/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/contrib/thrift.py
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/contrib/thrift.pyc
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/contrib/thrift.pyo
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/delegate.py
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/delegate.pyc
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/delegate.pyo
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/message.py
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/message.pyc
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/message.pyo
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/protocol.py
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/protocol.pyc
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/protocol.pyo
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/queue.py
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/queue.pyc
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/queue.pyo
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/spec.py
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/spec.pyc
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/spec.pyo
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/testlib.py
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/testlib.pyc
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/testlib.pyo
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/xmlutil.py
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/xmlutil.pyc
+%%PYTHON_SITELIBDIR%%/%%PORTNAME%%/xmlutil.pyo
+@dirrmtry %%PYTHON_SITELIBDIR%%/%%PORTNAME%%/contrib
+@dirrmtry %%PYTHON_SITELIBDIR%%/%%PORTNAME%%