aboutsummaryrefslogtreecommitdiff
path: root/net/pynids
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-06-29 14:03:12 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-06-29 14:03:12 +0000
commit11134ebd3d621962812a5b5160c72a0762da7704 (patch)
treec237029f4d0797fc499bb04d6d4d7e15b71bf736 /net/pynids
parent60ac8ae3bda6af217bcafe30bf907a38a15b11fd (diff)
downloadports-11134ebd3d621962812a5b5160c72a0762da7704.tar.gz
ports-11134ebd3d621962812a5b5160c72a0762da7704.zip
Notes
Diffstat (limited to 'net/pynids')
-rw-r--r--net/pynids/Makefile27
-rw-r--r--net/pynids/distinfo2
-rw-r--r--net/pynids/pkg-descr11
3 files changed, 40 insertions, 0 deletions
diff --git a/net/pynids/Makefile b/net/pynids/Makefile
new file mode 100644
index 000000000000..d1c94182367a
--- /dev/null
+++ b/net/pynids/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: pynids
+# Date created: 22 Jun 2005
+# Whom: Corey Smith
+#
+# $FreeBSD$
+#
+
+PORTNAME= pynids
+PORTVERSION= 0.5
+CATEGORIES= net python
+MASTER_SITES= http://pilcrow.madison.wi.us/pynids/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pynids-${PORTVERSION}
+DIST_SUBDIR= python
+
+MAINTAINER= corsmith@gmail.com
+COMMENT= Python interface to libnids
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_PYTHON_PREFIX= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/nidsmodule.so
+
+.include <bsd.port.mk>
diff --git a/net/pynids/distinfo b/net/pynids/distinfo
new file mode 100644
index 000000000000..f6c74f433649
--- /dev/null
+++ b/net/pynids/distinfo
@@ -0,0 +1,2 @@
+MD5 (python/pynids-0.5.tar.gz) = ae8fab78881aa60cb2d9e50c9348cf87
+SIZE (python/pynids-0.5.tar.gz) = 136808
diff --git a/net/pynids/pkg-descr b/net/pynids/pkg-descr
new file mode 100644
index 000000000000..080414348cba
--- /dev/null
+++ b/net/pynids/pkg-descr
@@ -0,0 +1,11 @@
+pynids is a python wrapper for libnids, a Network Intrusion Detection
+System library offering sniffing, IP defragmentation, TCP stream
+reassembly and TCP port scan detection. Let your own python routines
+examine (or kill) network conversations.
+
+pynids is free software, licensed under the GPL.
+
+WWW: http://pilcrow.madison.wi.us/pynids/
+
+- Corey Smith
+corsmith@gmail.com