aboutsummaryrefslogtreecommitdiff
path: root/net/pypvm
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2005-01-28 23:29:33 +0000
committerBrooks Davis <brooks@FreeBSD.org>2005-01-28 23:29:33 +0000
commit3c3ce396ec6cb391ea652c888e9fff3a7e7ded77 (patch)
treea0fbb9c9c6aa7752c1c6707fdc32bee5a461a53f /net/pypvm
parent7c9e53fd345dd7ffe5de61a2975c7a42494feaa2 (diff)
downloadports-3c3ce396ec6cb391ea652c888e9fff3a7e7ded77.tar.gz
ports-3c3ce396ec6cb391ea652c888e9fff3a7e7ded77.zip
Notes
Diffstat (limited to 'net/pypvm')
-rw-r--r--net/pypvm/Makefile42
-rw-r--r--net/pypvm/distinfo2
-rw-r--r--net/pypvm/pkg-descr9
3 files changed, 53 insertions, 0 deletions
diff --git a/net/pypvm/Makefile b/net/pypvm/Makefile
new file mode 100644
index 000000000000..123bf2788229
--- /dev/null
+++ b/net/pypvm/Makefile
@@ -0,0 +1,42 @@
+# Ports collection makefile for: pypvm
+# Date created: Wed, Jan 19 2005
+# Whom: Brooks Davis <brooks@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pypvm
+PORTVERSION= 0.94
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=${PORTNAME}
+
+MAINTAINER= brooks@FreeBSD.org
+COMMENT= PVM for Python
+
+BUILD_DEPENDS= pvm:${PORTSDIR}/net/pvm
+
+USE_PYTHON= YES
+USE_PYDISTUTILS=YES
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/pypvm.py \
+ %%PYTHON_SITELIBDIR%%/pypvm_core.so \
+ %%PYTHON_SITELIBDIR%%/pypvm.pyc \
+ %%PYTHON_SITELIBDIR%%/pypvm.pyo
+EXAMPLEFILES= master_test.py \
+ slave_test.py
+PLIST_FILES+= ${EXAMPLEFILES:S|^|%%EXAMPLESDIR%%/|}
+.if !defined(NOPORTDOCS)
+PORTDOCS= ChangeLog \
+ README
+.endif
+
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${EXAMPLEFILES:S|^|${WRKSRC}/|} ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/pypvm/distinfo b/net/pypvm/distinfo
new file mode 100644
index 000000000000..1fd4233b4af7
--- /dev/null
+++ b/net/pypvm/distinfo
@@ -0,0 +1,2 @@
+MD5 (pypvm-0.94.tar.gz) = 58fec38345a4d62712fbc59a51e4f205
+SIZE (pypvm-0.94.tar.gz) = 119658
diff --git a/net/pypvm/pkg-descr b/net/pypvm/pkg-descr
new file mode 100644
index 000000000000..b6d742bce302
--- /dev/null
+++ b/net/pypvm/pkg-descr
@@ -0,0 +1,9 @@
+pypvm is a Python module which allows interaction with the Parallel
+Virtual Machine (PVM) package. PVM allows a collection of computers
+connected by a network to serve as a single parallel computer. More
+information about the PVM package can be found at
+http://www.epm.ornl.gov/pvm.
+
+Pypvm is intended to be an educational and prototyping tool.
+
+WWW: http://pypvm.sourceforge.net/