aboutsummaryrefslogtreecommitdiff
path: root/net/pythondirector/Makefile
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-02-26 21:39:56 +0000
committerClement Laforet <clement@FreeBSD.org>2004-02-26 21:39:56 +0000
commitf012ee36b4e923252bf4d38825f681a0d16f560d (patch)
treefc6557b0476ef8b44c1a8af58921b6e47cc462f9 /net/pythondirector/Makefile
parent49cf406400afee42f43b30357ef0557115a56e21 (diff)
downloadports-f012ee36b4e923252bf4d38825f681a0d16f560d.tar.gz
ports-f012ee36b4e923252bf4d38825f681a0d16f560d.zip
Notes
Diffstat (limited to 'net/pythondirector/Makefile')
-rw-r--r--net/pythondirector/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/net/pythondirector/Makefile b/net/pythondirector/Makefile
new file mode 100644
index 000000000000..1acf189aaeed
--- /dev/null
+++ b/net/pythondirector/Makefile
@@ -0,0 +1,29 @@
+# New ports collection Makefile for: pydirector
+# Date created: Thu Feb 26
+# Whom: Clement Laforet <clement@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pydirector
+PORTVERSION= 0.0.7
+CATEGORIES= net python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pythondirector
+
+MAINTAINER= clement@FreeBSD.org
+COMMENT= A TCP load balancer written in Python
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/twisted/__init__.py:${PORTSDIR}/devel/py-twisted
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PORTDOCS= *
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>