aboutsummaryrefslogtreecommitdiff
path: root/net/qoauth
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-11-22 12:55:00 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-11-22 12:55:00 +0000
commit5898d7df5c5c0c4c33faa934a38001e755f6d900 (patch)
treeedc1328e7d68e649db202ae07c396b88869f73de /net/qoauth
parent14b67ba33b83fe27381b6547b20370f812a4da0f (diff)
- Convert to USES=qmake (and other USES while I'm here)
- Add state support - Convert LIB_DEPENDS to new style, adjust USE_QT4 components, etc. Approved by: portmgr (blanket approval)
Notes
Notes: svn path=/head/; revision=334586
Diffstat (limited to 'net/qoauth')
-rw-r--r--net/qoauth/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/net/qoauth/Makefile b/net/qoauth/Makefile
index 48bc9374a404..5fedc9b2627c 100644
--- a/net/qoauth/Makefile
+++ b/net/qoauth/Makefile
@@ -8,27 +8,20 @@ MASTER_SITES= http://files.ayoy.net/qoauth/release/${PORTVERSION}/src/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= kde@FreeBSD.org
-COMMENT= QT support for OAuth-powered network services
+COMMENT= Qt 4 support for OAuth-powered network services
-BUILD_DEPENDS+= qca-ossl>=2.0.0.b3:${PORTSDIR}/security/qca-ossl
+BUILD_DEPENDS= qca-ossl>=2.0.0.b3:${PORTSDIR}/security/qca-ossl
LIB_DEPENDS= qca.2:${PORTSDIR}/devel/qca
RUN_DEPENDS= qca-ossl>=2.0.0.b3:${PORTSDIR}/security/qca-ossl
+USES= qmake
USE_LDCONFIG= yes
USE_BZIP2= yes
-USE_QT4= corelib qtestlib network qmake_build moc_build
-HAS_CONFIGURE= yes
+USE_QT4= corelib qtestlib network moc_build
USE_OPENSSL= yes
-QMAKEFLAGS+= PREFIX=${PREFIX}
-
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's,target.path}/pkgconfig,INSTALL_PREFIX}/libdata/pkgconfig,g' \
${WRKSRC}/src/src.pro
-do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${MAKE_ENV} \
- ${QMAKE} ${QMAKEFLAGS} qoauth.pro
-
.include <bsd.port.mk>