aboutsummaryrefslogtreecommitdiff
path: root/net/qt4-network
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-04 23:30:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-04 23:30:38 +0000
commitd56984b0567867dd57ecb27fe0c508025c2426c5 (patch)
treeeb02dac4e0d7e5129ffac4c76b935a76a7e66676 /net/qt4-network
parent98813eadd27b8cd8500044af2a49b6d861809815 (diff)
downloadports-d56984b0567867dd57ecb27fe0c508025c2426c5.tar.gz
ports-d56984b0567867dd57ecb27fe0c508025c2426c5.zip
Notes
Diffstat (limited to 'net/qt4-network')
-rw-r--r--net/qt4-network/Makefile35
-rw-r--r--net/qt4-network/distinfo6
-rw-r--r--net/qt4-network/pkg-plist164
3 files changed, 112 insertions, 93 deletions
diff --git a/net/qt4-network/Makefile b/net/qt4-network/Makefile
index 11ee30764d41..3787d59404ab 100644
--- a/net/qt4-network/Makefile
+++ b/net/qt4-network/Makefile
@@ -8,7 +8,7 @@
PORTNAME= network
PORTVERSION= ${QT4_VERSION}
-PORTREVISION= 1
+PORTREVISION=0
CATEGORIES?= net ipv6
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -24,45 +24,40 @@ QT_NONSTANDARD= yes
QT_DIST= yes
HAS_CONFIGURE= yes
-USE_LDCONFIG= yes
+USE_LDCONFIG= ${PREFIX}/lib/qt4
USE_OPENSSL= yes
ALL_TARGET= first
CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
PATH=${WRKSRC}/bin:$$PATH
-EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
- --exclude '${DISTNAME}/mkspecs' --exclude '${DISTNAME}/qmake' \
- --exclude '${DISTNAME}/demos' --exclude '${DISTNAME}/examples' \
- --exclude '${DISTNAME}/src/gui' --exclude '${DISTNAME}/src/xml' \
- --exclude '${DISTNAME}/src/opengl' --exclude '${DISTNAME}/src/qt3support' \
- --exclude '${DISTNAME}/src/sql' --exclude '${DISTNAME}/src/plugins' \
- --exclude '${DISTNAME}/src/tools/moc' \
- --exclude '${DISTNAME}/src/tools/rcc' --exclude '${DISTNAME}/src/tools/uic3' \
- --exclude '${DISTNAME}/tools/assistant' --exclude '${DISTNAME}/tools/designer' \
- --exclude '${DISTNAME}/tools/linguist' --exclude '${DISTNAME}/tools/porting' \
- --exclude '${DISTNAME}/tools/qtconfig' --exclude '${DISTNAME}/tools/qvfb'
+
+DO_NOT_EXTRACT= demos doc examples mkspecs qmake tools translations \
+ src/dbus src/gui src/opengl src/phonon \
+ src/qt3support src/script src/sql src/svg src/testlib \
+ src/tools src/xml src/xmlpatterns src/3rdparty/clucene \
+ src/3rdparty/kdebase src/3rdparty/kdelibs src/3rdparty/webkit
+EXTRACT_AFTER_ARGS= | ${TAR} -xf -
+.for dne in ${DO_NOT_EXTRACT}
+EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
+.endfor
+
WRKSRC= ${WRKDIR}/${DISTNAME}/src/${PORTNAME}
CONFIGURE_WRKSRC=${WRKSRC}/../../
pre-configure:
${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
- ${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/lib|g' \
- -e 's|flat_headers.path.*|flat_headers.path=${PREFIX}/include/Qt|g' \
- -e 's|targ_headers.path.*|targ_headers.path=${PREFIX}/include/$$$$TARGET|g' \
- ${WRKSRC}/${PORTNAME}.pro ${WRKSRC}/../qt_install.pri
${MKDIR} ${WRKSRC}/../../mkspecs
${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../bin/qmake
${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../bin/moc
${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/../../bin/rcc
post-configure:
- ${REINPLACE_CMD} -e 's|${PREFIX}/lib/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
+ ${REINPLACE_CMD} -e 's|${PREFIX}/lib/qt4/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
-e 's|.*$$(QMAKE).*||g' ${WRKSRC}/Makefile
${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
-E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
-E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
- -E -e 's|(.*Cflags:.*)-I${LOCALBASE}/include |\1|g' \
- ${WRKSRC}/../../lib/pkgconfig/*Qt*
+ ${WRKSRC}/../../lib/pkgconfig/QtNetwork.pc
.include <bsd.port.mk>
diff --git a/net/qt4-network/distinfo b/net/qt4-network/distinfo
index 9451a68b5c02..0c630f09baf6 100644
--- a/net/qt4-network/distinfo
+++ b/net/qt4-network/distinfo
@@ -1,3 +1,3 @@
-MD5 (KDE/qt-x11-opensource-src-4.3.4.tar.gz) = 9499101ec54eb7b0de195b3c5e3ffa93
-SHA256 (KDE/qt-x11-opensource-src-4.3.4.tar.gz) = 8864dd80f3456be70a3be60364502a0ca3f46125b2f156860ad880ff55fcabd2
-SIZE (KDE/qt-x11-opensource-src-4.3.4.tar.gz) = 43988710
+MD5 (KDE/qt-x11-opensource-src-4.4.1.tar.gz) = b09decad252b5181f300135e3122481d
+SHA256 (KDE/qt-x11-opensource-src-4.4.1.tar.gz) = 5aca7b784fc4de3db292666490ade84cfd1810f189c089c5c2810a710993f386
+SIZE (KDE/qt-x11-opensource-src-4.4.1.tar.gz) = 108774120
diff --git a/net/qt4-network/pkg-plist b/net/qt4-network/pkg-plist
index af6ba9f40141..7f6bce343931 100644
--- a/net/qt4-network/pkg-plist
+++ b/net/qt4-network/pkg-plist
@@ -1,71 +1,95 @@
-include/Qt/QtNetwork
-include/Qt/qabstractsocket.h
-include/Qt/qauthenticator.h
-include/Qt/qftp.h
-include/Qt/qhostaddress.h
-include/Qt/qhostinfo.h
-include/Qt/qhttp.h
-include/Qt/qnetworkinterface.h
-include/Qt/qnetworkproxy.h
-include/Qt/qssl.h
-include/Qt/qsslcertificate.h
-include/Qt/qsslcipher.h
-include/Qt/qsslerror.h
-include/Qt/qsslkey.h
-include/Qt/qsslsocket.h
-include/Qt/qtcpserver.h
-include/Qt/qtcpsocket.h
-include/Qt/qudpsocket.h
-include/Qt/qurlinfo.h
-include/QtNetwork/QAbstractSocket
-include/QtNetwork/QAuthenticator
-include/QtNetwork/QFtp
-include/QtNetwork/QHostAddress
-include/QtNetwork/QHostInfo
-include/QtNetwork/QHttp
-include/QtNetwork/QHttpHeader
-include/QtNetwork/QHttpRequestHeader
-include/QtNetwork/QHttpResponseHeader
-include/QtNetwork/QIPv6Address
-include/QtNetwork/QNetworkAddressEntry
-include/QtNetwork/QNetworkInterface
-include/QtNetwork/QNetworkProxy
-include/QtNetwork/QSsl
-include/QtNetwork/QSslCertificate
-include/QtNetwork/QSslCipher
-include/QtNetwork/QSslError
-include/QtNetwork/QSslKey
-include/QtNetwork/QSslSocket
-include/QtNetwork/QTcpServer
-include/QtNetwork/QTcpSocket
-include/QtNetwork/QUdpSocket
-include/QtNetwork/QUrlInfo
-include/QtNetwork/Q_IPV6ADDR
-include/QtNetwork/QtNetwork
-include/QtNetwork/qabstractsocket.h
-include/QtNetwork/qauthenticator.h
-include/QtNetwork/qftp.h
-include/QtNetwork/qhostaddress.h
-include/QtNetwork/qhostinfo.h
-include/QtNetwork/qhttp.h
-include/QtNetwork/qnetworkinterface.h
-include/QtNetwork/qnetworkproxy.h
-include/QtNetwork/qssl.h
-include/QtNetwork/qsslcertificate.h
-include/QtNetwork/qsslcipher.h
-include/QtNetwork/qsslerror.h
-include/QtNetwork/qsslkey.h
-include/QtNetwork/qsslsocket.h
-include/QtNetwork/qtcpserver.h
-include/QtNetwork/qtcpsocket.h
-include/QtNetwork/qudpsocket.h
-include/QtNetwork/qurlinfo.h
-lib/libQtNetwork.la
-lib/libQtNetwork.prl
-lib/libQtNetwork.so
-lib/libQtNetwork.so.4
-lib/libQtNetwork.so.4.3
-lib/libQtNetwork.so.4.3.4
-%%DEBUG%%lib/libQtNetwork.so.4.3.4.debug
+include/qt4/Qt/QtNetwork
+include/qt4/Qt/qabstractsocket.h
+include/qt4/Qt/qauthenticator.h
+include/qt4/Qt/qftp.h
+include/qt4/Qt/qhostaddress.h
+include/qt4/Qt/qhostinfo.h
+include/qt4/Qt/qhttp.h
+include/qt4/Qt/qlocalserver.h
+include/qt4/Qt/qlocalsocket.h
+include/qt4/Qt/qnetworkaccessmanager.h
+include/qt4/Qt/qnetworkcookie.h
+include/qt4/Qt/qnetworkinterface.h
+include/qt4/Qt/qnetworkproxy.h
+include/qt4/Qt/qnetworkreply.h
+include/qt4/Qt/qnetworkrequest.h
+include/qt4/Qt/qssl.h
+include/qt4/Qt/qsslcertificate.h
+include/qt4/Qt/qsslcipher.h
+include/qt4/Qt/qsslconfiguration.h
+include/qt4/Qt/qsslerror.h
+include/qt4/Qt/qsslkey.h
+include/qt4/Qt/qsslsocket.h
+include/qt4/Qt/qtcpserver.h
+include/qt4/Qt/qtcpsocket.h
+include/qt4/Qt/qudpsocket.h
+include/qt4/Qt/qurlinfo.h
+include/qt4/QtNetwork/QAbstractSocket
+include/qt4/QtNetwork/QAuthenticator
+include/qt4/QtNetwork/QFtp
+include/qt4/QtNetwork/QHostAddress
+include/qt4/QtNetwork/QHostInfo
+include/qt4/QtNetwork/QHttp
+include/qt4/QtNetwork/QHttpHeader
+include/qt4/QtNetwork/QHttpRequestHeader
+include/qt4/QtNetwork/QHttpResponseHeader
+include/qt4/QtNetwork/QIPv6Address
+include/qt4/QtNetwork/QLocalServer
+include/qt4/QtNetwork/QLocalSocket
+include/qt4/QtNetwork/QNetworkAccessManager
+include/qt4/QtNetwork/QNetworkAddressEntry
+include/qt4/QtNetwork/QNetworkCookie
+include/qt4/QtNetwork/QNetworkCookieJar
+include/qt4/QtNetwork/QNetworkInterface
+include/qt4/QtNetwork/QNetworkProxy
+include/qt4/QtNetwork/QNetworkReply
+include/qt4/QtNetwork/QNetworkRequest
+include/qt4/QtNetwork/QSsl
+include/qt4/QtNetwork/QSslCertificate
+include/qt4/QtNetwork/QSslCipher
+include/qt4/QtNetwork/QSslConfiguration
+include/qt4/QtNetwork/QSslError
+include/qt4/QtNetwork/QSslKey
+include/qt4/QtNetwork/QSslSocket
+include/qt4/QtNetwork/QTcpServer
+include/qt4/QtNetwork/QTcpSocket
+include/qt4/QtNetwork/QUdpSocket
+include/qt4/QtNetwork/QUrlInfo
+include/qt4/QtNetwork/Q_IPV6ADDR
+include/qt4/QtNetwork/QtNetwork
+include/qt4/QtNetwork/qabstractsocket.h
+include/qt4/QtNetwork/qauthenticator.h
+include/qt4/QtNetwork/qftp.h
+include/qt4/QtNetwork/qhostaddress.h
+include/qt4/QtNetwork/qhostinfo.h
+include/qt4/QtNetwork/qhttp.h
+include/qt4/QtNetwork/qlocalserver.h
+include/qt4/QtNetwork/qlocalsocket.h
+include/qt4/QtNetwork/qnetworkaccessmanager.h
+include/qt4/QtNetwork/qnetworkcookie.h
+include/qt4/QtNetwork/qnetworkinterface.h
+include/qt4/QtNetwork/qnetworkproxy.h
+include/qt4/QtNetwork/qnetworkreply.h
+include/qt4/QtNetwork/qnetworkrequest.h
+include/qt4/QtNetwork/qssl.h
+include/qt4/QtNetwork/qsslcertificate.h
+include/qt4/QtNetwork/qsslcipher.h
+include/qt4/QtNetwork/qsslconfiguration.h
+include/qt4/QtNetwork/qsslerror.h
+include/qt4/QtNetwork/qsslkey.h
+include/qt4/QtNetwork/qsslsocket.h
+include/qt4/QtNetwork/qtcpserver.h
+include/qt4/QtNetwork/qtcpsocket.h
+include/qt4/QtNetwork/qudpsocket.h
+include/qt4/QtNetwork/qurlinfo.h
+lib/qt4/libQtNetwork.la
+lib/qt4/libQtNetwork.prl
+lib/qt4/libQtNetwork.so
+%%DEBUG%%lib/qt4/libQtNetwork.so.4.4.1.debug
+lib/qt4/libQtNetwork.so.4
+lib/qt4/libQtNetwork.so.4.4
+lib/qt4/libQtNetwork.so.4.4.1
libdata/pkgconfig/QtNetwork.pc
-@dirrm include/QtNetwork
+@dirrm include/qt4/QtNetwork
+@dirrmtry include/qt4/Qt
+@dirrmtry include/qt4