aboutsummaryrefslogtreecommitdiff
path: root/net/qt5-network
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2018-05-12 18:04:45 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2018-05-12 18:04:45 +0000
commit2d6132fc21deaa9507de284cd7331092161a2d93 (patch)
tree41217f87b5412364de8a4275c9e7acba3fc877be /net/qt5-network
parentb057adf3e18d99dead826a6e1f83e3e574cdb914 (diff)
downloadports-2d6132fc21deaa9507de284cd7331092161a2d93.tar.gz
ports-2d6132fc21deaa9507de284cd7331092161a2d93.zip
Notes
Diffstat (limited to 'net/qt5-network')
-rw-r--r--net/qt5-network/Makefile2
-rw-r--r--net/qt5-network/files/patch-src_network_ssl_qsslsocket__openssl.cpp20
-rw-r--r--net/qt5-network/files/patch-src_network_ssl_qsslsocket__openssl__symbols__p.h16
3 files changed, 4 insertions, 34 deletions
diff --git a/net/qt5-network/Makefile b/net/qt5-network/Makefile
index 0cdcdd37c01d..b0425a593ea4 100644
--- a/net/qt5-network/Makefile
+++ b/net/qt5-network/Makefile
@@ -2,7 +2,7 @@
PORTNAME= network
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net ipv6
PKGNAMEPREFIX= qt5-
diff --git a/net/qt5-network/files/patch-src_network_ssl_qsslsocket__openssl.cpp b/net/qt5-network/files/patch-src_network_ssl_qsslsocket__openssl.cpp
deleted file mode 100644
index 7c24c88a0745..000000000000
--- a/net/qt5-network/files/patch-src_network_ssl_qsslsocket__openssl.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
-* check macro is defined instead of version, LibreSSL < 2.5 doesn't have SSL_CTRL_GET_SERVER_TMP_KEY
-*
---- src/network/ssl/qsslsocket_openssl.cpp.orig 2016-12-01 08:17:04 UTC
-+++ src/network/ssl/qsslsocket_openssl.cpp
-@@ -1587,13 +1587,13 @@ void QSslSocketBackendPrivate::continueH
- }
- #endif // OPENSSL_VERSION_NUMBER >= 0x1000100fL ...
-
--#if OPENSSL_VERSION_NUMBER >= 0x10002000L
-+#if defined(SSL_CTRL_GET_SERVER_TMP_KEY)
- if (q_SSLeay() >= 0x10002000L && mode == QSslSocket::SslClientMode) {
- EVP_PKEY *key;
- if (q_SSL_get_server_tmp_key(ssl, &key))
- configuration.ephemeralServerKey = QSslKey(key, QSsl::PublicKey);
- }
--#endif // OPENSSL_VERSION_NUMBER >= 0x10002000L ...
-+#endif // defined(SSL_CTRL_GET_SERVER_TMP_KEY)
-
- connectionEncrypted = true;
- emit q->encrypted();
diff --git a/net/qt5-network/files/patch-src_network_ssl_qsslsocket__openssl__symbols__p.h b/net/qt5-network/files/patch-src_network_ssl_qsslsocket__openssl__symbols__p.h
index 28e401e27b7d..4d204c734efe 100644
--- a/net/qt5-network/files/patch-src_network_ssl_qsslsocket__openssl__symbols__p.h
+++ b/net/qt5-network/files/patch-src_network_ssl_qsslsocket__openssl__symbols__p.h
@@ -1,7 +1,4 @@
-* Boilerplate for SSL_CTX_set1_groups() used in qsslcontext_openssl.cpp
-*
-* check macro is defined instead of version, LibreSSL < 2.5 doesn't have SSL_CTRL_GET_SERVER_TMP_KEY
-*
+Boilerplate for SSL_CTX_set1_groups() used in qsslcontext_openssl.cpp.
--- src/network/ssl/qsslsocket_openssl_symbols_p.h.orig 2018-01-16 06:53:43 UTC
+++ src/network/ssl/qsslsocket_openssl_symbols_p.h
@@ -228,7 +228,7 @@ int q_BIO_read(BIO *a, void *b, int c);
@@ -13,7 +10,7 @@
int q_BN_is_word(BIGNUM *a, BN_ULONG w);
#else
// BN_is_word is implemented purely as a
-@@ -511,11 +511,14 @@ void q_EC_KEY_free(EC_KEY *ecdh);
+@@ -511,6 +511,9 @@ void q_EC_KEY_free(EC_KEY *ecdh);
size_t q_EC_get_builtin_curves(EC_builtin_curve *r, size_t nitems);
#if OPENSSL_VERSION_NUMBER >= 0x10002000L
int q_EC_curve_nist2nid(const char *name);
@@ -22,11 +19,4 @@
+#endif // defined(LIBRESSL_VERSION_NUMBER)
#endif // OPENSSL_VERSION_NUMBER >= 0x10002000L
#endif // OPENSSL_NO_EC
--#if OPENSSL_VERSION_NUMBER >= 0x10002000L
-+#if defined(SSL_CTRL_GET_SERVER_TMP_KEY)
- #define q_SSL_get_server_tmp_key(ssl, key) q_SSL_ctrl((ssl), SSL_CTRL_GET_SERVER_TMP_KEY, 0, (char *)key)
--#endif // OPENSSL_VERSION_NUMBER >= 0x10002000L
-+#endif // defined(SSL_CTRL_GET_SERVER_TMP_KEY)
-
- // PKCS#12 support
- int q_PKCS12_parse(PKCS12 *p12, const char *pass, EVP_PKEY **pkey, X509 **cert, STACK_OF(X509) **ca);
+ #if OPENSSL_VERSION_NUMBER >= 0x10002000L